1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Device List Broken

Discussion in 'Tomato Firmware' started by krux01, Nov 27, 2008.

  1. krux01

    krux01 LI Guru Member

    After updating to 1.22 my device list no longer shows the hostname for devices that have static dhcp setup. I have cleared nvram which did not fix. Is anyone else having this problem or have any suggestions?
  2. peyton

    peyton LI Guru Member

    I had the same.
    I think it's not shown as your devices are not running.
  3. mstombs

    mstombs Network Guru Member

    No problem here with 1.22.

    If the devices haven't requested a new IP address by dhcp since upgrade or communicated with the router in last 5 minutes (arp table refresh time) then I think the router doesn't know the devices are online.
  4. spicoli

    spicoli LI Guru Member

    Everything got new IPs on my end. but I have DCHP so I guess thats why, even though it was the same for a looooooooooooooooooooong time (+2 years).
  5. bripab007

    bripab007 Network Guru Member

    My device list appears to work in the same capacity as it has since, oh, at least v1.15 (as far back as I've been using Tomato).
  6. krux01

    krux01 LI Guru Member

    The device which are no longer showing have statically assigned addresses. I put them in the static dhcp section for dnsmasq to acknowledge them. Is this correct?
  7. fyellin

    fyellin LI Guru Member

    You are seeing correct behavior and you are doing the right thing.

    On the Static DHCP page, you only need to enter the MAC address if you intend for the router to tell the device its (static) IP address. If you leave the MAC address as 00:00:00:00:00:00, its sole purpose is to help out dnsmasq.

Share This Page