1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Did my WRT54G v1 'go bad'?

Discussion in 'Cisco/Linksys Wireless Routers' started by mehron, Jul 5, 2006.

  1. mehron

    mehron LI Guru Member

    My connection speed through my router (wired and wireless) recently has been excruciatingly slow speeds (think 56k modem). I think the decline was gradual and I don't know when this started, but the speed through my cable modem is fine.

    These are the things I have checked or done:

    Reset
    hard reset
    change channel
    change password
    upgrade to current firmware
    check for other users


    Is there anything else that i should try?

    Can these things go bad?
     
  2. Toxic

    Toxic Administrator Staff Member

    power supplies can fade, but on the whole they usually either work or they dont. (ie brick)

    have you tried replacing your cables?

    do you have another PC to test it, incase a virus or trojan is slowing down you PC's net connection
     
  3. mehron

    mehron LI Guru Member

    Thanks for the help.

    The strange thing is that the speed for my connection is fine when run straight from the cable modem.

    Once I go through the router, the speed is terrible. I also forgot to mention that it seems as if only download speed is affected rather than upload (based on some speed tests).

    There must be a setting that I need to tweak, but I don't think anything has been changed on the router.
     
  4. Toxic

    Toxic Administrator Staff Member

    what firmware version you running now?
     
  5. mehron

    mehron LI Guru Member

    I'm now running the latest download. It is 4.30.5

    I'm going to try to test it at another location now so I can swap wires with another one.
     
  6. phecksel

    phecksel LI Guru Member

    I can't answer your specific question, but will suggest if you do nothing else to begin looking for a replacement power supply. I discovered too late that V1 routers have defective power supplys and fought with V6 for a few days before finally returning it and buying a GL unit. I have noticed a substantial improvement in wireless speed from the V1 to the GL (with WRT 23.1 installed).
     

Share This Page