dispatch protocol error: type 20 plen 334

Discussion in 'Tomato Firmware' started by royrapoport, Dec 27, 2006.

  1. royrapoport

    royrapoport LI Guru Member

    I just received my WRT54gl yesterday and immediately put tomato (latest) on it.

    It works like a dream, except that every once in a while I get
    dispatch protocol error: type 20 plen 334

    when logged in via ssh, and my ssh session dies.

    any idea what this means?
     
  2. digitalgeek

    digitalgeek Network Guru Member

    did you clear nvram w/defaults after the flash?
     
  3. BeHappy

    BeHappy Network Guru Member

  4. royrapoport

    royrapoport LI Guru Member

    I agree it's related to SSH usage, but I'm not sure that URL fits what we have here -- I'm using OpenSSH for the client, and the solution documented is for when you're using the commercial SSH client.
     
  5. BeHappy

    BeHappy Network Guru Member

    Take a look on your client ssh program and turn of rekeying in SSH2: set RekeyIntervalSeconds to 0 (in ~/.ssh2/ssh2_config for the client).
     
  6. bokh

    bokh Network Guru Member

    More information please

    - What version of OpenSSH are you using?
    - Any anomalies in $HOME/.ssh/config or /etc/ssh/ssh*_config?
    - On what platform (Linux, *BSD)?

    I use OpenSSH_4.2p1 (both on FreeBSD and Mac OS X 10.4.8) and they never cause any errors of any kind.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice