1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

dlna (media) server seems to hang w/ toastman build

Discussion in 'Tomato Firmware' started by o0enygma0o, Mar 8, 2012.

  1. o0enygma0o

    o0enygma0o Networkin' Nut Member

    I am running Tomato Firmware v1.28.7496 MIPSR2-Toastman-RT K26 USB VPN on an E3000. I had this problem with an earlier version, so I did a fresh install & upgrade recently. The first time I ran the media server, everything seemed to scan just fine. I re-organized a few directories and re-scanned, and it seems to hang again. The config page still says "Scan in Progress" after a very long time (much much longer than it took to scan the first time). If I do a top, it it shows that minidlna is running at 0%. If I run top while I restart the server it runs around 10% memory and 90% CPU, give or take, for less than a minute before dropping to 0%. If I access the server from my ps3 it just shows a few files and nothing more.

    Is there any way to set up logging with minidlna so that it throws some error messages when it hangs? Has anyone here experienced this? Any other thoughts or tips?

    Edit: just tried killall minidlna, then minidlna -f /etc/minidlna.conf -R and it worked perfectly. Scanned everything in a minute or two. any thoughts on why it might work from the command line and not the web config?

Share This Page