1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

dropbear logging

Discussion in 'Tomato Firmware' started by jan.n, Oct 15, 2009.

  1. jan.n

    jan.n Addicted to LI Member


    when I log in via ssh from remote, dropbear logs the following:
    Date Time IP dropbear[3168]: pubkey auth succeeded for 'root' with key md5 aa:bb:cc... from IP:port
    I'm unsure, but some time ago there was an additional line above each "login log" saying something like
    child connection from xx.yy.xx.yy.
    Why isn't this line logged anymore?
  2. rhester72

    rhester72 Network Guru Member

    Dropbear has been updated quite a few times as newer Tomato builds have come out, it was likely removed in a more recent Dropbear update.

  3. jan.n

    jan.n Addicted to LI Member

    Good thought, but I've always used vanilla Tomato 1.25, so the dropbear version has not changed...

    Edit: Attached a picture of my logging settings.
    2nd Edit: Can someone please explain the nvram log settings in detail?
    # nvram show|grep log

    Attached Files:

  4. jan.n

    jan.n Addicted to LI Member

    One step further:
    I searched the dropbear sources and found the corresponding message in svr-main.c:
    dropbear_log(LOG_INFO, "Child connection from %s", addrstring);
    That leads me to thinking that I should somehow change the loglevel, so that events with level LOG_INFO get logged.
    Ideas how to do that?
  5. mstombs

    mstombs Network Guru Member

  6. jan.n

    jan.n Addicted to LI Member

    Yeah but isn't the "console log level" something else? IMHO the "console log level" decides that kernel messages get logged to the _console_...

    I wanted to test that: I changed "console_loglevel" to 6 and did a "service syslog restart" but nothing changed...
  7. Toastman

    Toastman Super Moderator Staff Member Member

    I'm also interested in the logging details, because one of my systems has suddenly stopped logging DHCP and association tries, very important for me to debug user problems. I'm trying to reinstate it, but nothing seems to change the logging levels. Is there anywhere I should be looking for help with this?
  8. jan.n

    jan.n Addicted to LI Member

    I recently tried to set the console loglevel to something other than the default - nothing happend at all, no changes in the logs...
  9. jan.n

    jan.n Addicted to LI Member

    Just FYI: All of a sudden the "child connection from" reappeared in my logs. I did not change the config, nor did I reboot, nor anything else.
    Kinda strange...

Share This Page