1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

DynDNS in Tomato returning errors

Discussion in 'Tomato Firmware' started by Groovely, Oct 28, 2009.

  1. Groovely

    Groovely Addicted to LI Member

    First post, but have tried reading around, and asking elsewhere and can't seem to find answers. I'm hoping someone might be willing to help.

    I tried setting up DynDNS within Tomato 1.26 (on WRT54G). I have the following settings in the GUI:

    • Service (dropdown): DynDNS - Dynamic
    • UN: [my DynDNS username]
    • PW: [my DynDNS Password]
    • Hostname: custom.chosenURL.net
    • Wildcard: [unchecked]
    • MX: [Blank; no idea what this does]
    • BackupMX: [Unchecked]
    • Save state When IP Changes (NVRAM commit): [Checked]

    I tried asking on the DynDNS forum first, since I'm new at this and though it could be account settings, and according to them what I've inputted into Tomato seems reasonable.

    However, I'm still getting this error:

    Last Result: Wednesday October 28, 01:17:20 GMT-0400 2009:
    Invalid hostname.
    (1/3: Automatically retrying in 16 minutes)


    Forcing update doesn't change it. Can anyone tell me what I might be doing wrong? Sorry if it's some newbie error, but I really have tried looking around and solving it myself before posting.

    Thanks in advance.
     
  2. rhester72

    rhester72 Network Guru Member

    Have you already defined customer.chosenURL.net on the DynDNS site prior to trying to update from Tomato? The error you are getting suggests that DynDNS has no record of the hostname you're trying to update DNS for.

    Rodney
     
  3. Groovely

    Groovely Addicted to LI Member

    Thanks Rodney.

    Yes, I've already defined it on DynDNS, and verified that my login information is correct. When I login to DynDNS, this hostname is listed under MyServices exactly as I inputted it into Tomato.

    Any ideas on what else might be wrong or another way I could try to find more info on what the router is thinking/lacking?

    Thanks again,
    ~G.
     
  4. rhester72

    rhester72 Network Guru Member

    Try doing the same thing manually with wget (Google for using wget with DynDNS) from a dedicated host and see what you get - if it's the same error, it's not a Tomato issue. There isn't much debugging to go on in Tomato, but if you can reproduce outside that environment, it should be fairly straightforward to determine what's going on.

    Rodney
     
  5. beanie1984

    beanie1984 Addicted to LI Member

    Your setup looks correct. I've seen this error before, and it's usually something simple I've mis-configured. I just re-did my own DynDNS setup, and the service is working fine.

    I'd double-check these things:
    1. Re-enter your username/password/Hostname. Ensure there are no spaces or special characters, and verify capitalization.
    2. Do you have a public IP? I think DynDNS will take a 192.168.x.x, but it could be a factor.
    3. Check that your hostname is setup as "Host with IP address" in DynDNS.
    4. You could try to create another hostname, esp. on another domain to rule out that variable.
     
  6. TexasFlood

    TexasFlood Network Guru Member

    Looks exactly like my setup that has been working fine for some time. For the host name, I just put in the fully qualified name just as I would use it to access my computer from another location. For example, if my "host name" was texasflood and it was in the homeip.net domain, I would enter texasflood.homeip.net. The error message sounds like somehow whatever you entered here is not matching what is in your opendns account.
     
  7. Groovely

    Groovely Addicted to LI Member

    Thanks for the help! This is what it turned out to be. I had set it up initially to use WebHop, because I was following a tutorial that was recommended to me in the PulpTunes forums. Once I set it to "Host with IP" it updated fine.

    As a sidenote, I did like the ability to cloak and choose a title for the cloaked page. I'm using this to host a music server via PulpTunes and it normally just says "PulpTunes" on the tab, whereas I could put my library title using the cloak option. However, I figured by combining two DynDNS hosts I could get the best of both worlds.

    Now account #1 WebHop's (while applying my library to the page title) to account #2 which is in communication with my router to update my IP should it change.

    It seems to work, and hopefully it sounds reasonable (even if a little unnecessary). Sorry if my issue turned out to be newbesque and thanks again to all those who wrote back to help. I really appreciate it.

    ~G.
     

Share This Page