1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

EA6700 forgets configuration on reboot?

Discussion in 'Tomato Firmware' started by Fritoeata, Jul 10, 2017.

  1. Fritoeata

    Fritoeata Network Newbie Member

    I have a EA6700. I got it for cheap. I'm running the latest 140 build.
    I love it!... but.
    After I get everything to my liking and reboot it (I disable the 5g, and only use the 2.4g), The 5ghz turns on and becomes eth1, and 2.4ghz radio is not available to see at all. I've tried to save my configurations before I reboot, then restore them... the same problem occurs!

    ...It becomes a real hassle when I only access it via wifi, and I have no 5g devices so I need to dig out my cat5 and sprawl across the floor with my desktop to get the internet to work. I've done this about 5 times. I'm starting to hate it.

    My best guesses are:
    1. That I need to auto script something that runs before or after reboot. (please help!)
    2. That I need to figure out how to telnet into this thing and wakeup the 2.4 radio. (please help!)
    3. BOTH!!

    Thank you VERY much for reading this!
    Regards,
    Frito

    Note: I am not dumb, but I don't know the correct commands, and I could use some basic explanations from a gracious veteran. I will read and learn from every single word you type... trust me!
     
    joaso1 likes this.
  2. Fritoeata

    Fritoeata Network Newbie Member

    I believe this to be some sort of bug somewhere...
    see screencaps.
    Thank you!
    Frito
    Before reboot: 2.4g=eth1, 5g(disabled)=eth2
    [​IMG]
    After reboot: 5g(enebled)=eth1, 2.4=???
    [​IMG]
     
  3. roberthuang

    roberthuang Reformed Router Member

    Fritoeata likes this.
  4. Fritoeata

    Fritoeata Network Newbie Member

    Thank you very much roberthuang!
    I shall see what I can do about fixing or simply living with it.

    Frito
     
  5. Jose C

    Jose C Serious Server Member

    I have the same problem on ea6500v2, since is the same hardware it suffer from the same issue. I have learned to live with it, make sure to delete all information not needed, for example port forwarding examples.


    Sent from my iPhone using Tapatalk
     
    Fritoeata likes this.
  6. iv7777

    iv7777 Connected Client Member

    Flash the XVortex's or Koolshare's CFE will solve the 32k nvram bug. I have EA6300 and EA6700 with XVortex CFE and they both work like a charm in Tomato ARM. If you are on tomato already, i guess you have to flash back to DD-WRT first and then ssh into it to flash the CFE because tomato doesn't have mtd utility in there(at least i couldn't find one myself).Very important! make sure to pick the CFE with the right nvram variables for your router's model number. If accidentally flash CFE with the wrong variables(such as EA6300) into EA6700 would brick your router.
    After successfully flashed the new CFE, unplug the router's power cord and then, while holding the blue button(not the reset button), plug the power cord back in, wait till the light on the front panel flashes, release the button. Wait about a couple minute for it to boot up, you are good to go :)
     
    Fritoeata likes this.
  7. Fritoeata

    Fritoeata Network Newbie Member

    Could you briefly tell me how you accomplished the CFE flash?
    ...I cannot see how to get a good DD-WRT build specifically for the EA6700.
    Would this be worth trying?
    https://www.linkedin.com/pulse/flashing-cisco-ea6700-router-dd-wrt-ruben-faelens

    I appreciate the tips and advice.

    Frito
     
  8. iv7777

    iv7777 Connected Client Member

    I've never winded up in a situation like yours. So I probably cannot give your advice about how to get back to DD-WRT when the webgui doesn't work. All I know is getting back to DD-WRT is an easy way for me to flash the CFE. Search the forum you should be able to find the Xvortex CFE with 6700 variables in it. Make sure to edit the mac correctly and save the CFE. Once in DD-WRT and ssh into it, upload the CFE file(ie. cfe_ea6700.bin) to /tmp and use the following command to flash then reboot.
    If the flash went correctly, you should be able to see your router work very nice and stable ever since. I have very good experience using this router with Tomato AT 3.4, Shibby 140 and the custom firmware compiled by myself. Remember to follow the correct procedure to use the blue button to reset the NVRAM after the flash. That's it. good luck.
    Code:
    mtd unlock /dev/mtd0
    mtd write -f /tmp/cfe_ea6700.bin /dev/mtd0
    reboot
    
     
    Last edited: Jul 20, 2017
    Fritoeata likes this.
  9. marcbkk

    marcbkk Reformed Router Member

    Frito, if you are still looking for a DD-WRT specifically for the EA6700, you can download the latest beta build here:

    http://www.dd-wrt.com/site/support/other-downloads?path=betas/2017/07-19-2017-r32753/linksys-ea6700/

    If you rather have an older build version, just click on that link first, then click on the link next to Path in blue where it says "betas". Then you can choose by year and then date to find any older builds you might be looking for.

    It seems all the builds are betas and the latest one is dated July 19th of this year and that is the one I linked for you above.

    I haven't tested any of these though myself since I haven't received my EA6700 yet, but iv7777 told me in another post that he used the b23598 DD-WRT build to flash his CFE.

    I am not sure what date that build was made, but it is also probably somewhere in all those beta builds if you would like to try and find it and then use that one knowing it worked for him.

    I hope that helps.
     
    Fritoeata likes this.
  10. marcbkk

    marcbkk Reformed Router Member

    @Fritoeata - If you still want to flash your CFE, you may want to read the two following threads. The first one is very good as it is a how-to post showing pictures and step by step on how to flash your CFE. It was written for flashing a EA6900, but the steps for the EA6700 should be the same. The second post is a discussion I have been having with iv7777, who has been very very helpful, preparing me to flash my EA6700 when I receive it.

    http://www.linksysinfo.org/index.ph...-linksys-ea6900-supports-tomato-dd-wrt.71718/

    http://www.linksysinfo.org/index.ph...0-with-re6400-range-extender-on-tomato.73655/

    Our discussion on the second link above is a bit long (because I write a lot of detail), but it is worth reading through to make sure you don't make any mistakes along the way.

    You will need to download a couple of free programs if you don't have them already, which are Putty and WinSCP. You will also need the EA6700 CFE file to flash with (there are many versions out there, but I am going to use the one iv7777 gave me) and the CFEEdit tool. I have zipped up all 4 items on a single ZIP file if you want them and you can download them here: https://mega.nz/#!ktZjjSrQ!hJvcOfKd2t5Ijy0AWS1qSIC2TM2pimUsG53Rl8FXo-s

    One note when you are reading the post about flashing the EA6900 is that he doesn't tell you to clear the Nvram after you flash your CFE. So be sure to add that in. Also, you will need to edit the Mac Address in the EA6700 CFE bin file provided in the ZIP file using the CFEEdit tool. But you can read about that in my discussion with iv7777.

    Hopefully I will receive my EA6700 in about 10-12 days and, if I am able to do mine successfully, then I will be able to help with any other questions after that. Also, iv7777 can of course help too as he has much more experience with it and has done it successfully already.
     
    Fritoeata likes this.
  11. Fritoeata

    Fritoeata Network Newbie Member

    @marcbkk,
    Thanks so much for the comprehensive reply! Just yesterday I tried pinging in (static IP, direct connection, and all others disabled) and I got nothing. I power cycled, and the lights never came back on.
    ...Bricked.
    So, I got angry for a few minutes (yelling+screaming) then packed it up and returned it to Walmart(I bought the combo kit). Now I'm using my ISP's rental (Time Warner/Spectrum). I will return, however... I just need to find a new target router. I have DL'd your links and posts above.

    The thing is, I really liked the router!! The specs on this SOC were awesome, and I ALMOST(!!!!) had it!

    I look forward to learning, if you would do me the favor of chronicling what you've done.
     
  12. marcbkk

    marcbkk Reformed Router Member

    So sorry to hear you bricked it, but also glad to hear your heartaches are now over.

    As for me, my troubles might just be starting as I haven't received mine yet. Picked it up cheap online and still waiting for it to arrive. When I bought it though I wasn't aware of the Nvram bug or I might have taken another route to begin with.

    I do like to tinker with things, so I am not so put off by what I must to do get it working, but if I also end up bricking mine somehow, or I can't get the CFE to flash properly, then I will probably purchase an Asus RT-AC66U at that point.

    The Asus is also dual band and an AC1750 unit, so it runs at the same speed as the EA6700. It is about 3 times the price of the EA6700 I purchased though, but it is also a really good unit and should be easy to flash directly with Advanced Tomato and without lots of drama. If you don't mind to pay a bit more, then that would be the way to go.

    Otherwise, if you still feel adventurous, now that you have enough information and all the tools to do it right, you could get another EA6700 from Walmart and try it all again, starting with flashing it with DD-WRT, then the CFE flash, and finally with an Advanced Tomato flash. But if you are not that much of a glutton for punishment then I don't blame you.

    I will let you know though how I make out when mine comes and if I am successful or not. ;)
     
    Fritoeata likes this.

Share This Page