1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Extremely long boot times on RT-N16 with Shibby

Discussion in 'Tomato Firmware' started by gijs73, Dec 7, 2012.

  1. gijs73

    gijs73 LI Guru Member

    I've just got a new RT-N16 and installed the latest Shibby firmware on it (tomato-K26USB-1.28.RT-MIPSR2-104-AIO.trx). The problem is that it takes up to 10 minutes to boot.

    Immediately on start the Power, LAN and WAN LEDs light up. Every minute or two the power LED goes dark for several seconds, after which is turns on again. The LAN and WAN lights continue blinking rapidly all the time. Eventually, after multiple cycles the wireless LED lights up and the router finishes booting.

    During the boot process (before the wireless LED turns on) dhcp is not working. I tried setting the ip address manually on my computer, but I still can't access the router before it's finished (neither ping nor ssh nor http work).

    As you can see in the log, it only shows the last few minutes. To me it looks like every time the Power LED goes dark - the router is restarting, for whatever reason. Any idea why? Is there any way to keep persistent log that'll survive the reboot and see what causes the problem?
     

    Attached Files:

  2. koitsu

    koitsu Network Guru Member

    No, there is no way to retain the log.

    I don't see anything indicative in the router log of a problem. The December 31st date is due to the router not having a CMOS clock, thus it has no concept of what time it is when it restarts (hence the need for a working network connection + NTP sync).

    When you switched to this firmware, did you perform a thorough NVRAM erase after upgrading? If not, please do that first. Please do not use the backup/restore config option either -- that will just reintroduce NVRAM variables that may be causing problems.

    Finally, please provide here a very thorough/verbose explanation of every setting you change in the router GUI (i.e. every setting you change after resetting to factory defaults). There may be some feature which you're using that may have a bug.
     
  3. gijs73

    gijs73 LI Guru Member

    Yeah, I figured that much.

    Yes, I did.

    As far as I can remember, the problem was present immediately after flashing. I even was afraid that I flashed incorrectly, because it wasn't doing anything except blinking LEDs for more than 5 minutes. I'm going to reset nvram again later today and see if the problem remains.
     
  4. alfred

    alfred Networkin' Nut Member

    I have the similiar problem with flashing RT 104 AIO on the RT-N16.

    This is what I have done:
    1. manually set my pc to 192.168.1.2
    2. Administration/Configuration page, Restore Default Configuration, Erase all data in memory (thorough), OK.
    3. reboot, and then login again.
    4. Administration/Upgrade page, select the downloaded 104/AIO file, check the "After flashing, erase all data in NVRAM memory" box.
    5. flashing
    6. then I can not open the GUI to login until five or six minutes later. strange, so I did step 2,3 again.
    7. I even could not ping the router within at least five minutes after router reboot.
    8. run the recovery with restore button.
    9. flash back to the previous, then everything goes fine.
    I am sorry, I did not pay attention to the LEDs.
     
  5. fish4free

    fish4free Serious Server Member

     
  6. fish4free

    fish4free Serious Server Member

    I can confirm this problem. It seemed bricked. then restore to Asus->dd-wrt->back to 102ver.

    I notice on version 102 that after some time, router CPU load is 50! Then after sometime idle, router will freeze.
     
  7. ladysman

    ladysman LI Guru Member

    I also noticed on a brand new RT-N16 on v104. Went to 101 (what i'm using) and it's fine.
     
  8. Mangix

    Mangix Networkin' Nut Member

    serial console access :D

    seriously if there is a problem, serial will see it.
     
  9. Jeffspears

    Jeffspears Serious Server Member

    I can also confirm the same issue.

    I am having the same issue exactly like the first poster described howvever I would say its like 5-6 min long to boot but exactly same power light going twice.

    Funny I found this article while googling, I must admit I just bought this router a few days ago for a friend of mine so I thought the N-16 is this slow so I wanted just to confirm the issue

    Compared to my RT-N660 this is very very slow in booting, and now from reading this page it seems related to 104 version? So if I roll back to 102 I will be good? I guess the more important question is, is it only a boot tike issue and affeft the wireless or routing speed?
     
  10. kyrios

    kyrios Serious Server Member

    Jeffspears:
    No, back to 101.
     
  11. Monk E. Boy

    Monk E. Boy Network Guru Member

    Remember, if you do a long erase of NVRAM variables, you need to leave the router sitting for approximately 10 minutes (after it's finished booting) so it can configure all the NVRAM variables before you start changing them via the administration website.

    Personally all my RT-N16s take about 5 minutes to boot, but I assumed it was due to the elaborate configuration including a lot of iptables rules...
     
  12. Jeffspears

    Jeffspears Serious Server Member

    Okay I ran more testing on it, I tried to time how long does it take to boot with the 104, and it does vary from each restart it seems like its trying to power on something but fails and retries, I don't know but thats what it seems.

    So I downgraded to see if I`ll have the same issue, went to v99 and it worked perfect, to test it even further I timed the restart 55 Sec and I did it twice with the same timing. Anyway I mostly wanted to go for the 104 for the TomatoAnon project. But I guess it wasnt meant to be on this router (I am not got in implementing scripts).

    Well thats my take on the issue. I hope other googlers will find it helpful.

    Edit: I updated to v101 as you said it works perfectly, thanks for the help.
     
  13. shibby20

    shibby20 Network Guru Member

    I tested v104 on:
    - asus WL500gp (K26USB R1)
    - netgear wnr3550L v1 (K26USB R2)
    - netgear wnr3500: v2 (K26USB RT-N)
    - asus rt-n15u (K26USB RT-N)
    - asus rt-n53 (K26USB RT-N with wl_high module)
    - asus RT-N66U (K26USB RT-N 64k)

    On all start time was shorted than 90 seconds. Well if your router is booting in 5-10 minutes, this is a problem with router or mess in nvram.

    On my RT-N66U i have:
    - WAN DHCP
    - 3 brigdes (br0, br1 and br2 - 4 vlans)
    - both radios on (2.4 and 5GHz)
    - one guest SSID enabled
    - openvpn client on (static key stored in nvram)
    - pptp server on
    - usb on (ext2/3)
    - HDD 500GB connected
    - build-in transmission on
    - samba and ftp server on
    - minidlna on
    - syslog and bandwidth`s data stored on USB HDD drive

    And reboot takes <90secs

    Best Regards!
     
  14. Jeffspears

    Jeffspears Serious Server Member

    Forgive me I am just a novice user and I am more convinced that I screwed up loading the firmware than I am with a bug inside it. I have high respect to you shibby and appreciate what you are doing, I am just conveying what happened to me without fingering. My RT660 also works well with the 104.
     
  15. subz3ro

    subz3ro Networkin' Nut Member

    I can confirm this problem happening with my RT N-16 as well. Reverted back to version 102
     
  16. Knowbody

    Knowbody Serious Server Member

    Looks like it's the RT-N16 specifically that's booting slow with 1.04
     
  17. Jeffspears

    Jeffspears Serious Server Member

    Okay I think I got to the bottom of this or not :) not an expert but here it goes

    There are 2 sections to download from
    K26
    K26RT-N

    What I am downloadin and the first poster is from the K26 and what I am noticing from others who arent facing any issues is they have the K26RT-N.

    When I get home I will test my theory but I am guessing this is the misunderstanding.
     
  18. ryzhov_al

    ryzhov_al Networkin' Nut Member

    There is watchdog a In stock firmware, which reboots router if some of wireless modules fails to start. And a funny bug, when manually switched off PHY cause a 3-times reboot.
    May it be the same for Tomato?

    gijs73, is wireless interface is not switched off?

    Anyway, you may count reboots (or not reboots) by pinging router and counting «TTL=100» sections.
     
  19. Jeffspears

    Jeffspears Serious Server Member

    Okay so I went home and flashed to the 104 AIO of K26RT-N version and it boots regularly without any issue, I don't know if the N16 was suppose to use the K26 version or not but at first I used the K26 version cause I saw the N16 router listed for that version and not listed in the K26RT-N version anyway thats what lead me to there :).

    Shibby I don't know if you still read this thread, but I am a big fan of the Anon project and would love if you could open a thread for feedback as there is no proper place that consolidates all input. I saw many great anon ideas thrown in many threads

    I`ll throw my 2 cents here and do a lil thread hijacking, The Uptime in the table resets each time I restart my N660 and I have scheduled it to restart on a daily basis so my uptime will always be less than a day like I have just flashed to the firmware in the same day, I don't know if that was the idea or do you plan on introducing a new column of a cumulative running time. One last thing I hope you get the chance to improve the uptime sorting as it lists 9-1 regardless of days I am sure you know what I am talking about.

    Best wishes for you man keep up the great work.
     
  20. xorglub

    xorglub Addicted to LI Member

    I confirm K26RT-N does not seem to experience the issue, while the normal K26 version does.
     
  21. n66666611

    n66666611 Serious Server Member

    same here RT-N16 + k26 104 = 8-10 mins to boot...
    I will try k26RT-N
     
  22. leandroong

    leandroong Addicted to LI Member

    Tomato Firmware 1.28.0000 MIPSR1-104 K26 USB BTgui-VPN
    ZTE ZXV10 H618B

    Mine around 2mins, still acceptable. I think the recording of iptable could be the culprit, as your database grows, more calculation needed for both real-time and ip-table statistics. I could be wrong, but disabling one could improve boot time perhaps... what do you think?
     
  23. n66666611

    n66666611 Serious Server Member


    and?...and...?????
    Sorry Shibby but it seams you've miss something : we are talking about RT-N16...
    You can list all the router you want, the fact is that your latest build has something wrong with RT-N16.
     
  24. Jeffspears

    Jeffspears Serious Server Member

    You should show more respect to the people who are taking alot of their time developing and testing these stuff for us and. At least shibby tried it on half a dozen routers before releasing it, and you won't take the time to try the other (K26RT-N) firmware like u said earlier.
     
  25. shibby20

    shibby20 Network Guru Member

    but 3500L v1 is the same as RT-N16. Sources are the same for all routers well or something is broken and issue exists on all routers or everything is correct and the problem is on user side.

    I have one RT-N16 + v092 but it`s my prime router (uptime >150days) and i can`t flash him :/
     
  26. mito

    mito LI Guru Member

    @Jeffspears, agree with you 100 %
     
  27. leandroong

    leandroong Addicted to LI Member

    Tomato Firmware 1.28.0000 MIPSR1-104 K26 USB BTgui-VPN
    ZTE ZXV10 H618B
    Boot time: around 90mins

    Maybe, there is something that causing it in MIPSR2?
     
  28. csfuu

    csfuu Serious Server Member

    Same problem here: I installed tomato-K26USB-1.28.RT-MIPSR2-104-AIO.trx on my RT-N16 and thought that I had bricked it. Reinstalled manually and thought that it was still bricked until it finally came up after 10 minutes or so. I'll either try the K26RT-N version or back down to 102, but having found this thread I wanted add my voice to those verifying the original post.
     
  29. shibby20

    shibby20 Network Guru Member

    ok , you may have right. one user from openlinksys confirm the problem and i find the propably reason of that. i made test build and it works correct, well fix will be included in next release.

    if someone want to test it yourself, please pm to me.

    best regards
     
  30. JJack

    JJack Serious Server Member

    I'm also experiencing long boot times (about 10 minutes) with RT-N16

    Flashed with: tomato-K26USB-1.28.RT-MIPSR2-108-AIO.trx

    I have cleared NVRAM (thorough) and reset everything.
    Wireless set to N Only with WPA2
    Used Port Forwarding to open 12 ports
    Set Transmit power to 42mW
    I have not yet configured my VPN, VLAN, or any other special features

    After looking at Shibby's chart, it seems that version K26 is "preferred" for this particular router. Any suggestions?
     
  31. Elfew

    Elfew Addicted to LI Member

    I have asus rt-16n with latest shibby 108 AIO RT-N fw... there are no problems, boot time is under 100sec...
     
  32. leandroong

    leandroong Addicted to LI Member

    ZTE ZXV10 H618B
    My boot-time is 90mins + 15secs
     
  33. Monk E. Boy

    Monk E. Boy Network Guru Member

    For an RT-N16 you can use either the RT-N or RT versions of firmware (Newest vs. Older wireless drivers), and you need K26 (Linux kernel version 2.6).

    You can try doing what's called a 30-30-30 reset, which on an RT-N16 means holding down the WPS (not Reset) button for 30 seconds, continue to hold down WPS and disconnect power, hold for another 30 seconds, continue to hold down WPS and reconnect power, hold for a final 30 seconds, then release WPS (so the WPS button is held down for 90 seconds total,). On WRT54 routers it did different things depending on which time you held down the reset button, but it shouldn't hurt anything. Setup your router normally after that and see if reboots are any faster.

    Another thing you could try is putting the router in recovery mode by having it disconnected from power, hold down the reset button and connect it to power, then wait for the power light to start slowly flashing on and off before releasing the reset button. This is recovery mode. Assign 192.168.1.2 to your ethernet card and use ASUS's firmware recovery utility (available from their support site, but an older version is included on the CD that shipped with the router) to flash your firmware to it. It includes a noticeably long delay after the flash completes to let the router setup NVRAM, and should display an error after that long delay (the long delay is normal, and if you're flashing a third party firmware the error message is also normal).

    I can't stress this enough that you need to give it a long pause after flashing or a thorough erase, if you jump right in after the reboot then the NVRAM can be incompletely configured. I had to batch setup about a dozen routers late last year and by saving the configuration (NVRAM dump) I could see how little changes in my flashing procedure caused a change in NVRAM size. I actually never got them all completely identical but they were all within a few bytes of each other.

    FWIW, the 5 minute N16 I mentioned earlier in this thread was replaced with an N66 that boots in substantially less time. It was the sole router for about 200+ students who were, of course, doing everything but their schoolwork (attempting - and failing - to run torrents, video chats, etc.) and as a result the router's connection table was slammed the instant it came online, which yielded a slow reboot and - once their various clients started going reconnect-happy after being disconnected - what appeared as a slow boot (but was primarily the router being incapable of servicing 1000+ connection attempts every second).
     
  34. goggles8

    goggles8 Serious Server Member

    Hopefully my experience will lend a clue as to what is happening. I have been running tomato on my RT-N16 for a couple of years with no problems. I recently purchased 2 units to set up at my dad's (access point+ WDS). After flashing Shibby's tomato-K26USB-1.28.RT-MIPSR2-108-AIO.trx I experienced the same problem as was mentioned here with the PWR led flashing off every couple of minutes. The only way that I could get the units to boot was to unplug all network cables, unplug the unit and plug it back in (without the network cables). It was rather frustrating and I was about to put 102 on them (same as my personal router is running) but instead I tried disabling USB support since my dad was not going to use the USB ports on these anyway.

    USB and NAS -> USB Support -> Core USB Support (uncheck). After saving the setting on that page I performed a shutdown from the web GUI. I don't know if the shutdown could have made any kind of difference but I thought I would mention it since that is the only other thing that I did. After it shut down, I unplugged the unit and plugged it back in. The boot problems are gone now.

    Good luck...
     
  35. NLion

    NLion Reformed Router Member

    Just installed Shibby's tomato-K26USB-1.28.RT-MIPSR2-108-AIO.trx on my Asus RT N16 and got this problem also. For me the boot time is not so long, around 5mins, but is very annoying.
    Previously I had TomatoUSB v26 1.28, flashed the Shibby one, with erase nvram settings, and it flashed and rebooted fine. After that, I went to erase nvram settings (yes, maybe overkill), and after that the router takes solid 5 mins to boot everytime, with the same simptom of power led blinking at intervals. I never took the time with tomatousb, but boot time was much much shorter, in the order of 1-2 minutes at most.

    5 mins is borderline acceptable for me, because of shibby extra features, but would love to get my old boot times back.

    @googles8, I tried what you say in your post, but to no effect. I have tried booting without anything connected and it doesn't speed the boot time. Currenty I have an usb powered hub connected to the router with a couple hard disks, but nothing else.

    I also tried the 30-30-30 method, no difference.

    Any ideas?
     
  36. koitsu

    koitsu Network Guru Member

    1. Under Administration -> Logging, please check Cron, DHCP Client, and NTP
    2. Click Save
    3. After roughly 30 seconds, reboot the router normally (via GUI)
    4. Let the router reboot and take ~5 minutes
    5. Once everything is back up, please go to Status -> Logs and click View All
    6. Copy-paste the contents into a file on your system, then upload that file in a reply post here on the forum

    This will hopefully shed some light on what's causing the delay for you, but no promises. Without that information, it's anyone's guess.
     
  37. duprade

    duprade Serious Server Member

    I just tried to install Shibby 108 on an ASUS RT-N16 I bought for my parents house.... the boot time was very long and I ended up reverting to 105, which is what's running on my router at my place. (and I just happened to have the file on my machine and knew it worked) Boot time on 105 is 90 Secs..... boot time on the 108 was between the 5+ min. Since my parents aren't that savy, I just installed 105 on there to make sure they have something that works.
     
  38. shibby20

    shibby20 Network Guru Member

    i don`t know why but RT-N16 is rebooting severall times. There is no errors or something. Problem is randomly. On my RT-N16 i haven`t "long time problem" but the same image on second RT-N16 and problem exist. I don`t know why but i`m working on it. Many people told me the problem exist on RT-AIO version but RT-Mega-VPN or RT-N-AIO works correct. Can you test it?
     
  39. ladysman

    ladysman LI Guru Member

    Shibby,
    I did this test on my "spare" RT-N16. I had v101 RT-AIO and went to RT-N v108. No issues with boot time.

    I then went to RT-AIO v108 and the problems arose. I went back to the "N" version and it works.

    My RT-N16 is one of the originals from when it was first released.
     
  40. goggles8

    goggles8 Serious Server Member

    I tried this on a third TR-N16 (purchases off of Ebay - had dd-wrt installed with a 2010 FW so an older unit). It had the same problem and with the same FW as with the two I recently bought brand new (as I described in post 34).

    Having all network cables unplugged did not seem to make any difference this time. Still got the ~5 minute boot time with the power LED flashing off two or three times before the 2.4 ghz LED will come on (the boot is successful shortly after the WIFI LED Lights up).

    So here you go guys, with the three RT-N16s that I tested (two brand new and one from 2010)
    I Disabled Core USB and the boot time went to less than a minute.

    Bottom line: If you care about long boot times and you want to use USB then do not use the non RT-N AIO firmware version 104-108 with the RT-N16.

    Edit: After playing with this some more, the "USB Storage Support" option can be unchecked to resolve the long boot time, You don't have to disable the entire "Core USB Support"
     
  41. kthaddock

    kthaddock Network Guru Member

    That is strange I have always use AIO-builds and I have never seen that problem with long boot time.

    kthaddock
     
  42. goggles8

    goggles8 Serious Server Member

    As previously stated - the problem does not exist in the K26RT-N version that you are using (as I can see by your signature). Just the K26.

    Just curious as to why you are quoting me? This entire 4 month old thread is about this problem. Also, there are several bug reports about this opened at http://tomato.groov.pl/?page_id=334

    http://tomato.groov.pl/?page_id=334&bugerator_nav=display&bug_project=1&issue=164
    http://tomato.groov.pl/?page_id=334&bugerator_nav=display&bug_project=1&issue=172
    http://tomato.groov.pl/?page_id=334&bugerator_nav=display&bug_project=1&issue=196
    http://tomato.groov.pl/?page_id=334&bugerator_nav=display&bug_project=1&issue=202
     
  43. kthaddock

    kthaddock Network Guru Member

    I quoted you regarding raw over this, okey only in K26 builds and regarding bugtracker it's reported bugs from people feeling they have boot problem no one have comfirmed or haven't provide ANY technical proof to starch theirs suspicion.

    I saw your post goggles8, Today at 10:16 AM and answere to that.

    kthaddock
     
  44. koitsu

    koitsu Network Guru Member

    The issue may have something to do with USB Core support -- I say this because at least on Toastman's firmware, once I enabled USB Core support (I moved from using CIFS/SMB for my Entware /opt stuff to a USB flash drive), my boot times went from 25-26 seconds to exactly 55 or 56 seconds.

    There's nothing in the kernel log (/var/log/messages) to indicate the source of the long delay either. I've worked out all the math of the timestamps (it's tricky due to lack of CMOS battery for storing the system clock time permanently, so you have to do a bunch of string-to-UNIX-timestamp conversions, then some basic math, then re-convert them -- rather not explain it here) in the logs, but there isn't a lot there.

    Part of me wonders if the long delay is caused by something the CFE has to do -- I imagine USB Core support would just enable/load a Linux kernel module for USB enumeration/class support, but it may be that there are some NVRAM variables involved that affect the CFE.
     
  45. goggles8

    goggles8 Serious Server Member

    If I toggle "USB Storage Support" off and on (saving after alteration) I can reproduce the behavior. The power LED goes off and cycles a few times, the WIFI light stays on though.

    Can someone who knows Linux better than me point me to a means to log what could be causing the reboot (kernel panic or other). I tried to tail /var/log/messages while toggling "USB Storage Support" off and on untill the router rebooted, but it did not yield anything helpful. I also formatted/mounted the JFFS partition and re-directed the system logging to there. There is just a gap from when I initiate the reboot, to when the boot succeeds. The JFFS partition must not be mounted before the reboot happens (I attached it anyway). Anyone know how to setup linux to log the dmesg data in realtime (and to flash memory)?

    Thanks for looking into this (Shibby and others)
     

    Attached Files:

  46. koitsu

    koitsu Network Guru Member

    The logging situation when "writing to flash memory" (as you put it -- you're talking about writing to a file on a filesystem that retains the data) is a chicken-and-egg issue. If the kernel panics, how do you expect the logs to get written to disk since the kernel is what handles filesystem I/O? Kernel panic means most, if not all, of the system is considered unusable/unstable at that point.

    For Linux kernel logging, look up klogd. That's the daemon that handles logging messages from the kernel. It's a userspace daemon, so when the kernel crashes.... you do the math. :p

    Basically there is no way to get what you're proposing, on any system (Windows, *IX, etc.). Even if you were to offload the logging messages to a remote host/system, there's no guarantee that there will be logs to send across the wire before the kernel crashes. Politely not rudely: think about it a bit more and you'll see the catch 22 of sorts.

    There is no solution to this, other than to use serial console and build a version of the firmware/kernel that drops to a debugger when the kernel panics so you can try to figure out what happened in real-time. Really, that's the only solution for debugging a kernel panic.

    P.S. -- LED indicators are not valid/proper ways to determine if the system has crashed or rebooted or otherwise. The CFE, I believe, handles the LEDs -- so you can have a kernel that's crashed and the LEDs do not have to change state.
     
  47. goggles8

    goggles8 Serious Server Member

    Thanks. You are correct - but it was more than the power led . I lost my SSH session and the router was unresponsive. When it finally came back around, /tmp had been cleared - so definitely a reboot happened.
     
  48. koitsu

    koitsu Network Guru Member

    Oh, sorry -- I didn't mean to imply a reboot or crash didn't happen, I definitely agree with you there. What I was trying to say with my statement was with regards to the part where you said "...but the WIFI light stays on..." -- to me the mention of the WIFI light being an exception implied that if the router rebooted/panic'd all the LEDs would somehow shut off -- which isn't the case. Sorry for any confusion my statement might have made!
     
  49. goggles8

    goggles8 Serious Server Member

    Well surely someone out there with an RT-N16, running Shibby's Build out there has a serial connector. I just hope that they want to help out. I may end up building one myself. Is it really as easy as it appears here? http://wiki.openwrt.org/toh/asus/rt-n16
     
  50. Monk E. Boy

    Monk E. Boy Network Guru Member

    Actually there was a recent thread on serial ports, in that a normal PC serial port is 12V and routers need... crud either 5V or 3.3V... so not every serial adapter will work. The upside is that the serial adapters that do work are on the cheap side. I'll see if I can find it in my discussion history...

    Edit: Nada on discussion history, but Google decided to be my friend today:
    http://www.linksysinfo.org/index.php?threads/just-bricked-rtn66u-after-tomato-upload.64827/
     
  51. RMerlin

    RMerlin Network Guru Member

    This is the adapter that I use here:

    http://www.ebay.com/itm/ws/eBayISAPI.dll?ViewItem&item=190685792376&ssPageName=ADME:L:OU:CA:3160

    Took a bit over a month to receive it in Canada.

    EDIT: I see that they no longer ship to Canada. Glad I got two before they changed that...
     
  52. alpovs

    alpovs Reformed Router Member

    I plugged in my RT-N16 that was in storage for some time and decided to upgrade the firmware. I can confirm that this problem exists with tomato-K26USB-1.28.RT-MIPSR2-108-AIO.trx (that's the version I upgraded to). I am going to try to disable USB support as suggested. Yes, I did thoroughly clear NVRAM.
    EDIT: Disabling USB support reduced the boot time to normal.
     
  53. leandroong

    leandroong Addicted to LI Member

  54. koitsu

    koitsu Network Guru Member

    No, max_sectors does not have to do with the issue of the router taking a very long time to boot. Please read what max_sectors controls: http://www.linux-usb.org/FAQ.html#i5

    Actually increasing max_sectors may provide performance improvements for some, but be wary of doing this: there are known issues with some USB chips (on either the host (router) or the storage device (USB enclosure)!) not handling larger I/O requests correctly. If you choose to tune this, you need to use a value that is a multiple of 8. This is incredibly important.

    I have tested increasing max_sectors on a RT-N16 using a USB 2.0 flash drive (HP V165W, 16GB), and there is no performance gain. Decreasing the value, however, does slow down buffered disk reads. You can do your own benchmarking with hdtune -tT /dev/sdX (available via Entware).

    But again: max_sectors has nothing to do with the long boot-up time.

    I'm aware of a way to figure out what's taking up all the time, but it requires a custom firmware/kernel be built (and I'm not even sure it's possible given how old our kernel version is, I need to look at the Linux kernel source to determine that).

    Edit: I've looked, and it's possible, I just don't feel particularly like risking bricking my only router. If someone wants send me an RT-N16 and whatever USB device they have hooked up that causes long boot times, I can build a custom kernel and see if I can work out where the delay is. I make no promises.
     
  55. Elfew

    Elfew Addicted to LI Member

    This issue is only in Shibby builds, after b105 I think...
     
  56. goggles8

    goggles8 Serious Server Member

    1. No USB device needs to be attached to the router for the problem to occur.
    2. This is not a "delay", it is a crash/abend/panic whatever you like to call it. The device reboots, usually multiple times.

    Thank you for the offer, but I am going to see if I can get any more info via the serial interface (it's in the mail) first.
     
    nobugme likes this.
  57. Frequenzy

    Frequenzy Networkin' Nut Member

    i learned from a friend that had the same issue. he used rt-n builds and its now ok. last known working is 105 rt build.
     
  58. quihong

    quihong Serious Server Member

    I just want to say I've experienced this issue also on my Asus RT-N16 - Shibby v108 AIO with USB flash drive attached. It doesn't really bother me though, since I rarely, if ever, have to reboot my router. For situation where I do reboot often, testing and such, I use my Belkin N300.

    Hopefully it gets resolved in a future release, otherwise we can also run the RT-N version I guess.
     
  59. luckman212

    luckman212 LI Guru Member

    I am really suffering from this issue heavily as I have set up a lot of RT-N16's for friends, family etc. So is the recommended solution for now to run the RT-N build 108 or stick with 'RT' build 105? Or not use shibby at all on the RT-N16? Just curious what other people are doing. thanks
     
  60. shibby20

    shibby20 Network Guru Member

    v109 is longboot free. Tested by 4 people. So pleasr wait for release - maybe i will finish today
     
    xorglub, Monk E. Boy and yac22 like this.
  61. Monk E. Boy

    Monk E. Boy Network Guru Member

    Oooh, I'm looking forward to hearing about the cause & solution.
     
  62. shibby20

    shibby20 Network Guru Member

    solution? New build-server :) On older was broken HDD.
     
  63. leandroong

    leandroong Addicted to LI Member

    Thanks again Shibby for your new FW109.
     

Share This Page