1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

File- and Printersharing not working (with Windows XP)

Discussion in 'Networking Issues' started by Quickdraw, Sep 8, 2004.

  1. Quickdraw

    Quickdraw Network Guru Member

    Basic question: is there any configuration setting on a WRT54G router (running Linksys or Satori firmware), that could prevent/disable file and printersharing, especcially for a wireless connected computer?

    I have two Windows XP Prof computers (A and B) wired to my Linksys WRT54G and one Windows XP Home computer (C) connected wireless to the router.
    All have been setup for simple (in contrast to advanced sharing with XP Prof) file- and printersharing using protocoll IPX/SPX. All 3 comp. have file- and p-sharing installed with binding to ipx/spx and binding to tcpip removed. All have a unique computername in the same workgroup.

    Now, while this works fine between A and B (A and B see each other under "View workgroup computers" and can access the other's shared folder), A and B can't see C and vice versa.

    I spent two days reading any MS article about that topic and various troubleshooting guides, but without success.

    The only difference of the invisible (and blind) computer C is, that it runs only the Home edition and is connected wireless. Could it be that the wireless stuff has problems with IPX/SPX? I am using WPA-PSK encryption, if that matters.

    Gratefull for any advice ...
    Joachim (from Germany)
  2. Quickdraw

    Quickdraw Network Guru Member


    All works fine when I connect computer C with a cable to the router.

    So the problem lies in the wireless connection.

    Why does my homenetwork fail only when the computer connects wirelessly? Any ideas?
  3. Quickdraw

    Quickdraw Network Guru Member

    Found it!

    Finally after hours of goooooogling I found a hint that windows does not allow file- and printersharing without WEP encryption of the wireless traffic.

    So I changed my security from WPA-PSK to WEP and instantly all was working fine.

    I consider that a bug. It looks like they have forgotten about WPA-PSK here.
    Naive question: how can I report that to Microsoft?
  4. Esquire

    Esquire Mesquire Staff Member Member

    File and printer sharing through my WRT54G works fine on WPA-PSK.
  5. Quickdraw

    Quickdraw Network Guru Member

    So it either must be hardware related or I'm missing some MS patch....?

    I also tried it with another wirelessly connected desktop. Same thing. WPA no, WEP yes.

    My wireless hardware is:
    Linksys WRT54G Router with latest firmware. I also tried Satori 4.0 but no change.

    1st wireless Comp. (Desktop):
    PRISM 802.11g Wireless Adapter
    Driver Date 18 Dec 2003
    Config Program 1.00.20 Date 4 Aug 2003
    NIC Firmware

    2nd wireless Comp. (Laptop):
    Intel High Rate Wireless LAN Mini-PCI Adapter with Modem
    Driver Date 04 Jun 2003
    Config Utility 3.00.04 29 Apr 2003
    NIC Firmware

    Does anything look suspicious?


    Update: further tests showed, that it also works with WPA-PSK and the AES algorithms but not with TKIP.
  6. Esquire

    Esquire Mesquire Staff Member Member

    If it works with AES, perhaps you should consider using that instead.

    I notice you are using the adapter's own wireless management application to handle the encryption, so reporting to Microsoft probably won't do anything. I use XP's own Wireless Zero Configuration, which requires the Wireless Update Rollup Package or SP2 to support WPA.

    Presumably you have disabled your WZC?
  7. Toxic

    Toxic Administrator Staff Member

    does ipx work oaver wireless though? try using tcpip and see
  8. Esquire

    Esquire Mesquire Staff Member Member

    That's a good question, but I think it should though since he doesn't have this problem with WEP and AES.

    I know NetBEUI works with WEP, TKIP and AES - I setup WLAN for my friends this way, and it has been working flawlessly - with nothing to configure they simply can't mess up what I have done :twisted:
  9. Quickdraw

    Quickdraw Network Guru Member

    Yes, I have checked Services and see WZC running on both wireless connected PCs, both have the rollup patch Q826942 installed and the protocoll is IPX/SPX. It works with WPA-PSK/AES and breaks the moment I switch to TKIP. Of course I wait at least 30 min for the change to propagate to all computers (I have a 3rd comp. wired to the router).

    These two wireless PCs are running the German version of XP (one Home, one Pro) and both are on the latest Update level (no SP2 though).
    Maybe there is a bug in the German implementation?

    The only reason for the problem I can think of is, that Windows does not recognize TKIP as a valid encryption and refuses wireless opereation.

    Well, I can try TCP/IP for a test, but would like to stay with IPX/SPX as it provides better security.

    Thanks for your replies!

    Update: I can't get it to work with TCP/IP at all, although I checked all those things I found in a plenty of postings (ZoneAlarm off, NetBIOS on, NodeType = Hybrid, etc.) so after two hours of experimenting I set it back to IPX/SPX.
    Since there are thousands of folks out there with the very same problem, it would be nice to have a tool that would autimatically check all the (estimated) 73 possible pitfalls and tell me what is wrong.
    Any volunteers ...? :)

Share This Page