1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Firmware 1.03.0b4

Discussion in 'Other Linksys Equipment' started by jrjove, May 3, 2005.

  1. jrjove

    jrjove Network Guru Member

    Anyone with this firmware with a RFC 2364PPPoA connection working...

    When I try to work with this firmware I always que my default Gateway IP the same as my Internet IP address!!!!!

    Thaks for your answers...
  2. dribble

    dribble Network Guru Member


    Could you confirm what you mean by the same address?

    your default gateway would have to be your wag54g (private address)


    If you try and send your packets to the public address your machine will not know where to go!
  3. booly

    booly Network Guru Member

    Me and a lt of other people and the same issue with internet connexion with this firmware.

    I downgrade to v1.02.07
  4. jrjove

    jrjove Network Guru Member

    Re: clarificaiton...

    I mean my internet address my provider gives me is 62.xxx.xxxx.xxxx and the internet gateway is the same adress.

    With 1.02.7 my ISP gives mes an internet IP and a different IP for internet gateway.

  5. san9jay

    san9jay Network Guru Member

    i have the same issue with the 1.02.9_04 AU firmware. Strangely the network seems to work fine so I am sticking with this firmware. I did try the 1.03.0_b4 firmware but that would loose the dsl link every couple of hours.
  6. dribble

    dribble Network Guru Member


    Your ISP gives you two addresses depending on the code? that doesnt sound right.

    your public address (62.x.x.x) would be provided by your ISP, this is the address that your WAG54G would use to connect to the internet.

    Your WAG54g code can not determin what IP allocation you get.

    Your PC would have a private address, unless you have purchased IP addressses from your ISP that are routed to your ADSL connection. (sounds more likely)

    If you have been given (purchased) more IP addresses, that have been provided by your ISP then they would route this to the address they have given you for the WAG.

    I would say that you have an unstable code that makes your connection drop, or not connect at all. If you drop some of the settings off the box (FW/Port forwarding etc etc) does the problem go away?


  7. jrjove

    jrjove Network Guru Member

    So nobody's working with a RFC 2364PPPoA connection on 1.03.0 b4....

    We shall be waiting for a new firmware brbrbr
  8. dribble

    dribble Network Guru Member


    ~In the UK... (like me) it works fine

    RFC 2364PPPoA connection on 1.03.0 b4.

    Although I have changed to a V2 WAG54G for testing purposes.
    The V1.2 does have "stability" problems due to overload and heat.

    Would it be worth looking at those issues, just incase that is the route cause?

    Unfortunately I still can not understand what you are trying to achieve :-(
  9. jrjove

    jrjove Network Guru Member

    Re: Confirmation

    Trying just to connect INET with this firmware
    With 1.02.7:
    ADSL Link: Up
    PPP Login: Connected
    Internet IP Address: 62.15.ABC.DEF
    Public Subnet Mask:
    Default Gateway: 212.106.HIJ.KLM
    Primary DNS Server: 62.14.x.x
    With 1.03.0 b4
    ADSL Link: Up
    PPP Login: Connected
    Internet IP Address: 62.15.ABC.DEF
    Public Subnet Mask:
    Default Gateway: 62.15.ABC.DEF
    Primary DNS Server: 62.14.x.x

    So as Default gateway is the same as my Internet IP Address i'm unable to access outside my router.

  10. dribble

    dribble Network Guru Member

    Clarity gained

    I see what you mean.

    That is not right, the WAG can not have itself as the DG, that is not right at all!

    would it be possible that the firmware that you have installed is corrupted?

    Perhaps download another .bin file? then try it again...

    I have had that firmware working fine and it reads like your 1.02.7 configuration.

    If another .bin file of the same version doesnt work then I would be looking at the box playing up... Is there any need to get it upgraded to 1.03.0 b4 for the time being ?


  11. tglx

    tglx Network Guru Member

    My 2 cents,

    WAG54G V1.2
    Firmware 1.03.4b.
    My ISP allows me both PPPOE and PPPOA connections.
    After a week with this code configured with PPPOE, I had several problems with the WAG54G being disconnected and unable to restore the PPPOE connection automatically... I then tried the PPPOA which seems to be much more stable and which reconnects automatically .

    Please note that All the previous versions of code I tried were absolutely not stable at all. including 1.02.7.

    In case it can help, I detail all the config I've been testing:
    Heavy traffic from and to the net, mostly generated from 2 wireless PCS ....
    (emule, torrent and FTP)

    -1- WAG54G 1.03.4b
    PPPOE + Firewall + Syslog + Wireless config not secured
    >>> Very unstable, rebooting twice a day and no reconnection

    -2- PPPOE + Firewall disabled + Syslog disabled + Wireless not secured
    >>> More stable but a reboot without reconnection every 2 days ....

    -3- PPPOA + Firewall disabled + syslog disabled + wireless not secured
    >>> Very stable (1 reboot with reconnection in 4 weeks)

    -4- PPPOA + Firewall enabled + syslog disabled + Wireless unsecured
    >>> Very stable for 2 weeks. No reboot, no freeze.

    -5- PPPOA + Firewall enabled + No Syslog + WEP 128 bits + MAC address configuration for authorising access.
    >>> Works really well since 2 weeks, note that enabling SSID broadcast or not doesn't change the way the WAG54G works, I mean it doesn't change its stability. So I'll configure my WAG54G with SSID Broadcast disabled and I'll wait 2 weeks before doing an update. This is my configuration today !

    When enabling Reporting tools and/or SNMP the box becomes unstable ...

    Conclusion :
    - In my case, PPPOE connection is not stable.
    - Enabling reporting tools makes the box very unstable in any configuration (PPPOE or PPPOA). Enabling SNMP is even worse...
    - Apparently (in my case) Firewall doesn't introduce unstability
    - WEP 128 and MAC configuration doesn't affect stability.
    - Keep your configration as simple as possible.
    - Don't use the reporting capabilities and no snmp ...

    >>>> Ideas <<<<

    I would be very interrested to know (accross Europe) on what kind of DSLAM you're connected to understand if there are relations between DSLAM and the unstability on the WAG54G ...
    I don't know why, but I've got the idea that if with PPPOE or PPPOA we don't find the same stability accross Europe with the same level of code, It might be because something external affects the way WAG54G behaves ...

    Here in France, with Wanadoo, I'm connected on a DSLAM from Alcatel.
    Sessions (pppoe or pppoa) are (probably) opened from a BAS which is from Redback.

    I hope my experience will help.

  12. jrjove

    jrjove Network Guru Member

    I think my Spanish ISP Jazztel uses Alcatel 7300 ASAM and as i have told you does not work well with 1.02.9 and 1.03.1beta firmware...

Share This Page