1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Firmware update WRT54G v1.42.2

Discussion in 'Networking Issues' started by BigBadAl, Apr 19, 2005.

  1. BigBadAl

    BigBadAl Network Guru Member

    Hi, I`m new, please excuse daft questions.

    As per the title, I want to upgrade my firmware but the version 1.42.2 doesn`t seem to tally with the versions available for download.

    Can someone point me in the right direction for one suitable for my router??

    Thanx in advance

    Al
     
  2. jdepew

    jdepew Administrator Staff Member Member

    Hi BigBadAl,

    The version that you refer to is the currently installed firmware on your router. The latest firmware version is 3.03.6. This firmware will work on all hardware versions.

    You can find it here- http://www.linksys.com/download/firmware.asp?fwid=233

    good luck!
     
  3. BigBadAl

    BigBadAl Network Guru Member

    Whoa, thanx for the quick reply.

    Is this one of those new fangled 'hacked' firmwares with bandwidth throttling and increased RF output power etc etc??

    Or do I need to upgrade to the v3 thing first then go to the hacked version??

    Thanx for your patience!!
     
  4. Toxic

    Toxic Administrator Staff Member

    Best way is to upgrade to the linksys official first of all.

    then use something like HyperWRT 2.1b1 which is also based on the lastest firmware.
     
  5. BigBadAl

    BigBadAl Network Guru Member

    OK, thanx guys, router is now running v3.03.6.

    Which would be the best hacked version with stable BW throttling and a nice RF output hike??

    Thanx
     
  6. BigBadAl

    BigBadAl Network Guru Member

    Ok guys, I think I`ve hosed my router.

    I upped to the 3.03.6 then to one of the hacked firmwares and the instructions said to way "some minutes" I waited about 10-15 and still had the WLAN light blinking really quickly so I rebooted the router and got into the admin part of the router but no chance of getting a ping past it.

    Tried everything I could think of but no go so I did the 30 second reset thing and got a constant blinking power light and no combination of 30 second resets or reboots would cure it.

    Now I`ve got a solid power light but my WLAN light flicks twice every 2-3 seconds and I cant get into the router or past it ping wise.

    So come on guys is it hosed or is there a way round this???

    Thanx again

    Al

    **UPDATE**

    Just downloaded the Auto update utility from linksys and got nowhere with it, until I plugged my laptop into the "Internet" port on the router, it went thruough all the motions of the update including the "writing to flash, please wait" then at the end it said "you have successfully updated your router" and I hit exit and rebooted the router.

    The router then went through the motions of a reboot and seemed to do so but I`ve still got this Lan port 1 flicks once then the WLAN port flicks twice imediately after it, if I inplug the LAN port 1 the WLAN still flicks every 2 seconds.

    Any ideas other than expensive paper weight??

    Thanx again
     
  7. Toxic

    Toxic Administrator Staff Member

    when you flash a firmware the auto updated does it immediately, however the flash is still being written to. if you reboot before you get solid lights you will trash the router again and again.

    firstly HOLD in the RESET Button for 30 Seconds.

    then wait approx 1min. if you get solid lights then it it normal. if not and you have flashing lights you will need to check the following links

    http://www.linksysinfo.org/modules.php?name=FAQ&file=index&myfaq=yes&id_cat=8

    the instructions maybe more general but they work in most cases.

    ALso try the following:

    turn router power off.

    run auto update. enter the details to flash the firmware. then turn power on to router, and at the same time try pressing UPgrade on the utility.
     
  8. BigBadAl

    BigBadAl Network Guru Member

    Thanx Toxic, but It looks like it`s almost certainly roasted!!!!

    I got as far as the 30 second reset and the pings....nowt!!

    I aint even getting an I.P. addy assigned, I can`t even opt for "use this I.P. Addy"

    It`s certifiably DEAD!!

    I`ve mailed Linksys with a sob story about a linksys firmware, intermittent dropping wireless conectivity and update failure.
    Let`s see what they say eh??

    Thanx anyway my friend, if you think of anything else, post it up!!

    Cheerz

    Al
     
  9. Toxic

    Toxic Administrator Staff Member

  10. BigBadAl

    BigBadAl Network Guru Member

    Whoa!!, What an absolute `mare!!!

    After much messing around with this, that and the other I managed to get into the router by connecting my pc`s LAN cable to the WAN port on the router and the v3.03.2 or whatever it is was there!! I reflashed it and it still wouldn`t give me an IP address off any of the LAN ports so I went to linksys and downloaded the latest v1.1 firmware which is 1.42.2 and I`m back on the air!!!

    All my Lan ports are workin, as are my wireless machines so for now I`m gonna stay llike this and see what linksys have to say!!!

    Just scared to reboot the router now in case it all goes the shape of the pear again!!!

    Ah well. we will see soon enough.....I gotta put the case back on!!

    Back soon, hopefully!
     
  11. BigBadAl

    BigBadAl Network Guru Member

    Righty, eventually I`m back.

    This router for some reason won`t reboot properly with the WAN cable connected, was never a problem before but it is now.

    Other than that It`s ok for now, I`ll just buy another off ebay or something.

    Any ideas why it won`t reboot (power LED continually flashes) if I leave the WAN connected???

    Thanx

    Al
     
  12. Guyfromhe

    Guyfromhe Network Guru Member

    i;ve never heard of anything like that... have you given it a good ol 30 second reset since you got it back up?
     
  13. BigBadAl

    BigBadAl Network Guru Member

    Tried the good old 30 second reset, still won`t boot with the WAN cable connected, remove it and do a normal reset and it boots fine, then you can pop the WAN cable back in and off we go!!

    Also, got a reply from Linksys, asking a load of Q`s so answered them and he said he`ll send me the link for the DL of the latest 3.xx.xx F/W, so, we`ll see how I get on with that then eh!?!?

    I`ll post back and let y`all know when it happens.

    Thanx again guys

    Al
     
  14. BigBadAl

    BigBadAl Network Guru Member

    Righty, upgraded to v3.03.6 and this little mofo won`t boot with the WAN cable in, if I do the 30 sec reset the power LED will constantly flash but if I just pull the WAN cable out for 5-10 seconds the power LED will go solid and I`m back on the air!!!

    I give in!??!?1 :evil: :evil: :evil: :evil:
     

Share This Page