1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

flashing E4200

Discussion in 'Tomato Firmware' started by ntest7, Dec 19, 2011.

  1. ntest7

    ntest7 Network Guru Member

    OK, just got my shiny new E4200 router, and of course want to flash Tomato on it.

    Is there some trick with the E4200? Every time I try it says "The image file is incorrect" and refuses to flash. This is no version number on it, so I assume E4200 v1. If it matters, the Linksys firmware is version 2.0.21

    I've tried toastman builds:
    tomato-E4200-NVRAM60K-1.28.0493MIPSR2-Toastman-RT-N-Std.bin
    tomato-E4200-NVRAM60K-1.28.2493MIPSR2-Toastman-VLAN-RT-N-VPN.bin
    and Victek:
    tomato-E4200USB-NVRAM60K-1.28.9007MIPSR2_RAF-VPN-NOCAT.bin

    Tried both Firefox and Chrome.

    I've flashed numerous E3000's and WRT-54GL's, but this is the first E4200 I've tried.

    I feel like I must be doing something really stupid here. Anyone want to take a stab at what?
     
  2. kthaddock

    kthaddock Network Guru Member

  3. hawkmat

    hawkmat Networkin' Nut Member

    You have a E4200v2. The v2 use firmware starting with 2 like 2.0.21. Version v1 use version that starts with 1 like 1.0.3.014. The E4200v2 uses a Marvell chipset and cannot be flashed with Tomato. If you attempt to do this you may brick the router. If you want Tomato send it back and get a E4200v1.
     
  4. ntest7

    ntest7 Network Guru Member

    Ah, now I see a v2 hidden on the bottom of the case in grey-on-grey lettering that's had for old eyes to read. The others I saw had v2 on the box also; since this one didn't I thought I was OK.

    Thanks all!

    back to the store...
     

Share This Page