1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

[Fork] Tomato-ARM by @kille72

Discussion in 'Tomato Firmware' started by kille72, Mar 24, 2017.

  1. kille72

    kille72 LI Guru Member

    Very strange that WiFi is not stable on Pedro's firmware...What do you think @pedro311? Are you sure you have cleared NVRAM after updating??
  2. Tally

    Tally Networkin' Nut Member

    I notice that on the Tenda AC15, I can only get about 90Mbps down max on 5Ghz but if I flash stock I get 190+Mbps. I am on a 250Mbit connection. Also on the Ethernet ports state I am only showing 100M when the ports are 1000M / Gigabit. Is this an issue and/or possibly why I am getting slow wireless / re: not gigabit? The AC15 is connected right into my gigabit LAN acting as a wireless A/P (not acting as a router). Thanks,
  3. Techie007

    Techie007 Serious Server Member

    @kille72: No, I haven't reset NVRAM since version 2017.2. The WiFi became rock solid in one of your 2017.3 beta versions. I'm really being quite picky--by rock solid, I mean absolutely no dropping. I haven't yet found a router on the market using stock firmware that works at this level. The dropping usually happens with "edge cases" anyway; sleeping Apple devices and devices that have poor reception. But it's nice! I don't get connect/disconnect notifications for devices that were in range the whole time, and iPhones don't take several seconds to reconnect to WiFi upon wakeup.

    @Tally: There is a known issue with Tomato and the Tenda AC15 on the 5 GHz WiFi. I believe Tomato doesn't know how to turn on the power amplifier for the 5 GHz radio, resulting in the signal being approximately 25 dB lower than it should, which would result in lower speeds. I don't know enough about this Linux/firmware stuff to even know where to begin, and the coders who have kindly added firmware support don't have one of these routers to personally tinker with.
  4. Tally

    Tally Networkin' Nut Member

    @Techie007 Thanks for the reply. That is a bummer. No wonder. I have been tinkering with every setting imaginable to include playing with transmit power and I still get the same result.
  5. Elfew

    Elfew Network Guru Member

    I cannot confirm, with a new updated wifi driver my RT-N18u is even better :) wifi is stable nad fast, also the coverage is better. Did you clear nvram?
    kille72 likes this.
  6. Nathan Ellsworth

    Nathan Ellsworth Connected Client Member

    I don't use USB much, but I did just now test by plugging in a USB3 drive to both ports on the EA6700 and it successfully auto-mounted my NTFS partitions both times. So I think both ports are still working. As for performance, I don't know how best to test that.
  7. ZnidaXP

    ZnidaXP New Member Member

    After a day or two the web GUI stops responding and I cant open it anymore. Only hard reboot helps. But the router is working ok, only GUI and SSH stops responding. Does anyone have the same problem? Router is EA6900 with CFE mod.
    Using the latest tomato-EA6900-ARM--2017.3b17-kille72--AIO-64K
    Last edited: Dec 17, 2017
  8. Elfew

    Elfew Network Guru Member

    @kille72 and @pedro311 - I suggest you to not reply to "bugs" and "issues" reported by users who DO NOT reset NVRAM after updating. It is waste of your time, really difficult to track real issues etc.
  9. KyleS

    KyleS Addicted to LI Member

    root@Tomato:/tmp/home/root# uname -a
    Linux Tomato #1 SMP PREEMPT Fri Nov 3 20:04:43 CET 2017 armv7l GNU/Linux
    root@Tomato:/tmp/home/root# wl ver
    6.37 RC14.86
    wl0: Nov 17 2014 11:28:42 version (r456083)

    I've been having the exact same weird issues exactly like Techie007's describing since switching from an ancient toastman build to this new tree. Maybe it's the new wireless driver?

    EDIT: Yes, I absolutely cleared my nvram after flashing new.
    EDIT2: Why not just match what RMerlin's shipping instead of going after what was in a tarball?
  10. kille72

    kille72 LI Guru Member

    Last edited: Dec 18, 2017
  11. srouquette

    srouquette Network Guru Member

    it's really a pain in the ass to reset nvram. Why is that? new settings don't have default values and aren't written in the file?
  12. kille72

    kille72 LI Guru Member

    If everything works without cleaning NVRAM, then we have NO problem. But if something does not work, it's obvious that you need to clear NVRAM and test again before reporting bugs. That's what I mean.
    The Master likes this.
  13. sac7000

    sac7000 Serious Server Member

    Last edited: Dec 18, 2017
  14. kille72

    kille72 LI Guru Member

    ...and we are asking for support and donations for new equipment, we need two new routers for Tomato tests :)
  15. pomidor1

    pomidor1 Networkin' Nut Member

    +10 euro for you
    kille72 likes this.
  16. Elfew

    Elfew Network Guru Member

    What routers will you buy? :)

    @srouquette - there are many changes in nvram variables between builds, it could (and it does) bring a lot of unwanted issues.
    kille72 likes this.
  17. somms

    somms Network Guru Member


    Thank you sir for the hard work.
    Just finished successfully flashing/NVRAM Flush/Re configuring my gateway router with your final build!;)
    kille72 likes this.
  18. My Name

    My Name Serious Server Member

    + 20 Euro and thanks for the work you guys do.;)
    kille72 likes this.
  19. kille72

    kille72 LI Guru Member

    We'll see...
    Last edited: Dec 19, 2017
    The Master likes this.
  20. Jonas I

    Jonas I New Member Member

    +20 EUR and thanks a lot for your work:)
    William Clark and kille72 like this.
  21. lubmar

    lubmar Connected Client Member

    Xstar13 likes this.
  22. Mercjoe

    Mercjoe Network Guru Member

    Last edited: Dec 19, 2017
  23. Sean B.

    Sean B. LI Guru Member

    I have a feeling that newer driver may be for a newer ARM version and therefore not applicable to routers running earlier hardware. But I may be incorrect, I'm curious for someone to confirm as well.
    Xstar13 and Techie007 like this.
  24. Yim Sonny

    Yim Sonny Serious Server Member

    +125 Euro. Paypal transaction 3A6867213N680015H
    Thank you very much for your hard work. I still have MIPS routers for most things but will need to start moving to ARM for the extra power.
  25. kille72

    kille72 LI Guru Member

    Wow, thank you very much!
  26. joksi

    joksi Serious Server Member


    I have a Netgear R6250 with fast upload 60-70Mbps, but only 15Mbps downstream on 2.4Ghz. After I installed your version (or Killes latests) in about-page Wireless driver is (r456083), the same as in Shibbys latest?
    Isn't there a new driver?
  27. kille72

    kille72 LI Guru Member

    Run "wl ver" command on v140 and v2017.3 and you will see the difference.
    Last edited: Dec 20, 2017
    Techie007 likes this.
  28. Elfew

    Elfew Network Guru Member

    Let us know :)
    kille72 likes this.
  29. joksi

    joksi Serious Server Member

    6.37 RC14.73
    wl0: Nov 17 2014 11:28:42 version (r456083)

    6.37 RC14.86
    wl0: Nov 17 2014 11:28:42 version (r456083)

    Is is RC14.86..?
  30. joksi

    joksi Serious Server Member

    Unfortunately, I don't see any improvement on 2.4 ghz on v 2017. 3. It's still 50-70mbps upstream and poor 10-15mbps downstream . Tried with two different clients (40mhz). Who have reported better speeds on Negear?
  31. ghoffman

    ghoffman LI Guru Member

    i'm wondering if the board_data parttion on your router has bad information. i think some of the wirelss parameters come from that partition. a devoper could provide confirmation or rebuttal.
  32. The Master

    The Master Network Guru Member

    X86 VM Client :D (HyperV)
    kille72 likes this.
  33. feedzapper

    feedzapper Connected Client Member

    You are alone on the 2,4 ghz Band to ran the UP/DOWN Tests ?
    There are no ohter AP's or Clients on the Band (same Channel) ?
    Oh, 40Mhz bandwidth - beautiful you need "7" 5mhz Channel Slots on 2,4 Ghz !
    e.g. you are on Channel 13. You are occupy the Channels 7-13 for 40 mhz.
    And all the Channles were FREE, while ran your speed test ?

    Sorry, my friend ..
    I think your test is not very meaningful !
    Last edited: Dec 21, 2017
  34. joksi

    joksi Serious Server Member

    Yep, I even created a separate SSID only for testing. Of course there are other AP's, I'm living in an aparment...
    I havent said my test was scientific, I'm just making a statement that the "new driver" doesn't show any improvement at all for me unde rmy circumstances. If the issue where with 40Mhz, then Upstream wouldnt reach 60-70Mbps. It's clearly some issues with the driver downstream. Switching to 20Mhz doesnt improve the downstream speed either.

    I have an old OEM Netgear , if I plug it in on the same channel I have like 80Mbps up/down-stream. So it's for sure not my environment thats the problem, everything points to Tomato.
  35. Techie007

    Techie007 Serious Server Member

    Done—€50. Thank you for your diligent work keeping Tomato alive! Now as to hardware, do you think you could fix the Tomato 5GHz signal strength issue on the Tenda AC15 if I sent you one? It's a really nice and yet inexpensive router with 16MiB of flash, easy to access the CFE to recover from a brick, and easy to access the serial interface for direct debugging. If you think you can and would appreciate the router, let me know in your response, and PM me with shipping details. Otherwise, my offer stands to any other developer here that is contributing to this project who thinks they could figure it out!
    kille72 likes this.
  36. Sean B.

    Sean B. LI Guru Member

    Is it possible to export/dump the CFE from the stock firmware?
  37. Techie007

    Techie007 Serious Server Member

    Pardon my ignorance, but I'm not sure exactly what "dumping the CFE" means. I have shared the factory bootlog and NVRAM here, Chaos99 found the factory Telnet credentials here, and said that you can download the entire firmware image ("including boot and settings") from the router here.

    Is there something else you would like me to check?
  38. Sean B.

    Sean B. LI Guru Member

    The CFE is the bootloader, and has specific hardware data/settings that wl ( the Broadcom wireless driver ) uses. In Tomato under Administration->Debugging there's a link to download the CFE, which will be in a binary .bin format. It's the same as doing:

    cat /dev/mtd0 > CFE.bin
    Using a hex editor it's often possible to decipher many of the hardware settings ( except as of recent, as manufacturers have started encrypting the CFE ). I unlocked the channel and transmit power restrictions on my RT-AC68P using this method. Things such as mA ratings for the poweramps etc are contained in the CFE and may shed some light on the output ability of the 5ghz radio if able to compare stock vs tomato.

    Here is an example from my RT-AC68P. The sections outlined show 5ghz radio PA gain settings:

    Last edited: Dec 22, 2017
    Techie007 and kille72 like this.
  39. sandspike

    sandspike LI Guru Member

    @kille72 Thanks for your continued work on a stable build since the Shibby releases have slowed.

    I've got a question for the group. I was trying to switch to Netgear Orbi with Wired Backhaul as Tomato had a few issues and didn't seem to be getting any patches. After trying the Orbi, I'm regretting the decision as Netgear's crap programming skills are reminding me why I went to Tomato in the first place. Playstation (hardwired) is having major communication issues, and multiplayer gaming is a nightmare for my kids now. Went from 100% Blue communications to Red/Yellow (Low).

    Here is what I want: Primarily wired network, but I need a larger wireless Network.
    I'd like one router and one additional wireless AP under a single SSID that plays nice and doesn't conflict.
    I have 2x netgear R7000s (Ideally I'd run these two with Kille72 Tomato), 1x TP-Link AC1900 Google Onhub, 1x TP-Link Archer C3000.

    Previously I had the R7000 do core routing/wireless, then setup the TP-Link Google On-hub under a 2nd SSID.
    But I found that they conflicted....If I got two far from one (and stayed connected) and closer to the other, it would cancel out my wireless signal. I'm looking for that smooth handoff.

    I've been looking, but not finding the right answer. I know I could set them to the same SSID, but will they play nice, and create that larger network, not conflict? The new mesh systems supposedly do this well.
    WDS doesn't seem like the right answer but I'm not sure.
  40. sandspike

    sandspike LI Guru Member

  41. ruggerof

    ruggerof Network Guru Member

    I think that your question would fit better in a separate thread.
  42. Almilade

    Almilade Connected Client Member

    + 20 € (sorry, couldn't send more, PayPal balance is now at 3.81 CHF).
    Merry Christmas and a Happy new Year.
    kille72 likes this.
  43. kille72

    kille72 LI Guru Member

    Thank you :) Merry Christmas and a Happy new Year!
  44. sandspike

    sandspike LI Guru Member

    Since I’m running Kille72 firmware, I don’t think so. Lots of others that may be using this firmware in this way. Setup 2x R7000s with latest Kille72 firmware, and its working well. But clients are still staying connected to their original AP even if it’s not the strongest signal. The hope is these newer mesh systems would do this better.
    Techie007 likes this.
  45. PetervdM

    PetervdM Network Guru Member

    handoff is more a client thing then an ap thing in an unmanaged environment. so unless you have centrally managed ap's there is no way you can force a client to switch. you may be in luck with a laptop however, in the wifi adapter settings, advanced look for something like "roaming aggressiveness" or "roaming sensitivity".

    edit: it seems that apps exists for android and ios too
  46. ruggerof

    ruggerof Network Guru Member

    That is exactly the reason for a separate thread, the behavior is not exclusive of Kille72's firmware. You would find the same behavior if you were using Shibby's, Toastman's and etc. It is your decision anyway.....

    BTW: I have 3 AP's, all with the same SSID & different channels and my wireless clients usually disconnect from the weak AP and connect to the strongest one without any problem.
    Techie007 likes this.
  47. Nathan Ellsworth

    Nathan Ellsworth Connected Client Member

    +10EUR Thanks for the awesome Christmas present, @kille72

    FYI I've seen 84 records in TomatoAnon showing 2017.3 build. Of those, the only ones running the newest WL driver are all Asus RT-AC3200 models. Is this because that model has a newer WL chipset than the rest?

    kille72 likes this.
  48. PetervdM

    PetervdM Network Guru Member

    r8000 running 2017.3 has too
  49. Tomato Mike

    Tomato Mike Network Newbie Member

    R8000 running 2017.3, cleared NVRAM after install - cannot connect on 2.4ghz network. Both 5ghz networks work fine. I tried renaming the network (same name as the 5ghz, as well as different name), changing the password, disabling wireless filter, etc... All of the obvious stuff. All previous versions of Tomato worked fine with the 5ghz and 2.4ghz having either identical or different SSIDs.

    When I try to connect, I get an "incorrect password" response. Anyone else have this issue? This happens with all of my devices, spanning across multiple brands. When I check out "Device List" in Tomato, the Tomato sees all of the devices as "Connected," however, when going to the devices themselves, they are certainly not connected.

    Everything worked fine until I enabled and disabled a Guest wireless network (which I had set to 2.4ghz). I then looked up THOSE symptoms, and found somebody else with the same issue: https://www.snbforums.com/threads/rt-ac3200-380-66_2-wireless-issue-resolved-see-post-8-24.39305/

    Disabling 2.4ghz and re-enabling it does not fix the issue. 2.4ghz seems permanently messed up.

    Resetting the NVRAM fixes the problem. Restoring my settings (saved when the problem was occurring) brings the problem back.
    Last edited: Dec 27, 2017
  50. pedro311

    pedro311 Serious Server Member

    It was said, that only bugs on fresh installations (means, with nvram clear) should be reported.
    Elfew and kille72 like this.
  51. Mercjoe

    Mercjoe Network Guru Member

    I do believe a MANUAL configuration should be included in that statement. Too many people rely on scripts or try to restore settings which could introduce config errors as well.
  52. Tomato Mike

    Tomato Mike Network Newbie Member

    If this reply was to me, I literally said that I cleared the NVRAM in my first sentence, after installing 2017.3. At the end of my post, I was simply confirming that clearing the NVRAM fixes the problem (after already having cleared it the first time, post-install) - the problem being, that when you disable a guest network, the WiFi that the guest network is linked to (in my case, 2.4ghz) no longer allows any connections.

    I tried this twice, just to confirm it is actually a bug. My router is working fine now, only because upon my last clearing of the NVRAM, I did not enable/disable my guest network. I set it up, but I didn’t turn it on or turn it off. The two times that I had my 2.4ghz go down, I had enabled and disabled the guest network.

    To reiterate, this bug is present after installing 2017.3, clearing the NVRAM, enabling a guest network and then disabling it. The only way to get the WiFi working properly again is to once again clear the NVRAM. If you save your settings after you have already disabled a guest network, and attempt to restore those settings on a cleared NVRAM, the problem will return. If you save your settings before disabling a guest network, you can restore those settings to fix it.

    Further, I posted a link explaining that people who use firmware by Merlin started to experience this problem once he incorporated the new Broadcom driver into his firmware. I don’t know if he sorted that problem out in more recent updates, but the problem cropped up for him as soon as he upgraded the driver - just as it did, here.
    Last edited: Dec 27, 2017
    Techie007 likes this.
  53. pedro311

    pedro311 Serious Server Member

    OK, I didn't get you, now I understand. Thanks for feedback.
    Techie007 likes this.
  54. Edrikk

    Edrikk Network Guru Member

    The reason for the confusion is that this sentence. In that it says erasing NVRAM fixes the issue, but reads like restoring your old config causes the break.

  55. Techie007

    Techie007 Serious Server Member

    I would suggest saving your current NVRAM dump (Administration -> Debugging), configuration (Administration -> Configuration), enabling and disabling the guest network to break it again, saving your NVRAM again, and running a diff comparison on the two saved files to narrow down what setting differences are causing it to not work.

    You should also be able to restore the saved configuration file to restore WiFi functionality as before. Just don't use this feature after resetting the NVRAM for an update/debugging as it would also copy over bad settings that you were trying to erase by clearing the NVRAM.

    Also, just for my understanding, what do you mean by "guest network"? I was not aware that Tomato offered that functionality, but rather Virtual Wireless, where the user would have to manually create the guest subnet and access point to simulate a guest network. I've not had any issues with that feature besides it not accepting custom MAC addresses on anything but wl* and wl*.0 (and I don't know how far back that bug goes).
  56. Tomato Mike

    Tomato Mike Network Newbie Member

    Ah, gotcha. I just wanted to be clear that the if you save your config after disabling the guest network, and then use the config after clearing the NVRAM (which fixes it), it will break again. I thought that should be emphasized since I had cleared my NVRAM after installing 2017.3 the first time, which means this is a genuine bug. Sorry if I wasn’t being clear enough with that - I’m just used to seeing most of the problems people report due to using their old configs after doing an upgrade without doing an NVRAM clear first. I just wanted to emphasize that I had done the clear NVRAM, and using the backup config (which was made from scratch after doing the NVRAM clear and all of my settings from scratch - plus disabling my Guest WiFi SSID - re-breaks it).

    The same problem happened with the users using the Merlin firmware with the new Broadcom drivers - so I guess there is a connection there?
  57. kw_broadens

    kw_broadens Connected Client Member

    Can someone explain the relation between the wireless driver version displayed on the "About" page:
    and the output of the "wl ver" command (and what is sent to TomatoAnon) which shows this wireless driver version:
  58. lubmar

    lubmar Connected Client Member

    did anybody try any experiments with "Advanced/Transmit Power" to get signal stronger ? ... my 5ghz is on the weak side ...
  59. Techie007

    Techie007 Serious Server Member

    What router are you talking about? If it's the Tenda AC15, there's a thread for that. And yes, I have tinkered with the settings; region #a and 400mW gets the best signal strength.

    @Tomato Mike: Did you see my previous post? I had posted while you were writing and I'm not sure if you saw it.
  60. Nite2ru

    Nite2ru Network Newbie Member


    I have Tenda AC15 router running with Tomato firmware kille72 VPN build 2017.3. Everything is working fine except iptv. When igmpproxy is starting, the message appears in the log
    Dec 29 10:35:42 Tenda user.err igmpproxy[14787]: MC-Router API already in use; Errno(98): Address already in use
    I see igmpproxy in running processes but iptv is not working.

    phyint vlan2 upstream
    phyint br0 downstream ratelimit 0
    On my previous router (Asus RT-N66U with Shibby Tomato) I think I remember seeing in the log lines with "multicast group" and addresses like 233.x.x.x or 239.x.x.x. I don't see such messages anywhere in the log of Tenda.
  61. joksi

    joksi Serious Server Member

    I will have to go back to Shibbys v 140 from 2017.3, 2.4ghz is extremely bad on my Netgear R6250 now. (like 5 mbps througput...). Haven't tested any other features yet, people seem to report IGMPproxy iussues with IP-tv too so better safe then sorry.
    I have reset nvram after upgrade, and reconfigured everything manually but that was a waste of time :( I though the new driver were "better" performing? Also I see 2.4ghz clients disconnecting randomly now...
  62. madpanter

    madpanter Networkin' Nut Member

    Using this one: tomato-RT-AC3200-ARM--2017.3-kille72--VPN-64K, installed with erase NVRAM and then also done erase all data in NVRAM trough.

    Bug: can not set custom ssid on wireless, (save button does not work)
  63. Tomato Mike

    Tomato Mike Network Newbie Member

    By Guest Network, yes, I meant that I created a VLAN with a guest subnet, access point, SSID, etc. I don't know how far back this bug goes either since I usually have "avoid NVRAM commit" turned on and that setting would probably always have been on any time I turned my guest network on and off. This time, I hadn't had it on when testing the guest network functionality, so I noticed the bug. I don't think I always had "avoid NVRAM commit" turned on every time in the past, though...

    When I get back from vacation, I'll see about comparing the two NVRAM dumps.

    Has anybody else tried this?
  64. Suva

    Suva LI Guru Member

    I am using RSync on Shibby tomato ver. 132. Suddenly it (RSync) stopped working. Can anyone guide me on how I should troubleshoot or fix this issue?

  65. maurer

    maurer LI Guru Member

    Try to run it from ssh session.
    rsync --help
  66. joksi

    joksi Serious Server Member

    Anyone with experience of Killes/Pedros firmware on Netgear R6250?
    Below is the best I get on 2.4ghz Wifi, same as with Shibbys versions...


    Upstream is always great... downstream obviously differentiates a lot. I have tried different channels, 20/40Mhz, three different clients (TV, PC with old Netgear USB-wifi stick and also new Sony Android cellphone). On all down stream is 10-20Mbps, and upstream 50-70Mbps.
  67. sac7000

    sac7000 Serious Server Member

  68. joksi

    joksi Serious Server Member

    Thank you, I have tried it and yes upstream is now maxing my Wan on 2.4ghz (90-100mbps,impressive), but downstream is still crappy in comparement, 15-20mbps...

  69. xtacydima

    xtacydima LI Guru Member

  70. sac7000

    sac7000 Serious Server Member

  71. joksi

    joksi Serious Server Member

    Eh.. What?
    I have 100mbps downstream on 5ghz....
  72. sac7000

    sac7000 Serious Server Member

    joksi Then the matter is in something else.
  73. joksi

    joksi Serious Server Member

    Yeah that's what I'm trying to say, it must be Tomato drivers or something.. That's why I'm asking if anyone else are seeing better performance om Netgear routers?
  74. gs44

    gs44 Addicted to LI Member

    Joksi, I have a Netgear R7000 and although my wireless isn't performing as bad as yours, I have noticed a pretty good slow down on actual speeds since the new wifi driver update.

    I think Kille72 needs to put the older wifi driver back into netgear builds. Other than that latest Kille72 version is rock solid and I am so happy he is continuing Tomato support
  75. joksi

    joksi Serious Server Member

    It's very strange, since Pedro earlier wrote that the new driver will make especially Netgear owners happy with beter and faster 2.4ghz performance. I would say if it has changed its only for the worse, compared to Shibbys last release v 140.

    The issue have always been with downstream performance, very big difference from upstream which is more then good.
  76. monoton

    monoton Connected Client Member

    Had an R6250 a couple of years ago. At that time I could never get one of the bands to work (guess it was the 2.4GHz band) so I sold it. The situation seems to be the same as before in regards to this router.

    Edit: This was with Shibby and Toastman, not with kille's build (don't think kille had a build that long ago)
  77. Tomato Mike

    Tomato Mike Network Newbie Member

    While I haven't really noticed much of a speed problem, I have noticed that on two occasions, the 2.4ghz radio stopped working (separate issue to the Guest Network problem I mentioned) and the router required a reboot for the problem to be fixed. I never had any of these issues with the previous driver. Could be a coincidence, but certainly worth reporting.

    Anyone else experience anything weird like that?
  78. PatrickLi

    PatrickLi New Member Member

    I've recently flashed 2017.3 to my R8000 and liking it very much. It relieved my raspberry pi from running dnsmasq and introduced a lot more feature than the official firmware.

    One of the feature I am trying to configure is multiple SSIDs. I am thinking of creating 3 SSIDs, main, iot and guest. As R8000 is a triband router that means I need to create 6 virtual wireless interfaces in addition to the existing 3. The GUI says I can do 4 vif per radio so that shouldn't be a problem.

    However, no matter which way I try, I cannot get more than 4 additional vifs. The GUI allows me to create them but the router will not broadcast more than 7 SSIDs (3 physical + 4 virtual). A bit digging reveals the following.
    • It doesn't matter which physical interface the 4 extra vifs are created on. Only the first 4 vifs created are visible.
    • The reason for this is most likely because the driver will start to issue existing MAC address to the new interfaces. Physical interfaces have MAC addresses starts with E8:FC:AF ending with 31-33 and the virtual ones starts with EA:FC:AF and ending with 30-33. Starting from the 5th vif one of the existing MAC for an existing vif will be used. Trying to change that in the MAC address page doesn't work at all. In fact the driver always override whatever you specify in the MAC address page anyway.
    This leads me to believe that it might be the driver that is causing the problem. I understand you can't do too much about the driver but I still would like to see if anyone else have tried this?
  79. rs232

    rs232 Network Guru Member

    It appears like there's a little CSS bug under Administration/Scripts (tested on 2017.2 and 2017.3).

    Basically when you try to edit any of INIT/SHUTDOWN/FIREWALL/WANUP, as soon as you start editing the tabs at the top disappear. You can still save but to make the tabs reappear you need to click the script menu again.
    Nothing major but it used to work fine so I guess it's easy to fix.

    P.S. I did just clear the NVRAM in case you're wondering
  80. PetervdM

    PetervdM Network Guru Member

    running 2017.3 on r8000, but not able to reproduce
  81. rs232

    rs232 Network Guru Member

    Sorry I would have added: Asus ac56U AIO using firefox 57.0.4


    When I click into the edit field:


    With M$ Edge works fine though...
  82. kw_broadens

    kw_broadens Connected Client Member

    I'm running 2017.3 on R8000 and using Chrome cannot reproduce your bug. If you upgraded from an earlier version of Tomato you should clear the browser cache as there have been CSS changes.

    kille72 likes this.
  83. kw_broadens

    kw_broadens Connected Client Member

    I just tried this on my R8000 running 2017.3 and on the Advanced > MAC Address page I saw that the 4 MAC addresses were repeated, but I was able to update them to 9 different MAC addresses. After reboot the 9 different MAC addresses remained intact. Interestingly, however, when I ran a wireless scan on my phone I saw the 9 SSIDs and 9 MAC addresses, but the MAC addresses were mixed up!

    kille72 likes this.
  84. rs232

    rs232 Network Guru Member

    I suppose it's safe to assume this to be a Firefox issue actually as other browsers are behaving as expected.

  85. rs232

    rs232 Network Guru Member

    Other 2 issues I'm experiencing on 2017.3:

    Issue 1) I have found is the Channel Scan function for WiFi while in Network/Basic. It does not populate the channels used by the neighbours in the channel drop down list any more. This is broken in both 2.4 and 5GHz and have tested on 2 different routers with Firefox and Edge (same result).


    The Wireless Survey under Tools seems to behave correctly instead.

    Issue 2) I have setup my primary router to work on ch11 (I have also rebooted just to make sure) where the network survey of the secondary router and my android mobile phone tell me it can see the SSID on ch1. Can anybody try to replicate this please? As mentioned I did a fresh intall with NVRAM clean performed. The nvram seems to be set correctly as far as I can see:

    Router A)

    root@tomato36k:/tmp/home/root# nvram show | grep chann
    size: 47249 bytes (18287 left)
    Router B)
    My mobile phone also confirms, the primary router does operate on CH1 and not CH11
    Last edited: Jan 8, 2018
  86. PatrickLi

    PatrickLi New Member Member

    Thanks for testing this.

    I guess I need to make some statements in my original question a bit clearer.

    I can actually change the MAC address in the GUI, and they do get written to nvram and stick on reboot. However if you go to the individual pages of the vifs you will see a warning next to the MAC Address line like the following:

    Screen Shot 2018-01-09 at 8.49.08 AM.png

    That means the WL driver overrides whatever you set in the MAC address page.

    Also interestingly I now get a empty MAC address on the 5th vif I try to create (even after reboot) and in overview it is shown as down.

    Screen Shot 2018-01-09 at 9.03.35 AM.png
    Screen Shot 2018-01-09 at 9.09.51 AM.png

    I wonder if this has anything to do with how you created the extra interfaces? All in one go or one by one, clicking the save button after each?

    I also wonder if this has anything to do with the fact that one of my SSIDs has a single quote and a space in it. When adding this SSID on the virtual wireless page, after the first save the quote and the text after the space are dropped. I have to edit it and save again for it to stick.

    I need to do more testing however this is the only router at home so the family gets really annoyed when I break it for too long.

    Thanks again for your help.
  87. kille72

    kille72 LI Guru Member

    No problem here, Firefox 57.0.4.
  88. rs232

    rs232 Network Guru Member

    I have refreshed Firefox and the problem went away, as mentioned it was an obvious catch considering Edge worked fine. The other issue on WiFi as per my post above instead seems to be a real thing...
    Last edited: Jan 9, 2018
  89. kw_broadens

    kw_broadens Connected Client Member

  90. gawd0wns

    gawd0wns Network Guru Member

    Could the list of openvpn ciphers be updated? If you run openvpn --show-ciphers, you will see that most of what is in that list has been deprecated. Also, OpenVPN defaults to AES-GCM ciphers when TLS 1.2 is used.
  91. RMerlin

    RMerlin Network Guru Member

    Those newer ciphers are only available through NCP, not through the legacy cipher keyword AFAIK.
  92. JonnY90

    JonnY90 Networkin' Nut Member

    Hey guys,

    i can't fand any information how i can flash my router with your fork. At the moment im running r7000@shibby 1.40.

    Just take the newest build vom kille72 and erase nvram after flashing? Or do i need to take the initial file?
  93. kw_broadens

    kw_broadens Connected Client Member

    That's all I did on my R8000 - went straight from Shibby 140 to kille72 with erase after flashing and then manually re-entering config.

  94. JonnY90

    JonnY90 Networkin' Nut Member

    Didn't work for me.

    I erased nvram multiple times after flasing, but everytime i made my basic configuration (WAN config, Wifi) the site to configure routing or static dhcp seems to be empty.

    So i switched back to Shibby
  95. kille72

    kille72 LI Guru Member

    Erase browser cache after update!
    JonnY90 likes this.
  96. pomidor1

    pomidor1 Networkin' Nut Member

    Attached Files:

  97. WillyTP

    WillyTP Network Newbie Member

    Hello everybody... I should report a bug on latest 2017.3, installed on an Asus RT-AC68U.
    After more or less 20 days, 24h/24 perfectly working, yesterday something went wrong.
    Router IP interface no more available, Wi-Fi network "visible" but impossible to log in into, Internet not working.

    An hardware reboot solved the problem.

    Can somebody please point me some log to look at (if possible) in order to see what happened?

  98. eangulus

    eangulus Network Guru Member

    Not sure if my problem is firmware or hardware related.

    Have had the RT-AC3200 for near a year. CPU temps have been in the low 80s. I have read elsewhere that this is fine.

    For past week thou, I have been getting reboots happening once it gets over 70 degrees.

    I have a fan blowing on it now and do long as it sits below 70 it seems stable.

    PS: Very hard to keep it cool here. There is heavy use as it's used for home business, and there are 5 teenagers using it constantly. Also here in Dubbo Australia, average days temps at this time of year is around 40C. First time in 15 years that I have had stability issues due to heat.

    Sent from my Pixel XL using Tapatalk
  99. JonnY90

    JonnY90 Networkin' Nut Member

    Ahh ok after work i will give it another try.

  100. user17600

    user17600 Reformed Router Member

    Have had the RT-AC3200 for near a year. CPU temps have been in the low 80s. I have read elsewhere that this is fine.

    For past week thou, I have been getting reboots happening once it gets over 70 degrees.

    I have had both an E3000 and N66 crap out due to heat issues. In both cases I did not monitor the temperature routinely which led to premature death. In both cases 2-3 years was the lifecycle before death.

    A replacement N66 and my curent R7000 sit on a laptop cooler and maintain CPU temperatures at or below 50C. The N66 is now 3 years old and running fine (at the parents house) and the R7000 is now approaching 1.5 years with no issues.

    YMMV but 80C (175F) is probably cooking the components and when there is even a slight cooling (at night) then something is separating or flexing leading to issues.

    You may be able to extend the life by keeping it cool, but probably the unit is done for.

    The other thing you might first check is the power connector (wall-wart). If this is failing and under/over volting that could lead to problems too. But I would cool your unit too. A laptop cooler is $10 and uses <1 watt of power. Cheap insurance.

Share This Page