1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

[Fork] Tomato by Shibby, compiled by @kille72

Discussion in 'Tomato Firmware' started by kille72, Mar 24, 2017.

  1. pedro311

    pedro311 Serious Server Member

    Last edited: Oct 17, 2017
    sac7000, pomidor1, ericjwill and 2 others like this.
  2. DooZer

    DooZer Network Newbie Member

    I made fixes for wlan quality indicator. Old one didnt just work because for atleast arm it just returns 0 noise. I took the quality calculations from asus source code.

    Code:
    if (info->RSSI >= -50)
    apinfos[ap_count].RSSI_Quality = 100;
      else if (info->RSSI >= -80)    // between -50 ~ -80dbm
    apinfos[ap_count].RSSI_Quality = (int)(24 + ((info->RSSI + 80) * 26)/10);
      else if (info->RSSI >= -90)    // between -80 ~ -90dbm
    apinfos[ap_count].RSSI_Quality = (int)(((info->RSSI + 90) * 26)/10);
      else                    // < -84 dbm
     apinfos[ap_count].RSSI_Quality = 0;
    https://bitbucket.org/hup47/tomato-arm-hud47/commits/ea6aec283193d60798dd57efa0a84fa75ac8c1d5
     
    Last edited: Oct 6, 2017
    Techie007, pomidor1, Elfew and 4 others like this.
  3. pedro311

    pedro311 Serious Server Member

  4. pedro311

    pedro311 Serious Server Member

    Last edited: Oct 17, 2017
    pomidor1 likes this.
  5. DooZer

    DooZer Network Newbie Member

  6. Elfew

    Elfew Network Guru Member

  7. DooZer

    DooZer Network Newbie Member

  8. Elfew

    Elfew Network Guru Member

    @DooZer - last question, the driver for RT-N18u is same in the newer fw (for example: 3.0.0.4.380.7743)? Or why did you use driver from 3.0.0.4.378.XXX?
     
  9. DooZer

    DooZer Network Newbie Member

    I couldnt get newer one working thats why its from 3.0.0.4.378.XXX.
     
  10. DooZer

    DooZer Network Newbie Member

    AndreDVJ, Elfew, pedro311 and 3 others like this.
  11. pedro311

    pedro311 Serious Server Member

    Thank you very much, @DooZer ;)
    Will test it just after building.
     
    pomidor1 and kille72 like this.
  12. kille72

    kille72 LI Guru Member

    Good job guys! :)
     
  13. Elfew

    Elfew Network Guru Member

  14. Elfew

    Elfew Network Guru Member

  15. pedro311

    pedro311 Serious Server Member

    Mmmm.. something's wrong here:

    Clipboard01.png
     
  16. DooZer

    DooZer Network Newbie Member

    Fixed it already. Didnt see that bug because i dont have more then one wlan here.
     
    Last edited: Oct 8, 2017
    Elfew likes this.
  17. pedro311

    pedro311 Serious Server Member

    Great! So waiting for updated commit, or just for a fix ;)
     
  18. DooZer

    DooZer Network Newbie Member

  19. pedro311

    pedro311 Serious Server Member

  20. feedzapper

    feedzapper Connected Client Member

    Works great and stable here FOR ME ;-) :

    Name TomatoUSB
    Model Netgear R7000
    Chipset ARMv7 Processor rev 0 (v7l)
    CPU Frequency 1000 MHz (dual-core)
    Flash Size 128MB

    Time Thu, 12 Oct 2017 20:45:19 +0200
    Uptime 7 days, 07:27:46

    also with openvpn 2.4.4
    running one openvpn server and two openvpn client's at the same time (nordvpn)
    thanks for the quickly update with the secure problem in the DNSmasq 2.77 version.

    ->
    Current Version: 1.28.0000 -2017.3b7-kille72- K26ARM USB AIO-64K
    Free Memory: 213.04 MB (aprox. size that can be buffered completely in RAM)
     
    Last edited: Oct 12, 2017
    kille72 likes this.
  21. Edrikk

    Edrikk Network Guru Member

    Hi there @kille72

    If you get a second maybe an updated build with Pedro's recent HTML fixes?
    I would think the functionality can be trusted now as "beta" versions hve been out for a while now...

    Probably good to get the fixes including the various pages out to people who don't update because of the beta tag?
     
    kille72 likes this.
  22. kille72

    kille72 LI Guru Member

    Hi @Edrikk

    I will do that, I'll take all the commits from @pedro311 och @AndreDVJ. Try new WiFi drivers a bit more and release version 2017.3. Cheers!
     
    Goggy, M_ars, Elfew and 2 others like this.
  23. ericjwill

    ericjwill Network Guru Member

  24. madpanter

    madpanter Networkin' Nut Member

    Is it possible to compile VPN version for 3200?

    Best regards.
     
  25. kille72

    kille72 LI Guru Member

    You have to wait for version 2017.3, so far you can use version 2017.2 VPN or 2017.3b7 AIO on AC3200
     
  26. lubmar

    lubmar Network Newbie Member

    lets hope new WiFi drivers will improve the 5G a bit (its my only "problem") ... thanks !
     
    kille72 likes this.
  27. madpanter

    madpanter Networkin' Nut Member

    Already ussing 2017.2. Tnx for reply
     
    kille72 likes this.
  28. johny_mnemonic

    johny_mnemonic New Member Member

    Did anyone notice beautiful announcement about WPA2 being successfully cracked (krackattacks com) ? ;-)
    They say, it mainly target clients, but it would be nice to get it patched on the router as well.
     
  29. pedro311

    pedro311 Serious Server Member

  30. Elfew

    Elfew Network Guru Member

    I hope there will be a new release soon with a working fix for that, because it seems to be a really serious issue.
     
    kille72 likes this.
  31. fermulator

    fermulator New Member Member

    clients need updates too;

    the vulnerability as far as I've read about thus far seem to imply primarily a client-side trickery -- can a router-side patch fully plug the hole?
     
  32. srouquette

    srouquette Network Guru Member

    yeah, it's mostly a client side problem. and it seems to impact more linux and android (41%) because of wpa_supplicant 2.4.
     
  33. darekd

    darekd Network Guru Member

    I'm running Shibby 140. Can I backup the settings, install 2017.2 (wipe NVRAM) and restore the settings? I have asus rt68.
     
  34. AndreDVJ

    AndreDVJ Addicted to LI Member

    It all depends on what you want to accomplish.

    If NVRAM values are messed up, backing up then eventually restoring from the same file won't do any good.

    I personally backup / restore values via scripts. You should be familiar with getting scripts running on your router and how to manipulate nvram values via command line.

    See http://linksysinfo.org/index.php?th...eto-identical-router-model.73381/#post-286195
     
  35. Orwell's George

    Orwell's George New Member Member

    Hi Everyone, just discovered kille72 releases recently and installed the latest test release 2017-10-05 on my Linksys EA6700.

    I get the following error message in 'Access Restriction Overview' " iptables-restore: line 40 failed", is this the place to report bugs?? Thanks

    edit: I re-installed & everything works now
     
    Last edited: Oct 18, 2017
    pomidor1 likes this.
  36. zaion520

    zaion520 New Member Member

    Hello, kille72. My English is poor
    When the modem restarts and the WAN state is disconnect, it will not be reconnected
     
  37. Tim Sudall

    Tim Sudall Reformed Router Member

    I noticed two problems;

    1. GUI seems to not display properly in chrome sometimes, this is most apparent when loading a configuration file and rebooting. Even if you are on AIO version if you load a config file sometimes only VPN menu items are shown. Its fixed by running another browser or deleting temporary internet files so it seems to be a caching issue.

    2. I thought that MiniDLNA reliability was better with this version compared to toastmans release I was running before but today the server went blank again and I had to restart it which prompted a rescan. Any reason why sometimes the server just seems to bug out and not show any media from time to time?

    I also have a question, is there a way to toggle the transmission gui on and off using a script? For example if I start transmission daemon using the same script the webgui uses, it doesn't respect it in the webgui (still shows off) any way to link this behavior so the webgui matches the status of transmission when its not started by the webgui?
     
  38. vex-box

    vex-box Serious Server Member

    @kille72

    Would you please also consider a VPN version of the EA6900 build on your next compile.

    TIA Vex
     
  39. micmanm

    micmanm Addicted to LI Member

    Can I use firmware 2017.2 on the RT-AC68U Rev.E1 router?
     
  40. pomidor1

    pomidor1 Serious Server Member

    no today - maybe in the future, another processor sdk now only RMerlin soft,
     
  41. pomidor1

    pomidor1 Serious Server Member

    @kille72 How long, and what do you hear about the new test of the wifi driver :)
     
  42. kille72

    kille72 LI Guru Member

    I'm back in 2 weeks, going on vacation first...
     
  43. fermulator

    fermulator New Member Member

    I created bitbucket issue: kille72/tomato-arm-kille72/issues/18/wpa2-vulnerability-vu-228519
    Can anyone comment (conclusively) if we can or should do anything AP-side? (i.e. is there any update useful on the tomato router side?)
     
  44. Monk E. Boy

    Monk E. Boy Network Guru Member

    AP side requires either vulnerable encryption (WPA2/TKIP or WPA2/GCMP) or 802.11r (FT). Everything else in KRACK is client side. Since Tomato doesn't implement 802.11r, the only thing you can do AP-side is to make sure you aren't using TKIP or GCMP. Client vulnerabilities can't be fixed AP side.

    I have no idea what cellular companies are going to do for all the Android phones they've spent years failing to push updates out to. Personally I'm planning on buying an unlocked phone on my own from the manufacturer so I can actually update the thing on my own, because the cellular companies sure as hell don't care.
     
    Mercjoe likes this.
  45. RMerlin

    RMerlin Network Guru Member

    It's obvious: a big, fat "nothing". Just like with all the other previous security issues that came up.
     
  46. maurer

    maurer LI Guru Member

  47. pegasus123

    pegasus123 Addicted to LI Member

  48. pomidor1

    pomidor1 Serious Server Member

    @AndreDVJ You are testing so, on bitbucket you wrote this new wifi driver from rt-n18u and what you say is some progress in netgear performance?
     
  49. AndreDVJ

    AndreDVJ Addicted to LI Member

    Nothing changed on my Netgears. Performing the same for all devices I have.

    Some config lines may be, may not be honored by the driver itself (~/release/src-rt-6.x.4708/wl/linux/wl_apsta.o)
     
    pomidor1 likes this.
  50. pedro311

    pedro311 Serious Server Member

    Here you go:
    https://bitbucket.org/pedro311/freshtomato-arm/commits/61cd758102c5f3840348a66aa9676177daa3c9d9
     
  51. pedro311

    pedro311 Serious Server Member

    PS. I can build image with latest patches/updates/changes if you want to test it.
     
    Elfew, sszpila and pomidor1 like this.
  52. pomidor1

    pomidor1 Serious Server Member

    would have been nice
    I would like to try to install a new cloud and you have 5.6 to add php so it can work
    where to find images?
    so generally this is great thanks for your work on tomato

    R6400 please:)
     
  53. pedro311

    pedro311 Serious Server Member

    Last edited: Oct 26, 2017
    Goggy and pomidor1 like this.
  54. pomidor1

    pomidor1 Serious Server Member

    flash ok
    In the evening I will test your bulid, wifi driver and php 5.6.31 ;-)
     
  55. blakey

    blakey New Member Member

    Hi, I use kille72 fork and I'm happy with it, but I have a question, can the LEDs work on the AC56U router?
     
    Last edited: Oct 26, 2017
  56. blakey

    blakey New Member Member

    It will be nice, could you build for AC56U?
    Thanks for your work.
     
    Last edited: Oct 26, 2017
  57. pedro311

    pedro311 Serious Server Member

  58. blakey

    blakey New Member Member

    Woow…, excellent, thanks, wireless signal is very strong (twice) and good, 5 meters from the router the quality was 51 and now is 100.
     
  59. sszpila

    sszpila Reformed Router Member

    I must rollback my Ac56u to 2017.2 because 2.4GHz network was not working properly. My foscam wifi camera disappearing for about 2 minutes from connect. It's visible in tomato devices page, but no ping at all. Reverting to 2017.2 and camera working perfectly. Camera using 2.4GHz network with wpa2/AES.

    Wysłane z mojego 2014811 przy użyciu Tapatalka

    Also, there is nothing in tomato logs after camera dissappeared.

    One more thing, laptops has trouble to connect to 5GHz band, resulting defaults to 2.4GHz unless disabled and enabled 2.4GHz band on router.

    Could you make a test build for AC56u with old wl driver?
     
    Last edited: Oct 26, 2017
  60. blakey

    blakey New Member Member

    Did you try to restart devices? I have more than 10 devices connected to AC56U wireless (2.4 and 5 GHz) and wired but I don"t have that issue, so far it has not thrown the connected devices.
     
  61. sszpila

    sszpila Reformed Router Member

    Yes, restarted several times, only revert to 2017.2 makes my wifi network work properly.

    Wysłane z mojego 2014811 przy użyciu Tapatalka
     
  62. blakey

    blakey New Member Member

    Strange, try another wireless channel (1-11).
     
  63. Elfew

    Elfew Network Guru Member

    It seems to be an issue with your installation, did you reset NVRAM and set everything from scratch? I have really good time with a new updated wifi driver on my second device!
     
  64. blakey

    blakey New Member Member

    Is it necessary to delete NVRAM?
     
  65. pomidor1

    pomidor1 Serious Server Member

    According to my opinion it is necessary to clean nvram,
    This is the effect of changing the tab Wireless Virtual Interfaces and Wireless filter.

    After cleaning, the only drawback I noticed. Haha Pedro blocks Shibi's side and I can not get on the tomato anon and to the base of the skins.
    Maybe Shibby is a miner hehe and he extracts bitcoins ;-)


    not only me have troubles
    http://www.linksysinfo.org/index.php?threads/tomato-shibbys-releases.33858/page-80#post-291892
    3, 4 days ago Shibby wrote a post on the openlinksys website so it's rather a case of Shibbie's website
     
    Last edited: Oct 26, 2017
  66. Elfew

    Elfew Network Guru Member

    @blakey - it is recommended... if there are new entries and changes in NVRAM between versions, it causes issues. So clean NVRAM and reboot router. Then set everything, no back ups
     
  67. blakey

    blakey New Member Member

    Okay, thanks, I will make it.
     
  68. sszpila

    sszpila Reformed Router Member

    Ok. Give one more chance. Since I can't do clear nvram at this time, I flashed test version, several reboots, clicked save on wireless filter and wireless interfaces tabs and waiting....

    Wysłane z mojego 2014811 przy użyciu Tapatalka
     
  69. Elfew

    Elfew Network Guru Member

    without clearing NVRAM it will be same... there are new entries, thats why old version works and the new one is not...
     
  70. pedro311

    pedro311 Serious Server Member

    Goggy, Edrikk, The Master and 2 others like this.
  71. sszpila

    sszpila Reformed Router Member

    So far it's working. I leaved camera idling for more than 5 minutes (tomato show 1/1 tx/rx rate) and connect without any problems. To make sure I leave this camera idle for more than half a hour and check again.

    Wysłane z mojego 2014811 przy użyciu Tapatalka
     
  72. sac7000

    sac7000 Reformed Router Member

  73. pedro311

    pedro311 Serious Server Member

    This is not Multi Language Tomato, so no chance to add any language pack, sorry.
     
  74. sszpila

    sszpila Reformed Router Member

    It's still working after night :)

    Wysłane z mojego 2014811 przy użyciu Tapatalka
     
  75. pedro311

    pedro311 Serious Server Member

  76. pomidor1

    pomidor1 Serious Server Member

    Attached Files:

  77. lubmar

    lubmar Network Newbie Member

  78. pedro311

    pedro311 Serious Server Member

    Good to hear it :)

    Well, I've already uploaded "tomato-R6300v2-ARM--2017.3b9-pedro--AIO-64K" but ok, will build VPN version in a moment.
     
  79. pedro311

    pedro311 Serious Server Member

  80. monoton

    monoton Connected Client Member

    Right now I have my 5GHz band set to 80MHz, but If I click Save on Advanced-Virtual Wireless Page the 5GHz band will still automatically be set to 20MHz.
    So if anything is changed in Advanced-Virtual Wireless you still have to go back to Basic-Network to set the 5GHz band back to 80MHz.

    Otherwise everything else I've tested seems to work just fine, including setting Priority for br0 in the bandwidth limiter.

    EA6400 - xvortex CFE - 1.28.0000 -2017.3b9-pedro- K26ARM USB AIO-64K
     
  81. PeeJajL

    PeeJajL New Member Member

    Good morning all.

    I own an ea6200, Q87-ea6200 and I'd like to install tomato on it. Will this firmware work?

    Thanks.
     
  82. pedro311

    pedro311 Serious Server Member

    Thanks for feedback, will look at it once again.
     
  83. lubmar

    lubmar Network Newbie Member

  84. Magnus

    Magnus Network Newbie Member

    speed usb3.0 still 3 times slower than on stock AC56U. 22MB/s vs 63 MB/s Samba :( Only fat minus.
     
  85. pomidor1

    pomidor1 Serious Server Member

    from where you have this data
    Shibby tested this router, and on Rmerlin and Tomato had a USB3 speed of up to 31 MB / s and the OFW had 23 MB / s.
     
  86. Magnus

    Magnus Network Newbie Member

    Test with firmware 3.0.0.4.374.4561.

    [​IMG] [​IMG]

    obviously, in tomato mode 2.0
     
  87. cloneman

    cloneman Networkin' Nut Member

    Can someone look into the webui bandwidth calculations on the right of the select boxes in qos-settings.asp ? They have disappeared since shibby multiwan, they work in 1.32. I wonder if it's something very silly that caused those numbers to disappear. I don't know javascript or I'd have looked into it already.
     
  88. Elfew

    Elfew Network Guru Member

    It is reimplemented by @pedro311 in his latest build ;)
     
    cloneman likes this.
  89. Tomato Mike

    Tomato Mike Network Newbie Member

    Hey all,

    Long time Tomato user here (I have a Netgear R8000). I figured I would join this site so we could collaborate. I have some suggestions, but since my account is new, I cannot post any github links at the moment (so that will have to wait a bit).

    I was also curious if anyone was working on Netgear's 2017 model routers, such as the R8000p? The 'p' models apparently come with AES acceleration built into the CPU, so VPN speeds should get a major improvement. I don't plan on upgrading any time soon, but I just wanted to know if that was on anybody's radar.

    Lastly, I'm also aware that LEDE has come up with a "fix" for "KRACK" - where there is an option that supposedly protects unpatched WPA2 clients. Is this possible for Tomato?

    You guys are all doing amazing work with Tomato, and I wanted to thank you for the great work. Thank you, so much for the amazing firmware! I look forward to being able to post links so I can make some suggestions to improve Tomato's Adblock feature.
     
    visceralpsyche likes this.
  90. pomidor1

    pomidor1 Serious Server Member

  91. Magnus

    Magnus Network Newbie Member

    so with the USB 3.0 speed?
     
  92. pomidor1

    pomidor1 Serious Server Member

  93. Magnus

    Magnus Network Newbie Member

  94. PetervdM

    PetervdM Network Guru Member

  95. Tomato Mike

    Tomato Mike Network Newbie Member

  96. Tomato Mike

    Tomato Mike Network Newbie Member

    In any case, I wanted to offer a suggestion to improve the Adblock portion of Tomato. I was thinking that you guys could build in some of the suggestions here: https://wally3k.github.io/ - at least the major ones with the check mark next to them (which means there are no false positives), as well as upgrading some of the links that you guys already have built in, with their https version. Including a Bitcoin Mining list might be nice, as well: https://raw.githubusercontent.com/ZeroDot1/CoinBlockerLists/master/hosts

    I've been using the majority of the lists above for a while on my own with Tomato, and I thought some of the users might benefit from the new suggestions/https editions.
     
    The Master and RichtigFalsch like this.
  97. pedro311

    pedro311 Serious Server Member

  98. Tomato Mike

    Tomato Mike Network Newbie Member

    Thanks, pedro! I'm running your new version on my R8000. Everything is working fine (so far!) without flashing the NVRAM (including the new 'disable wireless filter' option for my guest network). I am coming off of kille72's 2017.3b7 version, which I did do an NVRAM flash after installing.

    I also like seeing the more accurate signal strength (Quality) under the Device List. Thanks, so much!
     
    szpunk and pedro311 like this.
  99. pedro311

    pedro311 Serious Server Member

    OK, so let's move on.

    Another compilation: 2017.3b12.
    I've added there a huge amount of @tsynik commits, and hope that it will work for you ;) At least, for me it works on RT-N18U + lte :p

    The same place: https://mega.nz/#F!QywknIpa!5JwWNIfEwCOKXqXG0AOh4w
    Folder "freshtomato-arm 2017.3b12" of course.

    Specially interested in feedback from ppl on PPPoe (reconnect is working again?), PPTP and L2TP connection.
    Reportedly been fixed PPTP client/server - also will be pleased to hear feedback on this.

    If you need image for another router - just let me know here.
     
    Elfew, pomidor1, Edrikk and 4 others like this.
  100. PetervdM

    PetervdM Network Guru Member

    i've downloaded and installed pedro 2017.3b11 over kille 2017.2 without clearing nvram and ran it for over a day now. i've not tested all yet, but it appears that wireless performance is better than before. also the number of "dhd_prot_ioctl: status ret value" errors in syslog is greatly reduced, sometimes i had to power down and restart the router because the log was flooding by these entries.
     

Share This Page