1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

[Fork] Tomato by Shibby, compiled by @kille72

Discussion in 'Tomato Firmware' started by kille72, Mar 24, 2017.

  1. pedro311

    pedro311 Reformed Router Member

    Last edited: Oct 17, 2017 at 12:40 AM
  2. DooZer

    DooZer Network Newbie Member

    I made fixes for wlan quality indicator. Old one didnt just work because for atleast arm it just returns 0 noise. I took the quality calculations from asus source code.

    Code:
    if (info->RSSI >= -50)
    apinfos[ap_count].RSSI_Quality = 100;
      else if (info->RSSI >= -80)    // between -50 ~ -80dbm
    apinfos[ap_count].RSSI_Quality = (int)(24 + ((info->RSSI + 80) * 26)/10);
      else if (info->RSSI >= -90)    // between -80 ~ -90dbm
    apinfos[ap_count].RSSI_Quality = (int)(((info->RSSI + 90) * 26)/10);
      else                    // < -84 dbm
     apinfos[ap_count].RSSI_Quality = 0;
    https://bitbucket.org/hup47/tomato-arm-hud47/commits/ea6aec283193d60798dd57efa0a84fa75ac8c1d5
     
    Last edited: Oct 6, 2017
    pomidor1, Elfew, M_ars and 3 others like this.
  3. pedro311

    pedro311 Reformed Router Member

  4. pedro311

    pedro311 Reformed Router Member

    Last edited: Oct 17, 2017 at 12:42 AM
    pomidor1 likes this.
  5. DooZer

    DooZer Network Newbie Member

  6. Elfew

    Elfew Network Guru Member

  7. DooZer

    DooZer Network Newbie Member

  8. Elfew

    Elfew Network Guru Member

    @DooZer - last question, the driver for RT-N18u is same in the newer fw (for example: 3.0.0.4.380.7743)? Or why did you use driver from 3.0.0.4.378.XXX?
     
  9. DooZer

    DooZer Network Newbie Member

    I couldnt get newer one working thats why its from 3.0.0.4.378.XXX.
     
  10. DooZer

    DooZer Network Newbie Member

    AndreDVJ, Elfew, pedro311 and 3 others like this.
  11. pedro311

    pedro311 Reformed Router Member

    Thank you very much, @DooZer ;)
    Will test it just after building.
     
    pomidor1 and kille72 like this.
  12. kille72

    kille72 LI Guru Member

    Good job guys! :)
     
  13. Elfew

    Elfew Network Guru Member

  14. Elfew

    Elfew Network Guru Member

  15. pedro311

    pedro311 Reformed Router Member

    Mmmm.. something's wrong here:

    Clipboard01.png
     
  16. DooZer

    DooZer Network Newbie Member

    Fixed it already. Didnt see that bug because i dont have more then one wlan here.
     
    Last edited: Oct 8, 2017
    Elfew likes this.
  17. pedro311

    pedro311 Reformed Router Member

    Great! So waiting for updated commit, or just for a fix ;)
     
  18. DooZer

    DooZer Network Newbie Member

  19. pedro311

    pedro311 Reformed Router Member

  20. feedzapper

    feedzapper Connected Client Member

    Works great and stable here FOR ME ;-) :

    Name TomatoUSB
    Model Netgear R7000
    Chipset ARMv7 Processor rev 0 (v7l)
    CPU Frequency 1000 MHz (dual-core)
    Flash Size 128MB

    Time Thu, 12 Oct 2017 20:45:19 +0200
    Uptime 7 days, 07:27:46

    also with openvpn 2.4.4
    running one openvpn server and two openvpn client's at the same time (nordvpn)
    thanks for the quickly update with the secure problem in the DNSmasq 2.77 version.

    ->
    Current Version: 1.28.0000 -2017.3b7-kille72- K26ARM USB AIO-64K
    Free Memory: 213.04 MB (aprox. size that can be buffered completely in RAM)
     
    Last edited: Oct 12, 2017
    kille72 likes this.
  21. Edrikk

    Edrikk Network Guru Member

    Hi there @kille72

    If you get a second maybe an updated build with Pedro's recent HTML fixes?
    I would think the functionality can be trusted now as "beta" versions hve been out for a while now...

    Probably good to get the fixes including the various pages out to people who don't update because of the beta tag?
     
    kille72 likes this.
  22. kille72

    kille72 LI Guru Member

    Hi @Edrikk

    I will do that, I'll take all the commits from @pedro311 och @AndreDVJ. Try new WiFi drivers a bit more and release version 2017.3. Cheers!
     
    Goggy, M_ars, Elfew and 2 others like this.
  23. ericjwill

    ericjwill Network Guru Member

  24. madpanter

    madpanter Networkin' Nut Member

    Is it possible to compile VPN version for 3200?

    Best regards.
     
  25. kille72

    kille72 LI Guru Member

    You have to wait for version 2017.3, so far you can use version 2017.2 VPN or 2017.3b7 AIO on AC3200
     
  26. lubmar

    lubmar Network Newbie Member

    lets hope new WiFi drivers will improve the 5G a bit (its my only "problem") ... thanks !
     
    kille72 likes this.
  27. madpanter

    madpanter Networkin' Nut Member

    Already ussing 2017.2. Tnx for reply
     
    kille72 likes this.
  28. johny_mnemonic

    johny_mnemonic New Member Member

    Did anyone notice beautiful announcement about WPA2 being successfully cracked (krackattacks com) ? ;-)
    They say, it mainly target clients, but it would be nice to get it patched on the router as well.
     
  29. pedro311

    pedro311 Reformed Router Member

  30. Elfew

    Elfew Network Guru Member

    I hope there will be a new release soon with a working fix for that, because it seems to be a really serious issue.
     
    kille72 likes this.
  31. fermulator

    fermulator New Member Member

    clients need updates too;

    the vulnerability as far as I've read about thus far seem to imply primarily a client-side trickery -- can a router-side patch fully plug the hole?
     
  32. srouquette

    srouquette Network Guru Member

    yeah, it's mostly a client side problem. and it seems to impact more linux and android (41%) because of wpa_supplicant 2.4.
     
  33. darekd

    darekd Network Guru Member

    I'm running Shibby 140. Can I backup the settings, install 2017.2 (wipe NVRAM) and restore the settings? I have asus rt68.
     
  34. AndreDVJ

    AndreDVJ Addicted to LI Member

    It all depends on what you want to accomplish.

    If NVRAM values are messed up, backing up then eventually restoring from the same file won't do any good.

    I personally backup / restore values via scripts. You should be familiar with getting scripts running on your router and how to manipulate nvram values via command line.

    See http://linksysinfo.org/index.php?th...eto-identical-router-model.73381/#post-286195
     
  35. Orwell's George

    Orwell's George New Member Member

    Hi Everyone, just discovered kille72 releases recently and installed the latest test release 2017-10-05 on my Linksys EA6700.

    I get the following error message in 'Access Restriction Overview' " iptables-restore: line 40 failed", is this the place to report bugs?? Thanks

    edit: I re-installed & everything works now
     
    Last edited: Oct 18, 2017 at 12:17 AM
    pomidor1 likes this.
  36. zaion520

    zaion520 New Member Member

    Hello, kille72. My English is poor
    When the modem restarts and the WAN state is disconnect, it will not be reconnected
     
  37. Tim Sudall

    Tim Sudall Reformed Router Member

    I noticed two problems;

    1. GUI seems to not display properly in chrome sometimes, this is most apparent when loading a configuration file and rebooting. Even if you are on AIO version if you load a config file sometimes only VPN menu items are shown. Its fixed by running another browser or deleting temporary internet files so it seems to be a caching issue.

    2. I thought that MiniDLNA reliability was better with this version compared to toastmans release I was running before but today the server went blank again and I had to restart it which prompted a rescan. Any reason why sometimes the server just seems to bug out and not show any media from time to time?

    I also have a question, is there a way to toggle the transmission gui on and off using a script? For example if I start transmission daemon using the same script the webgui uses, it doesn't respect it in the webgui (still shows off) any way to link this behavior so the webgui matches the status of transmission when its not started by the webgui?
     
  38. vex-box

    vex-box Serious Server Member

    @kille72

    Would you please also consider a VPN version of the EA6900 build on your next compile.

    TIA Vex
     
  39. micmanm

    micmanm Addicted to LI Member

    Can I use firmware 2017.2 on the RT-AC68U Rev.E1 router?
     
  40. pomidor1

    pomidor1 Serious Server Member

    no today - maybe in the future, another processor sdk now only RMerlin soft,
     

Share This Page