1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

FTP Problems with WAG54G

Discussion in 'Other Linksys Equipment' started by RolloTomasi, Apr 24, 2005.

  1. RolloTomasi

    RolloTomasi Network Guru Member

    Hi there,

    Got the WAG54G on Friday and set it up with no major problems, and everything has been fine until today. Today is when I first tried uploading files to my website via FTP. I use CuteFTP 6.0 and have had no problems using it before operating with a router (before I was using a DSL modem connected via USB) so I assume that eliminates any firewall based problems. I'm new to this whole world of routers and networks etc so don't really know a lot about it.

    After I couldn't get it to work at first I checked through the user guide for any mention of FTP and tried adjusting various settings to no avail. I then rang Linksys technical to support and they said I would have to enable FTP in single port forwarding, and talked me through that. But still had the same problem. Next we tried disabling all local firewalls that didn't work either. Finally we tried to enable it through DMZ but still no luck. At this point the only thing she could recommend was upgrading the firmware and then trying things again. I downloaded and installed the latest compatible version from Linksys.com (WAG54GV2-EU_AnnexA_ETSI_v1.00.19_001_code) and it said that the upgrade was successful. But after rebooting the version number is still the same as the original (1.00.19, Nov 30 2004) so i'm not sure if that means I had the most up-to-date anyway or if the upgrade didn't work.

    Away from fiddling with WAG54G set-up i've read through much of the CuteFTP help pages. They claim you should be able to run behind a router normally, but if not give a number of options to try. None of these made any difference either. So the problem remains. I double-click to upload the file, it shoots upto 100% as normal, but then never arrives in the webspace as if it's being stopped somewhere en route. Then if I cancel the transfer the name appears in the webspace but a 0 byte file. To me this all points to the router being the problem, so can anyone advise me on what to do next?

    Thanks for reading,
    RT
     
  2. Guyfromhe

    Guyfromhe Network Guru Member

    try setting your FTP cleient to use PASV mode see if that helps, if the DMZ was setup properly it should have worked, but give pasv a shot.
     
  3. DocLarge

    DocLarge Super Moderator Staff Member Member

    If by chance running in pasv mode still doesn't work, then just use port triggering. This is how I ran my WAG54G to connect to my ftp server. Single Port forwarding worked for me but again, as I've posted before, I had version 1.01.6. See if you can download this version because it is stable provided you:

    1) Get static ip
    2) Get dynamic dhcp or static ip (or use both like I do)
    3) Use "connect every 30 seconds) option

    Doc
     
  4. RolloTomasi

    RolloTomasi Network Guru Member

    This has developed into one of the most ridiculous situations i've ever experienced, in terms of making no sense at all to me.

    First let me say that my friend has the same router and FTP program, and a similar Dell computer (in case that's relevant) and she set-up everything up and has experienced no problems with anything. So it seems that whatever is causing this is specific to my system (or the unlikely final alternative, my isp (aol)).

    I attempted the things you suggested but simply switching to PASV mode had no effect. And I attempted the latter idea which also didn't work, but it's possible I did something wrong, I switched so many options and what not yesterday I often lost track of where I was upto. I didn't attempt any further changes to the firmware at this time.

    After much fiddling on my own I got in contact with my technoligically minded friend and with his help I did manage to get the FTP working properly. This was achieved by changing the numbers of the ports the router was suggesting to me, enabling them both, changing the ftp program to PORT mode and finally disabling both windows and router firewalls (I was still using McAfee). So this seemed to be the solution. However, with this new config, I discovered MSN messenger wouldn't work, a number of sites wouldn't open for me (I have a list if it's relevant) and that the connection seemed a little slower. Back in contact with my friend who got me to go back through the things we had changed to see if any 'stabilised' the connection. Immediately that I turned the router firewall back on MSN messenger connected and the sites became available. But as you might have guessed, FTP transfers would now not work again.

    So with a little more experimentation I have pinpointed it to the router firewall. With it enabled my connection works properly but I can't ftp. With it disabled I can FTP properly but certain sites are inaccessible. Has anybody ever heard of anything like this? And more importantly does anybody have any suggestions what I can about it?
     
  5. DocLarge

    DocLarge Super Moderator Staff Member Member

    Dude,

    what the "Hiz-ell" is going on with your WAG?!?! There shouldn't be this much strain setting it up to run an ftp server, much less using MSN. You must have a version 2 WAG, don't you?

    Doc
     
  6. RolloTomasi

    RolloTomasi Network Guru Member

    I do have a V2, yes.

    But I was just on my way here to say that things seem to be working now. It seemed everything that I tried to correct just escalated into something else, so I decided the best thing to do was delete everything off and start again. This time PASV mode still didn't work, but opening the ports and selecting PORT mode is working with the router firewall still enabled (and the connection to my laptop is still stable, which is another issue I didn't even get round to mentioning here!), so i'm happy for now. Thanks for your help.
     

Share This Page