1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Getting lower download speeds through WRT54Gv4 router & Tomato

Discussion in 'Tomato Firmware' started by WhitePhoenix, May 19, 2012.

  1. WhitePhoenix

    WhitePhoenix Serious Server Member

    Hello all. I have a 30 / 5 connection with Roadrunner Time Warner Cable.

    If I connect my PC directly into my router (PC has Gigabit Ethernet), speedtests that I do to the closest server, my local ISP's speedtest server (http://speedtest.oceanic.com), yield pretty much the advertised 30 Mbps down / 5 Mbps up speed. I also tried some Speedtest.net tests to West Coast servers (I am in Hawaii) and I still get these speeds.

    However, if I plug my PC into my WRT54Gv4 router with Tomato 1.28 firmware installed, my upload speed stays the same (save for about ~10% router/network overhead), but I lose anywhere between 8 Mbps - 15 Mbps, so I end up getting 15-22 Mbps download speeds.

    I notice if I reboot both the router and modem, I get 30 Mbps speeds for a short while, but it gradually starts dropping down to lower speeds, eventually "leveling off" at 15.

    I can just be idle and I still get these speeds - nothing seems to trigger it directly. Is this a fault of my router?

    I checked to make sure all my cabling is Cat5e, and already tried to do the following:
    - 30/30/30 reset of router
    - Messing around with MTUs on both the PC and router
    - Changing the MAC address of the WAN port and restarting both the router and modem (someone said this worked for them in another forum).
    - Switching LAN ports PC is connected to.
    - Switching the cable that's connected from the router's WAN port to the modem.
    - Forcing my network card and Tomato to negotiate a 100 Full Duplex connection.

    None of this stuff seems to have helped.

    My router is overclocked to 250 Mhz. I also have a spare Asus RT-N12 that I recently upgraded to TomatoUSB.

    Is the 30 Mbit download speed forcing my router to hit its limits? I spoke with someone at Linksys Online Chat Tech Support and they said the port speed of the WAN port is 50 Mbps, which is well above what my current Internet speeds are.

    Should I just upgrade to the RT-N12 so that I don't have to deal with this or is there some sort of configuration issue on my router or my PC that is causing this? Please remember, if I connect directly to the cable modem, I get full advertised speeds.

    Your help would be greatly appreciated.

    I might try flash to stock Linksys firmware and see if that helps, but I really don't want to do that unless I absolutely have to.
  2. NeutralGold

    NeutralGold Serious Server Member

    I had a WRT54G V2 that I just upgraded from, I ran standard tomato on it for a while and then upgraded to "tomato.RAF-K24-1.28.8515_lite.trx". I recommend trying a different build rather than standard tomato if you want to keep using the WRT54G. I have the same u/d speed as you and never had any issues with my V2. Maybe a different build will fix your problem. The Wan port on your router should actually be 100 mbps despite what the tech told you.

    Good luck.
  3. WhitePhoenix

    WhitePhoenix Serious Server Member

    I was thinking of switching to TomatoUSB or a Teaman build. I don't look forward to having to punch in all my settings again, but if that's what it takes to make it work I'll do it.

    Any second opinions before I go ahead and do this?
  4. NeutralGold

    NeutralGold Serious Server Member

    I've only ever tried the version I listed and standard tomato, both ran like the champs and never had any issues. Also after you swap, make sure to clear nvram in administration before you add your settings, to be sure that there's nothing lingering from anything else that could cause you problems.
  5. WhitePhoenix

    WhitePhoenix Serious Server Member

    Yeah, gonna make sure to do that. Can't get access to Victek's site. Seems to be down - did you get your trx file from that site? Does Victek have a mirror that can handle traffic? :(
  6. NeutralGold

    NeutralGold Serious Server Member

    Yeah, http://victek.is-a-geek.com/tomato.html. Apparently it is down. Sorry I'm not sure where else to get it. It being down is probably temporary as I visited it just last week. If toastman has a version for your router, try it. His builds are usually pretty solid and have some really nice QoS settings.
  7. WhitePhoenix

    WhitePhoenix Serious Server Member

    Yeah, I got the firmware.

    Tried Teaman, did the MAC address trick and power cycled both the router and cable modem. Didn't work.
    Tried the latest VicTek RAF build, didn't work.
    Tried the special older build based off of an older kernel (the one VicTek guarantees 60-80 Mbps WAN/LAN throughput); initially didn't work. I had better speeds (from 15-18 Mbps to 22-24 Mbps). Did a combination of the MAC address trick, overclocking it to 250 Mhz, and power cycling both the router and cable modem and now I'm getting full speeds.

    I really wished the latest VicTek build worked though, I liked the GUI additions, but them's the breaks. Anyone else had this problem? I don't understand why I need a specific firmware build to take advantage of what the WAN port is capable of. Makes no sense.

Share This Page