1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

hard bricked wrt54g v 3.0

Discussion in 'Cisco/Linksys Wireless Routers' started by Crashmaxed, Jul 22, 2005.

  1. Crashmaxed

    Crashmaxed Network Guru Member

    I just recently got a revision 3.0 WRT54G and the first thing i did after i got my grubby little hands on it was put freeman on it. It worked find expect that it would screw up the DHCP assignment on the internet uplink. I set defaults on options then flashed back to standard linksys firmware. After that I flashed on eWRT.....bad idea. It crashed hard on me and wouldn't even do the 5 second boot wait ping reply. I've done the pin 16 to antenna ground short and now i can get a ping reply whenever i start my router. problem is that it (the power light) just sits and blinks constantly. it never goes solid. I can constanly get a ping replay and can also use tftp to upload an image...it says successful but after rebooting it still does the same thing. Is there a certain name the .bin file has to be? i've heard of jtag cables and read a lot on them but don't quite understand how they work. Right about now i'm willing to try anything.
  2. bimmerm3m5

    bimmerm3m5 Network Guru Member

    Just like you, my v2 device doesn't reboot after a firmware upgrade (pings work after the antenna/pin 16 short circuit). I don't follow the JTAG setup either. I've never really soldered before.
  3. jagboy

    jagboy Network Guru Member

    make sure the tftp .bin file is less than 3mb
  4. cgondo

    cgondo Network Guru Member

    i had the same issue as yours but when i tftp Linksys old firmware (<3mb) i had the same problem. LED still blinking although tftp was completed.
  5. jagboy

    jagboy Network Guru Member

    i ran into this same thing with my wrt54gv2 and found out that the flash chip can only be grounded to the antenna for many times and the flash chip gave out and i got no more pings out of it. but one thing i nocticed is that if you i did the jtag mod then i could have saved it instead of grounding the flash chip until it died :cry:
  6. Crashmaxed

    Crashmaxed Network Guru Member


    All the firmware i've tried is below 3mb...in fact i've even used the firmware v3.01 utility that is downloaded directly off of linksys and it says success but after reboot it still blinks. I know how to solder good enough to add a jtag.....i've seen enough to know what a jtag cable is and how to make one but i haven't seen anything on what software to use over it or how to do it or anything.
  7. jagboy

    jagboy Network Guru Member

    look into my guide that i made here:

    and @ the bottom the last tip i think tip # 4 or somthing there is mention of a hairydairy mod or somthing it is a pdf open that and i think it talks about the software you use.

    hope this helps
  8. cgondo

    cgondo Network Guru Member

    I grounded the chips a couple of times and managed to upload firmware twice. Now i cant even get the ping reply anymore. Does this mean that the chip is dead now and even JTAG would not be able to save it?
  9. jagboy

    jagboy Network Guru Member

    it could be. that is what happened to me. maybe a jtag could help.
  10. cgondo

    cgondo Network Guru Member

    if JTAG does not help, do you think replacing the flash chip will? how feasible is this? I just do not want to have the WRT54G as a paperweight. Feel sorry for it
  11. jagboy

    jagboy Network Guru Member

    yeah i did for mine when i bricked it. funny, you kind of get attachted to it.

    but anyway back to reality replacing the flash is, i dont think going to work. i dont think that the flash chip on the wrt is a buy off of the shelf part. unless you can find it on ebay or somthing. but i think you are beter off just buying a new one and selling the bricked one on ebay. just mention it is a brick dont want to scew over some guy. sorry.

    well here is a link if you are interested.

    i found out that the flash chip comes in 64mb that would be cool if they used that instead of the 32mb.
  12. cgondo

    cgondo Network Guru Member

    isnt the 64MB is the one they use in WRT54GS? I am just wondering if there is any hope in reviving the router using JTAG now. Do you think?
  13. Crashmaxed

    Crashmaxed Network Guru Member


    I think i'll get or build a jtag cable....is there any software to use over the jtag that exists for windows????
  14. jagboy

    jagboy Network Guru Member

    no the flash chip that is in the WRT54Gs is the 32mb.
    i cant say weather it will work or not unles you try it.

    and here is a site that will make you the jtag and all the parts. i dont know if they provide the software.
  15. jagboy

    jagboy Network Guru Member

    yes i am pretty sire there is the software for windows but it is very very hard to find. try to contact the http://www.theforestnetworking.com/hardware.php

    and ask them.
  16. phonedaddy

    phonedaddy Network Guru Member

    I experienced the same issues with my WRT54GS V2.0 after a firmware update that went south. Here is what I did to recover it.

    1. Remove all cables.

    2. Default and initialize the router by removing power, hold in the reset button and apply power. Hold in the reset button for 30 seconds after power is applied.

    3. Let the router sit for 2 minutes.

    4. Remove power.

    5. Set your PC NIC card for 10Mbps Half Duplex, IP address, mask, then disable and enable the network connection.

    6. Connect your PC NIC to port 1 of the router.

    7. Short pins 15 and 16 of the Intel flash chip in the router. If it's not an Intel flash chip don't short the pins, do some research.

    8. Apply power to the router and keep the pins shorted for 2 seconds.

    9. Remove the short on the pins.

    10. Check if you can ping If ping is successful, you are ready to flash. If ping fails, start at item 1 again.

    11. Set up the TFTP utility on your PC and type in all the command line parameters except ENTER. This gets you ready to flash. Your BIN file must be less than 3 MB in size and must be named code.bin

    12. Watch the DMZ led, it will be flashing slowly, the POWER led will be flashing at a faster rate. When the DMZ led is off hit the ENTER key to run your TFTP utility.

    13. If the TFTP utility reports success, DO NOTHING. The DMZ led will remain off. Let the router sit and it will reboot after 30 to 60 seconds or more. Let the router fully reboot and initialize itself before attempting to communicate with it again. If the TFTP utility reports failure or timeout, start at item 12 again. If you get a second failure or timeout, return to item 1 and start again, do not rush this process it will only end in failure each time.

    Good luck and happy flashing. (grin)
  17. jagboy

    jagboy Network Guru Member

  18. malfeasance

    malfeasance Network Guru Member

  19. cgondo

    cgondo Network Guru Member

    i have tried pretty much all the suggested method besides the JTAG approach. I am just about to give up now. JTAG is my final hope. I did manage to upload the firmware twice on the router but maybe i was impatient enough to wait for the router to re-boot itself so i re-booted it myself. I wished i had been a bit more patient. I think i might have done the flash chip good ... JTAG is about the only line between a working router and an expensive brick.
  20. jjmack

    jjmack Network Guru Member

    Staples has the WRT54G for $39

    Given the effort of trying to replace the chip and so forth, it may be worth replacing the unit at this point from a time/cost analysis.
  21. jagboy

    jagboy Network Guru Member

    i mean go for the jtag but replacing the flash chip i not thnk it will work. your odds are slim to none. so youare better off buying a new one. and selling the bricked one.

Share This Page