1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Having a major problem with my new Asus RT-N16, even with different Mods...

Discussion in 'Tomato Firmware' started by Gaius, Oct 19, 2011.


Has your RT-N16 been stable since the day you bought it?

  1. Yes

    13 vote(s)
  2. No.

    2 vote(s)
  3. I've never owned an RT-N16

    1 vote(s)
  1. Gaius

    Gaius Networkin' Nut Member


    Hello everybody. Last week, I got my RT-N16 and I've been struggling with an issue that I've been trying my best to figure out become making a thread.

    The problem: all of a sudden, without any heavy network traffic, just normal browsing, my router will "lock up". The N16 will continue to show up in list of available networks and all my clients can connect to it, but that's pretty much they can do. They cannot access the internet, nor access the Tomato GUI.

    When I received this router, I played with the original firmware for a bit but an hour later, I successfully flashed the latest 7486 version of Toastman's mod. I made sure to clear the NVRAM after flashing it, turned on DHCP, and connected it to my modem. It worked great for a few days, but then it locked up. This lockup can ONLY be remedied by turning off the router and then clearing the NVRAM by pressing the WPS button when plugging it in and setting it up again as I did when I first bought it. I fixed the first lockup, and 24 hours later, the same lockup occurred.

    The only settings I've changed from the default are my security settings (WPA-PSK AES), my location which is the US, and I've been keeping it at 20mhz as per the advice on this forum. I had considered raising the transmit power from what I've read in a thread here but I've always kept it at 17MW.

    I then decided to try Shibby's mod, build5x-079V-EN, hoping the problem would go away, but within 48 hours, the exact same lockup occurred. I cleared the NVRAM twice to make sure I had a clean Shibby install, but no, the same thing happened, with the same settings I had when using Toastman, which were almost entirely default values.

    I'm currently using my RT-N16 as I type this, and I'm using the latest official Asus firmware released a few days ago, beta, which I just flashed before I came to this forum to post this thread waiting to see if the same lockup occurs tonight or tomorrow.

    I'd also like to mention that I've been running Toastman's latest 2.4 build on my old WRT4GL, and I've never had this lockup before, obviously because it's different hardware and firmware, but for some reason my clients don't seem to have a problem with it. Over the years, I've had original Tomato, TomatoUSB builds, Victek's mod, and finally, Toastman's mod on my WRT54GL, and it has never locked up like this. Not once. I had to use it again for a while this week because I didn't realize I needed to clear NVRAM to make my RT-N16 work well again.

    Here's my current clients if you guys need clues.

    -Desktop running W7 32bit, connected to Lan1 via Cat5 on my desk.
    -Laptop running W7 32bit, connected wirelessly via a built-in Atheros AR928X card.
    -iPhone 3GS
    -Canon Mp620 printer, connected wirelessly.

    Also, I use an older modem. A DCM-202 by Dlink. Could that be the issue?

    Keep in mind that I've been running this exact group of clients WRT54GL for over 2 years now with a variety of Tomato firmwares and I've never had this problem. The WRT54GL has been rock solid.

    Hope you guys can figure this one out for me, because this has been driving me nuts this week. I've posted a poll out of curiosity as well.
  2. kthaddock

    kthaddock Network Guru Member

    I have two RT-N16 and not recognice your problem. I suggest to do a "real" nvram reset.
    "Erase all data in NVRAM memmory (thought) and after that reconfigure by hand and se if that helps.
    I test alot of toastman, shibby, victek and dd-wrt builds and if I don't do a proper nvram clear it can be
    some strange issues.

    good luck!
  3. Gaius

    Gaius Networkin' Nut Member

    Yep, that's what I do before and after I flash my router. I always erase all data when flashing and after the flash I do another NVRAM clear and wait 5 minutes just in case. I just don't get what's causing this issue. I have yet to try Victek's build so maybe I will do that if the official Asus firmware dies on me too.
  4. Gaius

    Gaius Networkin' Nut Member

    K, the official Asus firmware locked up on me too. Could it be my modem? I've updated my first post.

    EDIT: Also, found this thread on the TomatoUSB forum looking for something that resembles my problem. I don't get a reboot like these people describe, but the lockup does seem to occur in the same timetable from anywhere between a few hours to 2-3 days.

  5. kthaddock

    kthaddock Network Guru Member

    Do you have your modem in bridgemode or do your modem handle dhcp ? and if then is problem with double nat.
  6. Gaius

    Gaius Networkin' Nut Member

    Pretty sure my modem handles DHCP, but my WRT54GL has the same default settings as the RT-N16.
  7. kthaddock

    kthaddock Network Guru Member

    Try to use your modem i bridgemode and test, to avoid double NAT problem. Let your RT-N16 handle dhcp and nat.
  8. ntamas26

    ntamas26 Networkin' Nut Member

    I heard that these RT-N16 are factory downclocked, because of stability reasons.
    Maybe try to downclock the router to 440MHz, if it will be stable after that, you should ask for RMA, because it's a hardware issue.

    use the following commands throguh SSH:

    nvram set clkfreq=440,220,110
    nvram commit
  9. kthaddock

    kthaddock Network Guru Member

  10. Gaius

    Gaius Networkin' Nut Member

    Actually for some reason I can't change settings on my modem. It doesn't let me switch bridge mode on or off because there does not seem to be such a setting at all on the modem config page.

    I've uploaded a screenshot of my Tomato page from my old WRT54GL I've had to use in the meantime. It's connected to my DCM-202 cable modem. Does anything look troublesome?
  11. Toastman

    Toastman Super Moderator Staff Member Member

    I rather doubt it's the modem although anything's possible. Here's what I would do. Since it's my mod, then I would flash the version previous to that, and keep doing so until the problem went away. Then we look for something that had changed from that build.

    Wireless drivers are the obvious one to look for, and here in this case we have an Apple device which are know to cause problems on some devices. I'd switch that off and see if the problem occurred without that around. The fact that it worked fine for a few days is one pointer that whatever the fault is, it was probably not present when the firmware was first flashed. Something happened. That's hard to pinpoint. The build is stable here, and tested on several RT-N16's and an E3000.

    The fact the web GUI is not responding smells somewhat of the router being low on resources, is it possible to telnet to it and get a look at what's happening? ps or top for example?

    It could be a hardware fault, and downclocking is one way to make the router possibly more stable, might well be a good idea.
  12. Gaius

    Gaius Networkin' Nut Member

    I flashed the N16 with Victek's latest stable firmware and made sure to clear the NVRAM 3 times this time with a 5 minute waiting period in between each clear and I've been running it for 24 hours. So far, everything is working great. I think something in the latest Shibby and Toastman builds is not agreeing with my router but as I understand it, those firmwares compiled with newly committed code. Thanks for helping, guys.
  13. Gaius

    Gaius Networkin' Nut Member

    I've discovered the problem! I have another family member in the house with an Intel wireless laptop. I could have sworn he had an Atheros laptop just like mine so I didn't mention it, but yes, it's an older laptop with a 4965agn card and it would drop the connection for him and then me as well. I was just in bed and he was pacing around the apartment trying to fix yet another drop and it woke me up so I had a look at his laptop and indeed, the Intel card was there with certain settings like WMM and throughout enhancement on and once the card was disabled, the problem went away for my laptop as well. I let him use my desktop adapter and I'm going to buy another mini adapter as well so he doesn't kill my network.

    I'd like to give a big THANKS to Toastman, whose posts I've been reading about how Intel cards can cause trouble with networks. Without his insight I never would have suspected that Intel would make such a crappy product, so crappy that it would down my entire network.

    Just so everybody knows, Intel 4965agn cards can make an Asus RT-N16 fail, especially with their extra settings. If you can't stop using it, uninstall the driver to return to default settings or just buy another adapter, preferably with an Atheros chipset.
    crashnburn likes this.
  14. dbmusa

    dbmusa Networkin' Nut Member

    I stumbled upon this thread due to a similar problem I'm having with a new RT-N16. I am afraid that technically I'm out of my element, as I don't have an element. My problem is that every 1 to 3 days during internet activity all internet connectivity will cease and the router cannot be accessed by entering the address in a browser. The router's gui and internet connectivity cannot be re-established until the router is power cycled, usually more than once. I've had this problem with the default firmware, the newest asus firmware, and now with a new "stable build" of dd-wrt firmware.

    I am not familiar with a lot of the terminology used in this thread but unlike Gaius i do not have wireless laptops nor wireless adapter cards so I do not think his solution could be mine. I'm not sure of the hardware specifications of the two PC's connected to the router via lan cables.

    Any information on how I might go about the next step in troubleshooting would be appreciated. I apologize in advance for my lack of technical familiarity.
  15. Gaius

    Gaius Networkin' Nut Member

    Dbmusa, go here:


    Download tomato-K26USB-1.28.RT5x-MIPSR2-083V-AIO.trx from that list. Make sure the filenames match.

    Flash it from the dd-wrt firmware. Then, do an NVRAM erase from your new firmware. Once it settles after 5 minutes of starting up, do yet another NVRAM erase just to be sure you've started fresh. Then, just enter your wireless settings and enjoy your router.

    It's the most stable build of Tomato I've found to date. It honestly never crashes. Good luck.
    eahm likes this.
  16. crashnburn

    crashnburn LI Guru Member

    Are you serious? The Intel 4965 AGN? Its part of my T61. Which laptop & which drivers was this guy using? I'm wondering if this would work fine for me with the Thinkpad Drivers.
  17. Gaius

    Gaius Networkin' Nut Member

    Haha yep, he was using a T61 as well. We fixed it by uninstalling the wireless drivers and restarting. Windows installed the drivers from Windows Update and they of course were left at default settings. After that, my issue was gone, and even after he visited weeks later, his laptop didn't mess with my router any longer nor did he report an issue on his side.
  18. Toastman

    Toastman Super Moderator Staff Member Member

    dufoq3 - How did you get on? Did you manage to recover your router?

    Cause - you used the 60K nvram version on a router that doesn't have 60K nvram. Then one day your router probably tried to use the extra nvram, and bricked your router. You probably need to start reading up on how to unbrick it.
  19. mito

    mito LI Guru Member

    Hi all, about Intel mini cards, to get full N 300Mbps speed i switched my Intel 4965 agn to an Intel 5300 agn, the old 4965 was super tuned up and changed almost every settings, never got more than 130Mbps but also never got a network drop nor any disconection. Now with the Intel 5300 agn i also changed a lot of settings, never had a disconection and get always 300Mbps with my avatar pic.
    Just my two cents.

Share This Page