1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

HELP: Asus RT-AC66U totally unresponsive after two weeks running Tomato

Discussion in 'Tomato Firmware' started by Hardrock, Sep 4, 2013.

  1. Hardrock

    Hardrock Reformed Router Member

    Hi All!

    Great forum and I hope someone can help me with an issue that has just happened with my Asus RT-AC66U router. I've had it now for 2 weeks and as soon as I got it, I loaded Shibby's Tomato "RT-AC66U_RT-AC6X--112-AIO-64K.trx" build.

    For these two weeks, It has worked perfectly, honestly can say the best router and firmware combination I've seen for both networking and range. However this morning, the whole unit became unresponsive!! All that happens when I reboot / reset is that three LED's come on the front - the LAN ports 1 and 2 and the globe LED. Can't communicate with recovery, it wont go into recovery!! it's like in a bricked state?

    Any suggestions please if this can be restored or is it a RMA ?
     
  2. jed_99

    jed_99 Addicted to LI Member

    First thing I would do, is a 30-30-30. Its not like you're going to make it worse.
     
  3. Hardrock

    Hardrock Reformed Router Member

    Hello - No 30-30-30 or combination of boot up sequences makes any difference. Can't ping it either. Looking around the internet other people have reported this kind of issue where only LAN1, LAN2 and WLAN LED come on with this unit.

    If I leave the router unpowered for about 3 hours and re-apply power the unit will try and boot again LAN1 LED will flash If it is connected to the PC ethernet port. But I can't communicate with it. If I then try and reboot it (plug out and back in) only the LAN1, LAN2 and WLAN LED come on.

    The LAN1, LAN2 and WLAN LED issue has been reported on the ASUS forum

    http://vip.asus.com/forum/view.aspx...22&board_id=11&model=RT-AC66U&page=1&count=15

    All I can tell you is that my AC66U worked great for two weeks using Shibby tomato and all of a sudden it dies.

    I suspect that either the flash or NVRAM is corrupt, but I can't do anything about it because it won't respond for me.

    I'll send it back but would like to try and fix it if I can. Any ideas guys ?
    RouterLED.jpg
     
  4. rainlake

    rainlake Reformed Router Member

    you better try TTL. and post your console output here.
     
  5. Hardrock

    Hardrock Reformed Router Member

    Hi ! Here is my serial dump on boot up. Tried the Ctrl-c but it would not break for me. Took power off and back on now getting the 3 LEDS, and no serial output. I need to leave the thing unpowered for about 3 hours before I can get a dump like below again. I do get a hwaddr in the dump below, just commented it out.

    Any ideas?

    CFE version 6.30.39.29 (r338244) based on BBP 1.0.37 for BCM947XX (32bit,SP,LE)
    Build Date: 一 10月 15 10:41:41 CST 2012 (yau@wireless-pub2)
    Copyright (C) 2000-2008 Broadcom Corporation.

    Init Arena
    Init Devs.
    Boot partition size = 262144(0x40000)
    Found an ST compatible serial flash with 32 64KB blocks; total size 2MB
    Found a AMD NAND flash with 2048B pages or 128KB blocks; total size 128MB
    bcm_robo_enable_switch: EEE is disabled
    et0: Broadcom BCM47XX 10/100/1000 Mbps Ethernet Controller 6.30.39.29 (r338244)
    CPU type 0x19749: 600MHz
    Tot mem: 131072 KBytes

    CFE mem: 0x80700000 - 0x8094EDE0 (2420192)
    Data: 0x80738B70 - 0x8073BE10 (12960)
    BSS: 0x8073BE10 - 0x8074CDE0 (69584)
    Heap: 0x8074CDE0 - 0x8094CDE0 (2097152)
    Stack: 0x8094CDE0 - 0x8094EDE0 (8192)
    Text: 0x80700000 - 0x80738B70 (232304)

    Device eth0: hwaddr xx-xx-xx-xx-xx-xx, ipaddr 192.168.1.1, mask 255.255.255.0
    gateway not set, nameserver not set
    Null Rescue Flag.
    boot the image...
    Check 2 trx result: 0, 0
    go load
    Loader:raw Filesys:tftp Dev:eth0 File:: Options:(null)
    Loading: TFTP Server.
    Failed.
    Could not load :: Timeout occured
    Loader:raw Filesys:raw Dev:nflash0.os File: Options:(null)
    Loading: ...... 3388180 bytes read
    Entry at 0x80001000
    Closing network.
    Starting program at 0x80001000
    Linux version 2.6.22.19 (root@tomato) (gcc version 4.2.4) #1 Sat Aug 10 22:12:48 CEST 2013
    CPU revision is: 00019749
    Found an ST compatible serial flash with 32 64KB blocks; total size 2MB
    Determined physical RAM map:
    memory: 07fff000 @ 00000000 (usable)
    memory: 08000000 @ 87fff000 (usable)
    Zone PFN ranges:
    Normal 0 -> 131072
    HighMem 131072 -> 589823
    early_node_map[2] active PFN ranges
    0: 0 -> 32767
    0: 557055 -> 589823
    Built 1 zonelists. Total pages: 65535
    Kernel command line: root=/dev/mtdblock3 console=ttyS0,115200
    Primary instruction cache 32kB, physically tagged, 4-way, linesize 32 bytes.
    Primary data cache 32kB, 4-way, linesize 32 bytes.
    Synthesized TLB refill handler (20 instructions).
    Synthesized TLB load handler fastpath (32 instructions).
    Synthesized TLB store handler fastpath (32 instructions).
    Synthesized TLB modify handler fastpath (31 instructions).
    PID hash table entries: 512 (order: 9, 2048 bytes)
    CPU: BCM5300 rev 1 pkg 0 at 600 MHz
    Using 300.000 MHz high precision timer.
    console [ttyS0] enabled
    Dentry cache hash table entries: 16384 (order: 4, 65536 bytes)
    Inode-cache hash table entries: 8192 (order: 3, 32768 bytes)
    Memory: 255116k/131068k available (2690k kernel code, 6744k reserved, 411k data, 208k

    init, 131072k highmem)
    Mount-cache hash table entries: 512
    NET: Registered protocol family 16
    usbcore: registered new interface driver usbfs
    usbcore: registered new interface driver hub
    usbcore: registered new device driver usb
    PCI: Initializing host
    PCI: Reset RC
    PCI: Initializing host
    PCI: Reset RC
    PCI: Fixing up bus 0
    PCI/PCIe coreunit 0 is set to bus 1.
    PCI: Fixing up bridge
    PCI: Fixing up bridge
    PCI: Enabling device 0000:01:00.1 (0004 -> 0006)
    PCI: Fixing up bus 1
    PCI/PCIe coreunit 1 is set to bus 2.
    PCI: Fixing up bridge
    PCI: Fixing up bridge
    PCI: Enabling device 0000:02:00.1 (0004 -> 0006)
    PCI: Fixing up bus 2
    NET: Registered protocol family 2
    Time: MIPS clocksource has been installed.
    IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
    TCP established hash table entries: 4096 (order: 3, 32768 bytes)
    TCP bind hash table entries: 4096 (order: 2, 16384 bytes)
    TCP: Hash tables configured (established 4096 bind 4096)
    TCP reno registered
    highmem bounce pool size: 64 pages
    squashfs: version 3.2-r2 (2007/01/15) Phillip Lougher
    io scheduler noop registered (default)
    HDLC line discipline: version $Revision: 4.8 $, maxframe=4096
    N_HDLC line discipline registered.
    Serial: 8250/16550 driver $Revision: 1.90 $ 2 ports, IRQ sharing disabled
    serial8250: ttyS0 at MMIO 0x0 (irq = 8) is a 16550A
    serial8250: ttyS1 at MMIO 0x0 (irq = 8) is a 16550A
    PPP generic driver version 2.4.2
    MPPE/MPPC encryption/compression module registered
    NET: Registered protocol family 24
    PPPoL2TP kernel driver, V0.18.3
    PPTP driver version 0.8.5
    pflash: found no supported devices
    Boot partition size = 262144(0x40000)
    Creating 2 MTD partitions on "sflash":
    0x00000000-0x00040000 : "pmon"
    0x001f0000-0x00200000 : "nvram"
    Found a AMD NAND flash with 2048B pages or 128KB blocks; total size 128MB
    lookup_nflash_rootfs_offset: offset = 0x0
    nflash: squash filesystem with lzma found at block 9
    Creating 2 MTD partitions on "nflash":
    0x00000000-0x02000000 : "linux"
    0x00131dc4-0x02000000 : "rootfs"
    NAND device: Manufacturer ID: 0x92, Chip ID: 0xf1 (Unknown NAND 128MiB 3,3V 8-bit)
    Creating 3 MTD partitions on "brcmnand":
    0x00000000-0x02000000 : "trx"
    0x02000000-0x04000000 : "jffs2"
    0x04000000-0x07f00000 : "brcmnand"
    dev_nvram_init: _nvram_init
    _nvram_init: allocat header: 2168061952, size= 65536
    usbcore: registered new interface driver hiddev
    usbcore: registered new interface driver usbhid
    drivers/hid/usbhid/hid-core.c: v2.6:USB HID core driver
    u32 classifier
    OLD policer on
    Netfilter messages via NETLINK v0.30.
    nf_conntrack version 0.5.0 (2048 buckets, 16384 max)
    ip_tables: (C) 2000-2006 Netfilter Core Team
    ipt_account 0.1.21 : Piotr Gasidlo <quaker@barbara.eu.org>,

    http://www.barbara.eu.org/~quaker/ipt_account/
    net/ipv4/netfilter/tomato_ct.c [Aug 10 2013 22:12:47]
    NET: Registered protocol family 1
    NET: Registered protocol family 10
    ip6_tables: (C) 2000-2006 Netfilter Core Team
    NET: Registered protocol family 17
    802.1Q VLAN Support v1.8 Ben Greear <greearb@candelatech.com>
    All bugs added by David S. Miller <davem@redhat.com>
    VFS: Mounted root (squashfs filesystem) readonly.
    Freeing unused kernel memory: 208k freed
    Warning: unable to open an initial console.
    emf: module license 'Proprietary' taints kernel.
    et_module_init: passivemode set to 0x0
    et_module_init: et_txq_thresh set to 0x0
    bcm_robo_enable_switch: EEE is disabled
    eth0: Broadcom BCM47XX 10/100/1000 Mbps Ethernet Controller 6.30.102.9 (r366174)
    PCI: Enabling device 0000:01:01.0 (0000 -> 0002)
    eth1: Broadcom BCM4331 802.11 Wireless Controller 6.30.102.9 (r366174)
    PCI: Enabling device 0000:02:01.0 (0000 -> 0002)
    eth2: Broadcom BCM4360 802.11 Wireless Controller 6.30.102.9 (r366174)
    / # lo: File exists
     
  6. Victek

    Victek Network Guru Member

    Loader:raw Filesys:tftp Dev:eth0 File:: Options:(null)
    Loading: TFTP Server.

    You can put a tftp server (better use windsolaris or any from sourceforge) with original asus firmware in, it's expected to be uploaded and then recovered... or try asus tool .. if the serial stops waiting the file when you pushed reset key during power ON...
     
    Last edited: Sep 6, 2013
  7. Hardrock

    Hardrock Reformed Router Member

    Hello, would you know why I need to wait around 3 hours before I can reboot this router? Is some memory or something being held up and being discharged slowly?
     
  8. Victek

    Victek Network Guru Member

    Just to sync, did you follow the procedure I mentioned?, I don't know the step you are stacked now...
     
  9. Hardrock

    Hardrock Reformed Router Member

    Hi Victek, please let me explain. The log I have above was from the first boot up of the router today. If I take the power off and try and re-power up, the router is basically locked / bricked. It will not give me a serial output or respond to reset. All that happens it that 3 LEDS come on as soon as power is re-applied.
    However!
    If I unplug the router for about 3 hours and then power up, I am once again able to get a serial log from it. It's like some form of memory effect?

    I measured some DC voltages inside the unit, all looks ok around the capacitors, I am getting 3.3V, 1.2V and 5V.

    Something is stopping the router from booting and I can't see what it is as of yet. Is there a way to reboot the processor on the board via other means?
     
  10. Victek

    Victek Network Guru Member

    Thanks for the explanation, I can see better scenario now, it looks as a hardware problem in a component that fails against temperature, when you unplug it then cool down and you can power again ... also the log stops after loading wireless driver for 5GHz (eth2)... but then it hangs again... I think it's time to RMA to ASUS. Just a curiosity did you changed power settings for wireless? I don't have wiring diagram for this model in order to disconnect RF Amplifiers power line.. sorry if I can't help you more, I assume the unit die.
     
    Last edited: Sep 6, 2013
  11. Hardrock

    Hardrock Reformed Router Member

    Victek, I agree with you. This looks most probably like a component failing against temperature. I am a little disappointed that this has happened to be honest. The Asus RT-AC66U is one of the better routers on the market and one of the most expensive, you simply don't expect it to die on you after two weeks usage.

    I have my Linksys E4200 router but couldn't get the range and the NAS kept dropping out using Shibby Tomato, this is why I went and bought a Asus RT.

    Vickek as a guru in networks, What would you suggest as a router for good stable NAS, VPN and range?
     
  12. Victek

    Victek Network Guru Member

    About RT-AC66U fail, well.. in general I see few DOA Asus... but remember you used a third party firmware ...

    I suppose with third party firmware ?
    For N range 2.4GHz = RT-N16 (Tomato-RMerlin) or TP-Link TL-WR1043ND (Openwrt). NG for NAS.
    For N range dualband = RT-N66 (Tomato-RMerlin). NG for NAS.
    For ACN range dualband = RT-AC56 (2x2), better CPU and USB3.0, VG for NAS or RT-AC66 (3x3) G for NAS, but sincerely I doubt you can reach these wifi speeds at large distances.

    NG= No good
    G = Good
    VG = Very Good
     
    Last edited: Sep 6, 2013
  13. koitsu

    koitsu Network Guru Member

    The problem is CFE or hardware-level. The answer is here (quoting the OP):

    If you don't even see serial output from the CFE, then that indicates a problem with the CFE, or something at the hardware level. Doesn't matter which -- you can't fix either of them.

    You got a bunk unit in some way. Solution: do an RMA with Asus.
     
  14. szpunk

    szpunk Networkin' Nut Member

    I have a similar situation here, but now I can switch the power button many times to run the unit... God, what time will into bricks...
     
  15. Victek

    Victek Network Guru Member

    Before going worst flash to stock firmware if you're not already ...
     
  16. Hardrock

    Hardrock Reformed Router Member

    @Victek is there any good custom firmware for the ac56u you can recommend? Is the range good on this? Are their many hardware reported issues on this unit? Thanks
     
  17. Victek

    Victek Network Guru Member

    Till now you have dd-wrt and RMerlin firmware to test your unit (I did not test any... yet) because the wireless driver from Asus is newer and hopefully more stable than wireless driver form third party firmware, why? cause source code distributed by Asus is a merge with some old modules not updated. So, no third party firmware to recommend now if you are seeking stable wireless, if you seek other functions then I recommend RMerlin firmware.

    The range? if you ask for wireless then I'll say first, is 2x2 mimo against 3x3 for RT-AC66U. The range is good in my site, I got 80-85Mbps in 5GHz band, but 30-40Mbps in 2.4GHz with Intel 6300 wireless card at aprox 8 meter visual line from the router.
    About LAN-LAN .. no problem .. everything good.
    About WAN-LAN .. With RMerlin and Asus stock firmware speed is ok >200Mbps. With dd-wrt or Tomato?... I can say nothing yet until I port it full, but ctf will hurt some features running in Tomato. In dd-wrt they improved last releases but then other features are disabled.
    About CPU, it's a dual core so some heavy tasks like VPN should work better (as Asus people expect also).

    If you ask me what router to choice... by technological evolution I suggest RT-AC56U but there are some bugs at the beginning (WPS is not working for 2.4GHz band), CFE collapsed with more than 32KB data in nvram, sometimes 5GHz band 'sleeps' with power_save function in my wireless card, in fact nothing rare for the new units and that will be sorted in next releases.

    Sorry if I'm so crude but always when you buy a new model don't expect 100% right... some manufacturers don't solve the problem never, Asus is always releasing new patches, I'm sure they will solve all teenager bugs..
     
    Toastman likes this.
  18. RMerlin

    RMerlin Network Guru Member

    Wireless is stable in my current public build. It was using all the latest bits from 374_34, and it's my main router at home - no problem with my Centrino 6230 card on the 5 GHz band. So you can use this as an alternative until you find Tomato has reached a stage where it's stable enough for you to switch to it.

    What worries me most are the CFE-related issues, since there is no simple way for end-users to update their CFE. At least those issues shouldn't affect normal use - it's mostly a problem for us developers, and for users who like to constantly flash new firmwares.

    I have source code for a newer CFE, but no idea if it fixed those issues. I suspect it didn't.

    No idea where DD-WRT development is for that router. I think Kong is currently looking into it.
     
  19. Bird333

    Bird333 Network Guru Member

    To paraphrase the great 'barryware', if your router is chugging along fine and then suddenly stops it's probably a hardware failure. Sorry OP. Good luck
     
  20. szpunk

    szpunk Networkin' Nut Member

    I try flashed stock firmware and all other firmeware(DD-WRT,Merlin, Victek, Shibby, TomatoEgg etc...) already, same issue here. I ever replace the CFE on DD-WRT with a public stock CFE, no luck here.

    I dont think this issue is about temprature, because i can start it just push power on button many times whenever unit hot or not. But like you say, maybe it's about the 5G diagram inside.

    What i think of this because whatever firmware i use, the 5G always show 288.5Mhz, include all DD-WRT, Tomato, Stock firmware i can find.

    [​IMG]
    [​IMG]
    [​IMG]
     
  21. shibby20

    shibby20 Network Guru Member

    i have correct:

    80mhz.png
     
  22. szpunk

    szpunk Networkin' Nut Member

    So, i think my ac66 have hardware issue...
     

Share This Page