1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Help for CCcam.x86 on NAS200

Discussion in 'Cisco/Linksys Network Storage Devices' started by Pa0l0ne, May 5, 2009.

  1. Pa0l0ne

    Pa0l0ne Addicted to LI Member

    I'm trying to use CCcam.x86 on NAS200, but i have these 2 errors:

    ./CCcam.x86: /lib/libc.so.6: version `GLIBC_2.4' not found (required by ./CCcam.x86)
    ./CCcam.x86: libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by ./CCcam.x86)


    How fix theme? ANy Idea? I thinks it's a problem related to Busybox wont have these 2 lybraries installed

    Thanks for help.
     
  2. jackito

    jackito LI Guru Member

    You need different versions of libc. My advice is "don´t mess with libc". Instead my advice is to get the sources (if they are available), download the Linksys source of the firmware and the cross-compile tools and try to compile the app against this building tree.
     
  3. alejandro_liu

    alejandro_liu Addicted to LI Member

    Alternative you can get the right glibc version (making sure is compiled i386/i486, as nowadays pretty much everything is compiled as i686) and run it as chroot. Simmilar to the way jac uses to run gentoo without flashing a new firmware.
     
  4. Pa0l0ne

    Pa0l0ne Addicted to LI Member

    ...by the way...the source code is'nt public yet...so i think only gentoo save my project. i will take a look on it and start some testing. Thanks all for replies!
     

Share This Page