1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Help! I think I hard bricked my e3200!

Discussion in 'Tomato Firmware' started by strictlyfocused, Jan 26, 2014.

  1. strictlyfocused

    strictlyfocused Serious Server Member

    So I logged into my router today and saw the little notification up top that shibbys v116 was released. I wanted to double check which version I was running so I went to the about page and saw that it was shibbys tomatousb build 115 MIPSR2 AIO. So I went to shibbys site, grabbed the same file only for 116.

    I then flashed it like Ive always done, but now my router is totally hosed! It will not boot up at all. When I plug it in, the power LED stays solid for ~2 secs, blinks once, and then never comes back on. I tried a 30-30-30 reset along with numerous power cycles but nothing is helping. I cant ping the router at all, it just results in "Destination Host unreachable".

    Looking at the file I downloaded, I'm almost postive I flashed the wrong file. I used the file called "tomato-K26USB-1.28.RT-MIPSR2-116-AIO.trx" and in hindsight I should have used the file "tomato-E3200USB-NVRAM60K-1.28.RT-N5x-MIPSR2-116-AIO.bin"

    What should I do next? Did I totally brick this thing?
     
    Last edited: Jan 26, 2014
  2. darkknight93

    darkknight93 Networkin' Nut Member

    I had a similar issue with my e3200.. And could not recover it. But you can try serial recovery.
     
  3. Aldebaran

    Aldebaran Reformed Router Member

    Noticed your cry for help so I created an account to provide a few links with good information about how to unbrick you Linksys E3200.

    Don't worry. I bricked mine too after I bought it. Takes only a few components to get it working again.

    - A USB extension cable
    - Breakaway pins
    - USB v2.0 t o uart serial converter

    First thing you have to do is to open it carefully. There is a JTAG connector onboard (without connector).
    You have to solder 5 breakaway pins on the PCB. The serial JTAG is described in the wiki openwrt link.
    Once you have done this you can connevt the serial TTL converter to the pins and connect the USB connector to your laptop/computer. I used Teraterm to connect a terminal to the USB serial converter.

    It's already 6 months ago since I unbricked my E3200 so I can't remember every detail. But also this article is a really good one because it tells exactly what commands you must use to fix your router again.

    It's a piece of cake once you've done it. I never regret putting Tomato on my E3200. It is running rock solid with an 5 months uptime.

    Good luck!
     
  4. darkknight93

    darkknight93 Networkin' Nut Member

    Mine was looking like that after "boot". Lights a Little bit lighting up but not as in normal Operation: WP_000233.jpg
     
  5. mstombs

    mstombs Network Guru Member

    Just to be clear the E3200 has serial console connection AND JTAG connection to both the processor and the wifi chip - there are 4 different connectors, see also

    http://www.dd-wrt.com/phpBB2/viewtopic.php?p=846369

    You need serial console connection to processor to interrupt the CFE boot, reset the corrupt NVRAM and enable tftp upload of a correct firmware via Ethernet:-

    http://www.dd-wrt.com/wiki/index.php/Serial_Recovery
     
  6. strictlyfocused

    strictlyfocused Serious Server Member

    You guys are awesome! After reading over those guides and documentation, I went ahead and ordered the following serial adapter:

    http://www.amazon.com/gp/product/B00FEAMUOK/

    When it arrives I will use the tutorials you all posted to hopefully recover my router. I will be sure to update this thread with my progress.

    Thank you all so much for taking the time to reply!
     
  7. Aldebaran

    Aldebaran Reformed Router Member

    MSTOMBS is right. There are multiple JTAG connectors. First try to clear your NVRAM via the serial console.
    If that doesn't work you can always try to fix the router via the JTAG to control the CPU. Never had to use this method before.

    Good luck and let us know if you get it up and running again.
     
  8. strictlyfocused

    strictlyfocused Serious Server Member

    Just wanted to update everyone, I received the USB serial adapter today and it worked perfectly. I was able to successfully restore my router by following your advice.

    I referenced the images on this page to solder in serial pin headers: e3200 - OpenWRT

    Then followed the instructions on this page using putty to interrupt the bootup process, erase the nvram, then tftp the OEM linksys firmware onto the router: Serial Recovery - DD-WRT

    After a couple reboots I was able to install the correct build of Tomato back onto the router, which I'm currently using to post this update.

    I cannot thank all of you enough! It cost me a total of $8 to fix my router which is light-years better than having to spend $100+ on a new one.
     
    mstombs likes this.

Share This Page