1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

HELP: may have BRICKED router during latest upgrade.

Discussion in 'Tomato Firmware' started by vexingv, Apr 28, 2008.

  1. vexingv

    vexingv LI Guru Member

    [solved] may have bricked router during latest upgrade.

    ok. so i just tried upgrading to 1.19 from 1.18 and proceeded as i would normally do. however, instead of progressing normally, i got an error message during upgrade: Error writing to MTD device. i waited for the router to restart itself, but it didn't and it simply timed out. i've tried to restart/reset the router, but nothing happens. the router still powers up but from there nothing. can someone help me. i'm clueless right now.

    i've got a buffalo whr-g54s. right now i've plugged in a second router i have.

    more info:
    the green power light is solid. and when i restart it the red lights blink twice before going out.

    another update:
    putting my laptop into manual dhcp and setting it to 192.168.11.100, i've managed to ping the router at 192.168.11.1 (the buffalo default), but i have not been able to access the admin/web interface. how should i proceed from here?

    i suspect that i will likely have to use the tftp method to put the firmware back on. but should i put the original buffalo firmware on? tomato 1.18? 1.19? since i've managed to ping it at this address, i don't want to progress and mess it up further without getting some opinions on how i should progress...

    thanks.

    solved! using the windows batch file to tftp to the router was successful. thanks again.
     
  2. nvtweak

    nvtweak LI Guru Member

    yeah, just set your pc with manual IP 192.168.1.2 subnet mask 255.255.255.0 and then plug in the router. after 5 seconds tftp flash it to 192.168.1.1 (at least my Buffalo router is 192.168.1.1 after I put other firmware on it. Yours might be 192.168.11.1, not sure.)

    after you verify it flashed correctly. go into the web interface and erase the nvram.
     
  3. LLigetfa

    LLigetfa LI Guru Member

    Just use the batch file that ships with 1.19 to TFTP it.
     
  4. vexingv

    vexingv LI Guru Member

    problem solved, 1.19 successfully on

    i managed to tftp to the router using the batch file (i was originally going to manually do it from my powerbook's terminal, but decided against it).

    in my 4 yrs of using custom router firmwares (and several years of flashing device, eg. motherboards, electronics, ect., firmwares in general), this upgrade is the first time that i have encountered a bad flash. i really don't understand why that happened and am still perplexed about that error message. i'm glad i was able to tftp the new firmware image, but i hope i don't have to do this again.

    btw, is the tftp upgrade the "safest" method to upgrade as opposed to the webgui method?

    thanks again
     
  5. LLigetfa

    LLigetfa LI Guru Member

    Yes, TFTP is very safe. The router is held in its pre-boot state and has more memory available and less workload on it.

    The batch file method takes out some of the timing guesswork. That's not to say you cannot do manually exactly what the batch file does.
     
  6. vexingv

    vexingv LI Guru Member

    well i remember when i first flashed this router from the original buffalo firware, i did do it manually using an OSX terminal window. i used the instructions found on the wiki and had to play around with the timing of the flashing lights, but managed to do it on the first try.

    the biggest (and only?) disadvantage i can see about using the tftp flash method seems to be having to manually change tcp/ip settings on the client computer each time prior to flash. that is unless leaving the client tcp/ip settings to dhcp (in my case 192.168.1.101; router 192.168.1.1) is safe to do when flashing with a tomato/custom firmware is already installed?
     
  7. LLigetfa

    LLigetfa LI Guru Member

    Since the batch file has the IPs hard coded, you might have to edit it to suit. I'm not advocating that all updates be done by DHCP, but you asked the question whether it is the safest way and to that the answer is yes.

    Aside from the initial flash from stock Buffalo, I use the web GUI. I even use the GUI to go from Tomato to dd-wrt or visa versa.
     
  8. speedfreak1982

    speedfreak1982 Addicted to LI Member

    Help --- Me Too

    Hey.
    I also have a WHR-HP-G54. Think i rebooted too soon after a TFTP update. Now the power light comes on, the diag light flashes a coupla times then goes out and the router repsonds to ping on 192.168.11.1. However when i try to tftp to it I get 1second of transfer before it says successful (about 900bytes of a 2.5Mb file).

    All the debricking sagas refer to not being able to ping at all? Am I in that boat or missing something?

    Thanks
     
  9. vexingv

    vexingv LI Guru Member

    i think you should be glad that you can ping the router. i would imagine that indicates that it's not a complete brick just yet. are you tftp-ing manually? if you're using WinXP, use the batch file to tftp the firmware to the router. i believe linksys also has some graphical tftp application as well, but i'm not sure.
     
  10. speedfreak1982

    speedfreak1982 Addicted to LI Member

    Much appreciated!!!!

    I thought that as i'd always got it to flash before that the timing wasnt an issue. Must be the fault stage it was in making the flash more time critical. I'd actually managed to take out a second router tonite (Think its an old laptop causing the initial fault). Just used the batch file and both are recovered! Cheers.
     
  11. LLigetfa

    LLigetfa LI Guru Member

    Some PC NICs are slow to init after gettting a link up and is may help if you have a hub or switch between the PC and the router to hold up the link state. Timing can be rather tight and that is why the batch file works well since it starts the TFTP transfer the moment it sees the first ping response.
     

Share This Page