1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Help: NSLU2 Installation Issues - Can't see drives

Discussion in 'Cisco/Linksys Network Storage Devices' started by djdube525, Jan 15, 2008.

  1. djdube525

    djdube525 LI Guru Member

    Cross threading is probably a no-no... I apologize... but I'm at wit's end.

    Here's the text from my post in the Networking Issues forum...

    A friend in another state had an NSLU2 with attached drives working with her network. At some point, the device stopped being accessible from PCs on her network.

    She mailed the unit and I tested it and everything seemed fine - I was able to access both drives connected to the unit.

    We've tried a few things... I was hoping someone may have some advice.

    Her router was set for:
    IP Address: 192.168.2.1
    Subnet Mask 255.255.255.0

    Given the NSLU2 device defaults to the .1 subnet, I had her change the Subnet Mask of the router to:
    255.255.240.0

    She rebooted her PC, and with the NSLU2 plugged into the network, she can finally get to the administration page of the NSLU2 device when pointing her browser to 192.68.1.77.

    However, she still can not "see" any of the drives from her PC. She tried changing the IP Address of the NSLU2 to 192.168.2.77, as well as matching the subnet mask of the router, but when she tries to save the config, she gets a "Unable to find Samba information" message.

    She's tried to use the set-up disk... tried plugging the NSLU2 directly into her laptop all to no avail.

    Any advice on what to try next? Or what simple thing I'm missing?

    Thanks!

    Dave
     
  2. d__l

    d__l Network Guru Member

    I think she should ideally have the NSLU2 on the 192.168.2.x subnet. I don't know what router she is using, but many Linksys routers seem to only be able to handle the 255 devices of a single 255.255.255.0 subnet.

    Now why she gets an "Unable to find Samba information" message, I can't say. The NSLU2's IP is stored in NVRAM on the NSLU2 and should be changeable at any time.

    If she expands her NIC's mask to 255.255.252.0, instead of the normal 255.255.255.0, she might be able to "see" the drives, but that wouldn't be the best final solution.

    I'm assuming that she doesn't have any software firewalls, such as ZoneAlarm or WinXP's firewall, operating here that would need to "trust" the NSLU2's IP
     
  3. djdube525

    djdube525 LI Guru Member

    I had her increase the router's subnet mask to 255.255.240.0...

    That allowed her to be able to connect to the NSLU2 via the web interface from her PC.

    I figured from there she could at least reprogram the NSLU2's IP Address... but whenever she tries to reprogram the IP address (or anything for that matter) associated with the NSLU2 she gets the Samba message.

    Maybe I need to read up on Samba... but what is actually going on? I'm wondering why she can't seem to reprogram the device... but appears to be able to access the devices configuration. She can migrate from one configuration screen to the next... she just can't seem to change anything.

    I'm sure this is something blatently simple... but it's not coming to me at the moment.

    :(
     

Share This Page