1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

help: OpenWRT->Tomato on Asus WL-500g Premium- wired ports not working!

Discussion in 'Tomato Firmware' started by burrokeet, Jul 1, 2008.

  1. burrokeet

    burrokeet Addicted to LI Member

    Hi- have an Asus WL-500g Premium running as our (small) office NAT gateway and wireless AP, been running OpenWRT 7.0.9 w/ X-wrt. No real problems w/ OpenWRT other than the web interface not being that great.

    Decided to switch to Tomato to improve our VOIP quality (plus migrating from POTS lines to Asterisk, so need better QoS).

    Flashed the Asus to Tomato 1.19, tried to access web interface to reset NVRAM and configure- REALLY slow... clicking on one of the menu items would take 30 seconds to return, often just timeout- this is on the wired connection (computer straight to Asus).

    Tried wireless connection- works great, no problems, fast- reset nvram, configured various settings in Tomato, seems to work great.

    But, none of our wired devices work (we have two networked printers, a NAS, and a couple Macs and PCs)- at the most they get an IP but can't connect, at worse not even an IP.

    Also, WPA/WPA2 doesn't seem to work w/ our XP clients now (works fine on the Macs)- they can connect fine to another wireless AP with WPA/WPA2 that we have.

    So at this point- try resetting NVRAM again, reset to defaults, reflash Tomato, reset NVRAM again, reconfigure- same thing.

    OK, so now I flash OpenWRT back again- SAME PROBLEM!?!

    did I kill my wired ports somehow? did Tomato?

    anyone know how to do a hard reset on the Asus and take it back completely to default settings?

    I'd try Tomato again, but this has been a very frustrating day.
  2. LLigetfa

    LLigetfa LI Guru Member

    Is this the older modular unit or the new V2? ISTR reading the V2 needs the _ND version and that the wired port VLANs need to be reassigned.

    Are you sure you are doing a full 30 second reset and not 29 seconds? How about erasing NVRAM from the commandline?
  3. burrokeet

    burrokeet Addicted to LI Member


    This is the older unit, not the V2

    tried erasing the NVRAM from the command line- what is the 30 second reset?

    the issue is the ports work sometimes briefly, they are not 100% dead
  4. LLigetfa

    LLigetfa LI Guru Member

    The 30 secnd reset is supposed to restore NVRAM to defaults. I found however that it doesn't erase all of NVRAM. When flipping between Tomato and dd-wrt, I've seen where the NVRAM settings survived the 30 second reset.

    I've also heard of the 30-30-30 reset procedure where you reset before powering off. Then you hold in the reset during power on. Then you TFTP flash and reset again after powering back up. I don't know the significance of the middle reset during power on.
  5. burrokeet

    burrokeet Addicted to LI Member

    ok thanks

    i am actually flashing back to the Asus firmware just to see if there is a physical problem with the LAN ports

    can you discuss the VLAN reassignment you mentioned for the V2? maybe there is some issue there that is surviving from the OpenWRT config?
  6. LLigetfa

    LLigetfa LI Guru Member

    Sorry, I have no first hand experience with the ASUS, only what I read.
  7. burrokeet

    burrokeet Addicted to LI Member

    ok an update

    flashed back to the latest ASUS firmware, did a factory settings reset from within the Asus firmware, then used the ASUS firmware restoration utility to reflash, this time with Tomato 1.19-ND.

    seems to be working ok now (fingers crossed)

    still need to tackle the WPA authentication
  8. tournet

    tournet LI Guru Member

    wl-500g with 1.19_ND works? realy?

Share This Page