1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

HELP Setting up WRT54G in Client Mode?!

Discussion in 'Networking Issues' started by Stangs55, Dec 1, 2005.

  1. Stangs55

    Stangs55 Guest

    I just bought a brand new SRX200, and I want to use my old WRT54G in 'Client mode' to connect computers to in another room.

    Basically I want my internet going into the SRX200 and the WRT54G connecting wirelessly to the SRX200 and then connecting a computer to that WRT54G and being able to get the internet.

    Can someone PLEASE provide me with some kind of tutorial as to what I am supposed to do/set?! I've installed the Talisman 1.04 firmware into the WRT54G and I've set it in Client-Bridge mode. I also reassigned its IP to (instead of .1 like my SRX200). With this setting, I am able to bring up BOTH router setup pages from a computer connected to the WRT54G...I'm just not getting my internet.

    How do I do this?

    Thanks :)
  2. Tomchu

    Tomchu Network Guru Member

    Since you can open the SRX200's admin page by connecting through the WRT54G, the bridge is working. The Internet access could be something simpler, like a DNS issue.

    I'm assuming you can ping the SRX200 while connected to the WRT54G. Can you ping any clients connected to the SRX200 through wired Ethernet? Can you ping google.com? If not, what about google.com's real IP address?

    That should lend you some clues as to where the breakage is occuring.
  3. 4Access

    4Access Network Guru Member

    I agree with Tomchu. Another possibility is a problem with the default gateway. Make sure the clients connected to the WRT54G have a default gateway of and not

    I'm not sure if Talisman automatically disables the DHCP server when in Client Bridge mode but if not make sure you manually disable it!

Share This Page