1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Help: TimeWarner QoS problem

Discussion in 'Tomato Firmware' started by kzch, Apr 13, 2010.

  1. kzch

    kzch Addicted to LI Member


    This is my first post. So please forgive me if I posted it in a wrong place. I doubt Tomato firmware is the cause of my problem, but I am hoping people here might be able to help me troubleshoot the problem.

    I have been using Tomato firmware for over 2 years on my Buffalo WHR-HP-G54, and am very happy with it. I have also been using Voip behind the router for about two years. The voice quality had been good until about 5 months ago. My BB ISP is TimeWarner. My Voip provider was italkBB, and recently rynga, Localphone, etc.

    The problem started around end of last year. When it happens, during the conversation, the other party cannot hear my voice for 5-15 seconds, but I could hear their voice at the same time. This happens every couple of minutes sometimes, making it very painful to make phone conversations.

    In the beginning, I suspected the QoS settings in Tomato is not set correctly. I am constantly running an emule program on one of my PCs. I did set up the QoS to give the ATA box the highest prority, and most traffic from the emule PC to the lowest priority. But the problem stays the same.

    Later, I found out actually the problem is not only with Voip, the Tomato realtime bandwidth monitoring of the WAN interface shows that when problem happens, both the uplink and downlink traffic are reduced to <5kB/s for the duration of the problem (5-15s). I also used a ping program to constantly ping my first hop router on the ISP side, and the ping would fail for the same duration.

    So the problem is loss of (all) uplink packets for 5-15 seconds every couple of minutes or so. This not only cause severe problem for my Voip, but also affected some other applications. Sometimes the MSN messenger would re-login. Even my realtime web chat session with Timewarner tech support could not stay connected due to this problem.

    I also tried two other routers, including a new Linksys router. Same problem.

    I also upgraded my BB service with TW, increased uplink bandwidth from 512k to 2m. Same problem.

    I had TW replaced my cable modem. The problem disappeared for about a month. But yesterday, it came back again.

    Now I suspect maybe TW is monitoring who is doing p2p downloading/sharing, and if they find you doing p2p, they may secretively penalize you by throttling your traffic. Now it affects all my traffic, not just p2p traffic. See when I swapped the cable modem with TW, it took their system one month to catch up with me again, so the problem is back.

    Could this be true? I don't know what else to look for wrt troubleshooting this problem.

    Thanks a lot for anyone who can provide some advices.
  2. kzch

    kzch Addicted to LI Member

    I also tested with PC connected to cable modem directly, it did not happen during the 1-2 hours test duration. But even with router connected, this problem does not always happen, it is possible that it does not happen for several hours or one day before it start to happen again.
  3. Porter

    Porter LI Guru Member

    This doesn't look like a typical QoS-problem, especially if you tried several other devices. Did they use the same QoS-settings?

    If something is shutting down your connection for several seconds at a time this could be due to electrical interference (right term for this?), i.e. a microwave or hairdryer being turned on. Some modems let read out their current line specifications which would allow you to see when there's a problem with the line. Unfortunately that's sometimes not very likely because there is just no software to do this or the manufacturer doesn't want you to be able to do this.
  4. phdeez

    phdeez Addicted to LI Member

    What model cable modem do you have? Plug that into google along with 'stats page' or something similar. I have a Webstar modem, and there is a 'second level' access which will show the modem log (which will show signal drops), cable line stats and the like.

    I'd bet this is a problem with your cable modem service, not QoS settings... since you are LOOSING connectivity to your first hop.
  5. kzch

    kzch Addicted to LI Member

    The two other routers I tried do not have QoS settings.

    Both old and the new cable modems are Motorola SB5120. The modem status page did not show any changes (signal to noise ratio, etc) during the 5-15 seconds time.

    I googled and did not find any mentioning of the similar problem.

Share This Page