1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

HELP with JTAG. Could not open CFE.bin for reading.

Discussion in 'Cisco/Linksys Wireless Routers' started by anectine17, May 21, 2006.

  1. anectine17

    anectine17 Network Guru Member

    Greetings. I'm pretty new to all this, so forgive my ignorance. I'm trying to de-brick a WRT54G v2. I've tried all the "normal methods", ie; shorting pins, etc. I'm at the point of JTAG now. I've figured it out to a point, and need some guidance. I'm using Windows XP. I built my own JTAG cable. I've played with HairyDairy's de-brick software and have success running it, but I now can't seem to flash the CFE.bin to the unit. I've so far been able to -backup:wholeflash, -erase:wholeflash, and -erase:nvram. When I try to flash:cfe or flash:cfe /noreset it performs several operations, then stops with an error that says "could not open cfe.bin for reading". I've made triple sure that cfe.bin is in the same directory as WRT54G (the .exe for HairyDairy's utility). I'm stumped as to why it won't open and flash the cfe. Any suggestions would be appreciated. Thanks.
     
  2. anectine17

    anectine17 Network Guru Member

    Looks like the sequence of commands I was given are for putting the DD-WRT Micro on the version 5. I'm sure I erased too much....wholeflash, nvram, cfe....but I did do a backup (took 15 minutes!!). So, I guess what I need to know is, how do I put the backup back on the router so I can start over, and what commands do I need to debrick this thing? What exactly do I erase? nvram? wholeflash? Do I mess with cfe? Once I'm there, I know how to tftp the new firmware in (it times out now). Advice from gurus please!!
     
  3. reber

    reber Network Guru Member

  4. anectine17

    anectine17 Network Guru Member

    Thanks for the reply. I've tried naming the CFE.BIN all caps, referring to it in my command prompt as caps, etc. I also see you linked me to the instructions for flashing a V.5. Those are the instructions I used. The problem is, I didn't realize they were V.5 instructions until I'd erased the wholeflash. I'm working with a VERSION 2!!

    I think what the problem is, is that the CFE.BIN I'm trying to use came with those instructions....it's from a WAP54G and will work on the V. 5 but it's wrong for the V.2. I need to know how to recover my cfe.bin from my wholeflash backup, OR how to get a new (correct) cfe.bin for my V.2. I found a link where I can get one, I believe. So once I put the correct cfe.bin into the V.2, I can tftp the Linksys or DD-WRT mini firmware in, correct?? Sorry, but like I said, I'm new to this and need pretty specific instructions. Thanks.

    http://lonewolf.hacker-nin.com/wrt/cfe/cfe.php
     
  5. reber

    reber Network Guru Member

    http://www.wlan-skynet.de/download/index.shtml

    I successfully reflashed a v2 router the other day using the bootloader generated from this great application.

    And it works all the same as described by the v5 flashing document.
    With a couple of exceptions, that is.
    1) If you use the Skynet CFE, you probably keyed in your MAC address and you won't have to update that later.
    2) You'll tftp to 192.168.1.1 instead of 192.168.1.245.

    You've just gotta have a valid cfe.bin.
    After the cfe flash, I like to erase the nvram and kernel just to make sure there are no problems.
    Then tftp to the native IP address and wait.
    I'm sure it'll work for you. Good luck.
     
  6. anectine17

    anectine17 Network Guru Member

    Thanks, I'll have a look at it. A couple of questions. You refer to me keying in my MAC address. I don't know what it is! Like I said, I backed up my wholeflash, and I'm sure my MAC is in there somewhere, but I don't know how to access it. Secondly, you mention needing a valid cfe.bin......I realize that........that's the problem....where do I get one??? Thanks again!!

    Alden
     
  7. reber

    reber Network Guru Member

    You'll see what I mean when you check out the link above.
    The app asks you to enter a MAC address before it generates a valid CFE.BIN for the selected wrt model.

    You'll want to use the MAC address printed on the bottom of your router below the serial number.

    Then use the CFE.BIN that it creates.
     
  8. anectine17

    anectine17 Network Guru Member

    Oh......duhhhh.....I knew that!! I looked at the program and couldn't figure out where to get the MAC to enter. It's on the bottom of the router.....really....I did know that. Thanks. I'll give it a shot!

    Alden
     

Share This Page