1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

HELP! with WRT54GS v3

Discussion in 'Cisco/Linksys Wireless Routers' started by theprovider, Feb 8, 2006.

  1. theprovider

    theprovider Network Guru Member

    PLZ HELP!!!!! ok.. first, some background: i tried to update the v3 firmware several times to no avail (with hyper wrt 2 and 21b1), using the web GUI. i always got "updates are failed" msg, after wich i could do the long reset recovery method without problems... a visit to google after and i find out that people having my same problem tried upgrading to ddwrt first to later install other firmware.. i did just that and ddwrt loaded nicely, after wich i installed hyper 21b1 (i think), and BAM! it's gone, can't do the long reset and wenever i try to ping it to up the official firmware i get only timeouts...power LED won't stop blinking... so i'm hoping you can answer some questions:

    1.-Do all those guides for de-bricking the WRT54G work the same for WRT54GS models (cuz i've only found guides for WRT54G). If they don't, can you link to some good guides?
    2.-i've also found the "shorting the pins" guides for 54G... will the same method work for a 54GS? Do both use the same pins?
    3.-Can you point me to a good TFTP software so i can up my original firmware?

    Please help me out. And if you could point me to some solution that doesn't require me to fumble with the hardware (bare electronics H-A-T-E me), you'll be my effing hero.

    cheers.
     
  2. Dj_brokensoul

    Dj_brokensoul Network Guru Member

    arg

    same problem here :thumbdown:
    Any ideas guys?
     
  3. __spc__

    __spc__ Network Guru Member

    DD-WRT is better than Hyper-WRT; why replace DD-WRT?
     
  4. theprovider

    theprovider Network Guru Member

    does it matter? it wont change the fact that i have a black and blue brick staring at me thru dead LEDs....

    ok, i managed to open the thingy up and i found, to my dismay, that it is completly different to the pics in the "shorting the pins" guide; i've located the intel flash (4.70.6), but it also has more pins than the chip in the guide. Also, i found thru the open wrt page that shorting the pins ain't such a good idea , cuz it can really kill the 54gs (tho its actual state is as good as dead)...

    so, ne1 done the pins thingy on a 54GSv3? PLZ HAAAAAAAAAAAAAALP!

    cheers.
     
  5. theprovider

    theprovider Network Guru Member

    ok, here's a pic:
    [​IMG]

    I also found out here that, on a GS, you should short pins 5&6.. later this same thread recomends(sp?) also 18&19 and 19&20. My problem is: wich row? there are 3 extra rows of pins (with those white markers people say should be next to the chip itself). By logic, i should short the pins closest to the chip , no?

    BTW, the chip's got a label saying ver 4.70.6 cs: 2E39.

    So, again: someone shorted a v3 GS successfully? please let me know how!
    cheers.
     
  6. theprovider

    theprovider Network Guru Member

    Yay! I got it to ping me by shorting the pins here (i tried this 3 or more times be4 it worked, btw):
    [​IMG]

    That's half the battle! Then i tried to tftp (using winxpprosp2's tftp[tftp -i 192.168.1.1 put code.bin]) the 4.70.6 firmware, dd-wrt generic mini v23 and hyperwrt 21b1: timeout (except for the first time i tried , with i-dont-remember-wich firmware; it gave me "can't downgrade to this firmware version" or something like that). i read somewhere that sending bins larger than 2mb can cause this... so:

    where can i find optimal bins? (wich ones worked for you, wich are better, etc)
    OR
    where can i find other tftp software (for winxp)?
    OR
    how can/should i config the winxp tftp?

    tnx in advance
    cheers.
     

Share This Page