1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

High CPU usage with transmission 2.82

Discussion in 'Tomato Firmware' started by idimitro, Feb 20, 2014.

  1. idimitro

    idimitro Reformed Router Member

    Hi, I have been using the entware transmission 2.82 since a few months and it has been OK. Since the last update of the entware, the transmission is using 100% of CPU, regardless of the traffic that the torrents are actually doing.
    Using the transmission from the shibby builds produces the same results.
    I am sure that the problem is not in the traffic, because using a transmission from https://www.lancethepants.com/files/index.php?dir=Binaries/transmission/
    and the CPU usage is ~50% at most. The problem is that this binaries are crashing quiet often.
    The question is: is it possible to downgrade the transmission from the entware? I know I can try to recompile it but may be somebody has better suggestions :)
    Any other suggestions or stable transmissions binaries I can try?
  2. lancethepants

    lancethepants Network Guru Member

    Just curious, what router are you using? What firmware version are you running? What is the speed of your internet connection? Are you using swap?
    In my experience aria2 performs much better over transmission as far as cpu usage and speed are concerned. Just one suggestion if you're willing to try something new.
    The binary I created is crashing? I haven't used transmission extensively so as to test it myself. I use the entware toolchain. I could try to re-compile something else if you'd like.
  3. shibby20

    shibby20 Network Guru Member

    IMO optware`s transmission is the most stable binary.
  4. leandroong

    leandroong Addicted to LI Member

    HIgh CPU happens only when you have allocated so many peers per torrent and global.

Share This Page