1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Home-build plain Tomato FW V1.28 is different from official binary

Discussion in 'Tomato Firmware' started by mros, Aug 15, 2011.

  1. mros

    mros Networkin' Nut Member

    I wanted to make a small tweak to the tomato firmware. No problem here, but I ran into an issue when comparing my own built tomato.trx and the one that I can download from the tomato firmware website (http://www.polarcloud.com/tomato): They are not the same like I expected them to be !

    Since this was my first time to build the tomato firmware I wanted to make a small test before flashing this into my router:

    I used the sources from http://www.polarcloud.com/tomato and WRT54GL_v4.30.11_11_US.tgz.

    After the successful build (according to the README instructions from the author) I got fresh my own fresh binaries (so the build process worked ok).

    In theory I expected my home-built tomato.trx binary to exactly match the official binary V1.28
    (I did not make any changes so far).

    This was not the case.
    Has anyone dealt with this before ?

    Best regards,
  2. Toxic

    Toxic Administrator Staff Member

  3. roadkill

    roadkill Super Moderator Staff Member Member

    you should clone the git repository
    git clone git://repo.or.cz/tomato.git
    then switch to whatever branch you want to compile (the default is original tomato 1.28)
    the resulting binary will be different from official tomato because of several reasons
    the version and generated files with version numbering are different, Jon's tomato build is compiled with 32 bit system arch
    there are several bug fixes to tomato 1.28 that were integrated in the git but it mostly depends on what branch you compile.

    Good Luck :)
  4. mstombs

    mstombs Network Guru Member

    The compiled firmwares are never binary identical because the compiler adds some time/date and host directory structure information, which then gets compressd into the filesystem image. The resulting firmware should be very similar in size, if not you can compare expanded filesystems using the "firmware mod kit" or similar - I once had a problem where the 'stripping' didn't work resulting in a significantly larger binary which still seemed to function OK.

Share This Page