1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Hotspot with chillispot

Discussion in 'DD-WRT Firmware' started by jnicholas, Apr 17, 2005.

  1. jnicholas

    jnicholas Network Guru Member

    I am using dd-wrt 3.2 on a WRT54GS as a hotspot. It works OK but I am missing something - perhaps someone can help.

    The chilli.conf file which is created on reboot contains the line
    dhcpif=eth1

    Now it seems to me that this is wrong as eth1 (the wireless interface) and vlan0 (which is the switch) are bridged together to form br0.

    So the only way I can get chillispot to work is either to replace the line in the conf file by
    dhcpif=br0
    or to break the bridge with the command
    brctl delif br0 eth1

    This is a bore as it means that you have to log into the box and issue the command after avery reboot. I have found the same for the Sveasoft firmware.

    Anyone have an answer?
     
  2. bummpr

    bummpr Network Guru Member

    Chilli Jail

    Chillispot works great in latest pre-4 release giving you lots of flexibility in configuring your chilli.conf file...and settings will now stick!!!

    Great job Brain!

    I still have a problem getting a clean connection to the Chillispot raidus service...I want to get into debug mode but with Chilli running, I'm no longer able to get to the normal server page for WRT maintenance nor able to telnet in...Chilli has reset the IP range to 192.168.182.X and I have not found a way back into the WRT.

    Can anybody help me...or do I have to reboot abd reset? There has to be a way back into the router, right?
     
  3. jagboy

    jagboy Network Guru Member

    hey bummpr

    could you post your config for chillispot. the config that is in the managmant page


    thanks
    -jag
     
  4. BrainSlayer

    BrainSlayer Network Guru Member

    in prefinal4 you can select your dhcp interface + additional config entries if you want. everything out from the management page
     
  5. bummpr

    bummpr Network Guru Member

    Sure thing

    I can't give you the exact config right now...the WRT is set up at work...I can get it to you Monday. But I use the simplest possible...I've set up a free Radius account at radius.chillispot.org. They will send you info on the radiusserver1, radiusserver2 and passcode parameters. They'll also provide you an admin page to establish up to 5 login and password accounts. You will have to convert the radius 1 and 2 names they give you into IP addresses because that is what DD-WRT will accept. Provide a valid DNS entry and you should be good to go.

    Brain has kindly provided a freeform entry box to record any other Chilli parameters you might want to add to the chilli.conf file but they should not be necessary to get it running in very basic mode.

    Let me know how you do.
     
  6. jagboy

    jagboy Network Guru Member

    ok here is what i did and i am using dd-wrtv22 pre4 on a wrt54gv2.2

    Primary Radius Server IP . . . 213.66.141.115

    Backup Radius Server IP . . . 213.66.141.115

    DNS . . . . . . . . 167.206.3.150

    Redirect URL . . . . . . https://radius.chillispot.org/hotspotlogin/
    Shared Key . . . zspdwy8qe3hqhvkcek
    DHCP Interface WAN
    Additional Chillispot Options:


    is there anyhting else i need to do?
     
  7. bummpr

    bummpr Network Guru Member

    Looks OK

    That's about all I did. I also turned off the WRT firewall and opened up UDP 1812 and 1813 on our organizations firewall to allow radius authentication. I then did a reboot of the WRT.

    Wireless access after the reboot brought up the Chilli login screen. My problem remains at this point that I can't get the radius authentication to work...I keep getting denyed and returned to the login screen. I'm not sure what to do next. I was planning to try again Monday (when I get back to work) to put Chilli into debug mode to see if I could figure out what is not not working right. It could still be a firewall issue. I checked on the radius.chillispot.org account administration screen and it does not indicate any activity...it's almost like I'm not getting out to the radius server.

    Any ideas from anyone else???
     
  8. jonny_b

    jonny_b Network Guru Member

    hi,
    seems that you miss to enter your nas id...

    and maybe you shouldnt post your radius password in a forum :)

    jonny
     
  9. XCOM7

    XCOM7 Network Guru Member

    0wN3d
    LOL
     
  10. Zucht

    Zucht Guest

    My config:
    Primary Radius Server IP : 213.66.141.115
    Backup Radius Server IP : 213.66.141.115
    DNS : [My ISP DNS]
    Redirect URL : https://radius.chillispot.org/hotspotlogin/
    Shared Key : [Key profided by radius.chillispot.org]
    DHCP Interface : LAN+WAN
    Additional Options : radiusnasid [id profided by radius.chillispot.org]
     
  11. bummpr

    bummpr Network Guru Member

    Still some problems

    Using pre 4 version...my config is exactly the same except I want it for wireless (WAN) users only. When I choose WAN, DD-WRT puts 2 entries into the chilli.conf file:

    dhcpif eth1
    dhcpif vlan0

    Chilli doesn't like this double entry for the dhcpif parameter and refuses to start.

    I think this is a bug that needs to get fixed by Brain before chilli will operate correctly.
     
  12. TheJoker

    TheJoker Network Guru Member

    Re: Still some problems

    I think you mean WLAN (Wireless Local Area) and not WAN (Wide Area, the internet), right?

    correct me if i'm wrong but if eth1 (wlan) and vlan0 (lan) together form br0 (wlan + lan), and u just want to use the the wlan, cant you just remove the line "dhcpif vlan0" from the chilli.conf file?
    This way only the "dhcpif eth1" remains which is the wlan.
     
  13. BrainSlayer

    BrainSlayer Network Guru Member

    i dont know what he's doing wrong. in the config file will only be 1 line like "dhcpif" written. a second would only be attached if he configured this in the additional option.
     
  14. bummpr

    bummpr Network Guru Member

    Re: Still some problems

    I think we are all agreeing but...the choices in the web interface are WAN, LAN, and LAN-WLAN. I would like to invoke Chillispot/radius authentication only for my wireless users so I can still use a wired connection to do any debugging and configuration changes on the WRT.

    Whenever I choose "WAN" (since WLAN is not an option), I get 2 dhcpif entries in the .conf file. As you pointed out, I should only have to edit the chilli.conf file to remove the additional unwanted entry but VI editor is not available so I am stuck.

    However, I just installed WinSCP and am trying to pull the /tmp/chilli.conf file to my wired PC to edit the file and repost back to the WRT. I'm hoping this will work!!!

    Thanks for your posting...any other advice is very much appreciated. I'm really anxious to get this working.
     
  15. BrainSlayer

    BrainSlayer Network Guru Member

    okay if this only happends at "wan" it might be my misstake. WAN is definitly the right setting. i check my sources this evening and fix it. but it can take 2 - 3 days to the next release since i have to test the new routing code first
     
  16. jnicholas

    jnicholas Network Guru Member

    Chillispot working just fine

    Hi guys,

    Well, for me Chillispot in the new version prefinal4 works fine - thanks!

    I have to choose the option DHCP Interface: LAN + WLAN and then I get the following conf file.

    radiusserver1 212.147.nn.nn
    radiusserver2 212.147.nn.nn
    radiussecret xxxxxx
    dhcpif br0
    uamserver http://212.147.nn.nn/cgi-bin/hotspotlogin.cgi/
    dns1 212.147.nn.nn

    If I choose the option WAN it doesn't work and the conf file contains two dhcpif lines. But the above option is OK. I can still connect to the router via the RG45 ports for configuration - I just have to set my address manually as there is no DHCP.

    Not sure why you have cut out vi it was useful. Are you short of memory? Anyway I can always edit the file locally and push it with scp.

    Keep up the good work - its a very useful firmware and much appreciated.

    Jon
    Switzerland
     
  17. BrainSlayer

    BrainSlayer Network Guru Member

    i found the bug. its fixed internally now
     
  18. bummpr

    bummpr Network Guru Member

    Thanks again

    Good (FAST) work...I'm happy to hear that it wasn't just me.

    Using WinSCP I was able to modify the chilli.conf and finally got Chilli to work the way I want to...I'm much happier using WinSCP and Notepad than trying to master the very "strange" commands in vi.

    Now my next challenge...getting the hotspotlogin modifed to reflect a more personal appearance and getting it to run on the WRT box.

    Anybody got some hints?
     
  19. dellsweig

    dellsweig Network Guru Member

    Re: Thanks again

    Also - It would be nice to see a non-authenticated version of Chillispot (no requirement for radius) OR a choice to install NoCatSpash instead of Chillispot at boot time.

    NoCatSpalsh seems to be the answer for thiose that want to run the captive portal web site on the WRT. I have done some work with NoCatSpalsh on EWRT but the EWRT .3 release was not too stable
     
  20. jagboy

    jagboy Network Guru Member

    hey me too i am in the same situtation. i have to have a captive portal. but i really dont need the logig in. just a screen to say "hi click to brows the web"
     
  21. pasys

    pasys Network Guru Member

    this thing used to work , i set it up last time correctly , so my settings are saved in the router , now when i re-enabled it , nothing works


    any suggestions guys

    thanx !
     
  22. jagboy

    jagboy Network Guru Member

    could you tell us how you set it up or what steps you took. maybe you did something wrong
     
  23. ScoobyDoo32

    ScoobyDoo32 Network Guru Member

    Chillispot Config.

    OK, I still dont get it.. I've been told on the berliner forum that I need to have chilispot running on a seperate server because dd-wrt doesnt include php and hotspotlogin.cgi. Is this true or is it not ? The setup examples shown in this thread give the redirect url as https://radius/chillispot.org/hotspotlogin/ - but i've read elsewhere that this is not a valid location ?

    Many people seem to say "i have it working" , but they wont give details of their config..I dont understand why. If someone has it working, why cant they just say how they config'd it ?

    Earlier in this thread is this post:

    My config:
    Primary Radius Server IP : 213.66.141.115
    Backup Radius Server IP : 213.66.141.115
    DNS : [My ISP DNS]
    Redirect URL : https://radius.chillispot.org/hotspotlogin/
    Shared Key : [Key profided by radius.chillispot.org]
    DHCP Interface : LAN+WAN
    Additional Options : radiusnasid [id profided by radius.chillispot.org]

    BUT - this person didnt say it was working, they just said it was their config. Does this work ??

    In additional options - if my radiusnasid was, say RADIUS1 , would the exact syntax in the box be:
    radiusnasid RADIUS1

    Brainslayer managed to identify the problem with the dual entries in config - i also had this problem.. BUT ignored the question about WHY IS IT CALLED WAN, when it should be called WLAN ? I dont see anywhere that anyone has actually acknowledged that this should say WLAN ?

    Another question was asked/mentioned , although it was only partially mentioned. TO GET chili to work, you are supposed to disable DHCP in the DD-WRT web interface and that chilli takes over the DHCP functionality. OK, I've read that on chili site and i get it - BUT , the question was asked then, especially in light of the WAN+LAN bug - HOW DO I GET TO MY ROUTER CONFIG once chili takes over the dhcp function and the web interface seems to go away or to be inaccessible ? Or is this just a misunderstanding of what ip to use that someone has posted ? Would i put the ip of the 'gateway' in my url to get to the router config page ?

    And, after all that - once i get chili working (or if..) - do i end up with what i want which is a splash page that I can customize ? I too am only looking for the nocat splash functionality, users and passwords mean nothing to me.... in fact, the only way this will work for me would be to have a single user and put that user/password onto the splash page.

    PLEASE - if anyone can give some answers and more details than the peacemeal and seemingly conflicting information I've been given , I appreciate it !
     
  24. ScoobyDoo32

    ScoobyDoo32 Network Guru Member

    My NONWORKING current config

    Through the interface, I setup:
    Chillispot: Enable
    Primary Radius server ip: 213.66.141.115
    Backup Radius server ip: 213.66.141.115
    DNS: mydnsip
    Redirect URL: https://radius.chillispot.org/hotspotlogin/
    Shared Key: secretkey1
    DHCP Interface: LAN+WLAN
    Additional Chllispot options:
    radiusnasid mychillinasid


    This left me with chilli.conf of:
    radiusserver1 213.66.141.115
    radiusserver2 213.66.141.115
    radiussecret secretkey1
    dhcpif br0
    uamserver https://radius.chillispot.org/hotspotlogin/
    dns1 mydnsip
    radiusnasid mychillinasid

    My wrt ip is: 192.168.200.254

    So i reboot the router, and i try connecting with my wireless notebook - i see the router but i dont get an ip address. I manually set my ip address to 192.168.200.12 and I can connect to the router AND out onto the internet with no intervention from chilli or anything else.

    SO - what am I missing ? I've done exactly what the other posts here say work !
     
  25. jagboy

    jagboy Network Guru Member

    i have been asking the same question for w while
     
  26. ScoobyDoo32

    ScoobyDoo32 Network Guru Member

    Re: My NONWORKING current config

    Hello hello ?? Is anyone home ?? Would have thought one of the people that says they have this working might have replied....


     
  27. grinthock

    grinthock Network Guru Member

    Yes somethings wrong.



    I have the same situation, it's setup the same as the above post here, but it's not giving out addresses. (WRT54G)


    Even in debug mode it's not "seeing" the DHCP requests
     
  28. black7

    black7 Network Guru Member

    Any more news on this?
    I had Chilli working, then one day it just stopped.
    So, I've restored to factory default, reloaded my DD-WRT backup via backup web interface, and ....... it still doesn't work.

    I get IP, I get redirected to login page, but I keep getting LOGIN FAILED, etc.
    I've tried my own personal hotspotlogin, I've tried using the hotspotlogin that chillispot provides, but I keep getting LOGIN FAILED as if it wasn't authenticating.

    This all started happening on 7/6, and I think the same day chillispot's forum went down too.

    Coincidence?

    I'm thinking something happened to chillispot's radius server as I didn't change any settings on my WRT. AND the same day their forum went down. (www.chillispot.org/forum)

    Anyone out there using chilli's radius service and having problems? Or is it still working for you?

    Next task for me is either finding a way to run a small radius server on the WRT, or setup a seperate WRT just to run a radius server on (which currently seems more feasible due to the limited space on the G).
    If anyone has any more info regarding this, please pass it on. I'll definately do the same as I come across more info and get things setup for myself.
     

Share This Page