1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

How best set up 2 routers (newbie question)

Discussion in 'Networking Issues' started by GavT, Mar 2, 2005.

  1. GavT

    GavT Network Guru Member

    I have a belkin 54G wireless router/adsl modem, and a linksys WRT54GS with hyperwrt firmware. Currently I am using the lynksys as a wireless AP/firewall in gateway mode and the belkin as a modem/primary firewall with wireless turned off.

    I have read a few posts which refer to setting the second router to AP mode instead of gateway mode and was wondering if I my configuration was correct.

    as far as I'm aware my system works ok and I think my firewalls are working.

  2. TazUk

    TazUk Network Guru Member

    So your using the Belkin effectively as an ADSL modem/router and the Linksys as an AP?
  3. GavT

    GavT Network Guru Member

    I suppose what im really asking is whats the difference between using the linksys in gateway or AP mode. The belkin is only being used as a modem at the moment.

    Will I have a more effective system if I use the linksys in AP mode?

  4. TazUk

    TazUk Network Guru Member

    I'm a bit confussed by what you mean by this :? The Linksys can work as a gateway or router, that's on the internet connection side of things. On the wireless side it can act as an access point, wireless client or wireless bridge, depending on the firmware used.
  5. Ice-cream

    Ice-cream Network Guru Member

    ewrtV3 / nocat gatway /2 subnets / config

    I trying to do the same thing have 2 different subnets lwrt54g running ewrt ver 3 which does have a setting for gateway or router.. and Im unsure how to configure the linksys to talk to wich has the internet connection. the linksys in connect to a linux computer runnign nocat gatway this is what I get when I execute gateway

    [root@localhost nocat]# bin/gateway
    [2005-03-06 17:52:24] Resetting firewall.
    [2005-03-06 17:52:24] Detected InternalDevice 'eth1'
    [2005-03-06 17:52:24] Detected ExternalDevice 'eth0'
    [2005-03-06 17:52:24] Detected LocalNetwork ''
    [2005-03-06 17:52:27] Binding listener socket to
    [root@localhost nocat]#

    and when I run ifconfig..

    [root@localhost nocat]# ifconfig
    eth0 Link encap:Ethernet HWaddr 00:C0:DF:24:09:CC
    inet addr: Bcast: Mask:
    RX packets:39935 errors:0 dropped:0 overruns:0 frame:0
    TX packets:12454 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:100
    RX bytes:4894451 (4.6 Mb) TX bytes:1263839 (1.2 Mb)
    Interrupt:11 Base address:0xb000

    eth1 Link encap:Ethernet HWaddr 00:0B:2B:14:6A:73
    inet addr: Bcast: Mask:
    RX packets:4803 errors:0 dropped:0 overruns:0 frame:0
    TX packets:1381 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:100
    RX bytes:501802 (490.0 Kb) TX bytes:228785 (223.4 Kb)
    Interrupt:10 Base address:0xd000

    lo Link encap:Local Loopback
    inet addr: Mask:
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:105 errors:0 dropped:0 overruns:0 frame:0
    TX packets:105 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:7776 (7.5 Kb) TX bytes:7776 (7.5 Kb)

    [root@localhost nocat]#

    I can ssh into eth0 ( from no problems
    and then ping (the WRT54G)
    which is 1 of the 2 nics in the gateway box next to the WRT54G AP

    [root@localhost nocat]# ping
    PING ( 56(84) bytes of data.
    64 bytes from icmp_seq=1 ttl=64 time=1.87 ms
    64 bytes from icmp_seq=2 ttl=64 time=0.834 ms
    64 bytes from icmp_seq=3 ttl=64 time=0.832 ms
    64 bytes from icmp_seq=4 ttl=64 time=0.835 ms
    64 bytes from icmp_seq=5 ttl=64 time=0.842 ms
    64 bytes from icmp_seq=6 ttl=64 time=0.828 ms

    --- ping statistics ---
    6 packets transmitted, 6 received, 0% packet loss, time 5050ms
    rtt min/avg/max/mdev = 0.828/1.008/1.877/0.388 ms
    [root@localhost nocat]#

    then ping from linxu to ewrt ver3)

    [root@bearfoot root]# ping
    PING ( 56(84) bytes of data.
    From icmp_seq=2 Redirect Host(New nexthop:
    From icmp_seq=3 Redirect Host(New nexthop:
    From icmp_seq=1 Destination Host Unreachable
    From icmp_seq=2 Destination Host Unreachable
    From icmp_seq=3 Destination Host Unreachable
    From icmp_seq=4 Redirect Host(New nexthop:
    From icmp_seq=5 Redirect Host(New nexthop:
    From icmp_seq=6 Redirect Host(New nexthop:
    From icmp_seq=4 Destination Host Unreachable
    From icmp_seq=5 Destination Host Unreachable
    From icmp_seq=6 Destination Host Unreachable
    From icmp_seq=8 Redirect Host(New nexthop:
    From icmp_seq=7 Destination Host Unreachable
    From icmp_seq=8 Destination Host Unreachable
    From icmp_seq=9 Destination Host Unreachable
    From icmp_seq=11 Redirect Host(New nexthop:

    --- ping statistics ---
    11 packets transmitted, 0 received, +9 errors, 100% packet loss, time 9995ms
    , pipe 3
    [root@bearfoot root]#

    there isnt a 0.5 on the network..
    does anybody now what the working.iptables file is used? from nocat?
    how should the cat 5 cables look from the WRT54G to the gatway? should I use a crossover(patch) cable? use the wan port or lan port..

    when i logon to the ewrtv3 via wifi and sue diag ping to the 192.168.0.x subnet I get 100% loss..
    it tried to connect to the internet but times out..
    I Dont get the no cat splash senario..

    Ive been on this for a while now, I dont know much about iptables and netfilter and not sure if the kernal is 100% working with iptables but the gateway didn't complain... has wifi on it and working fine with wep..

    errr well that enough for now hope someone knows what the hell im talking about and can solve it riddle hicup gateway....
  6. t4thfavor

    t4thfavor Network Guru Member

    kinda confusing but i will try

    put the WAN port of the router into the gateway. im not sure if you need crossover i think the jacks autosense.
    then there should be a dhcp sever running on the gatway which will give the router its gateway and ip addr

    to talk between subnets you need to set up an advanced route.
    in the web config page(standard firmware and satori 4.0) its under

    set it to lan wan and then configure it to

    the appropriate settings(gateway and whatever)
    good luck
  7. Ice-cream

    Ice-cream Network Guru Member

    ok set up udhcpd on the gateway and set a static route to the gateway box and also on the netgear router to the other gateway ip enabled rip..

    tried using the wan port but couldnt acesses the gateway/ nocat page changing it to the lan port enabled me to and get the nocat login while logged in the ewrt...

    are you sure about the placement of the cable??
    read some where about using port 4 whats different about port 4..
    this could of been for a different setup mind..

    how should I configure the ewrts internet conection?? at the mo it set to DHCP automatic?? why does the nocat login not come up when I connect tot he ewrt the gateway is set do I need to add a port number to this ip address?? in the ewrt to the gateway at 58xx somthis is the nocat port..(eg not sure about port number)

    and the working.iptables file that comes with no cat, how can I check that iptable/netfilter is working correctly? with nocat...

    Thanks C
  8. Ice-cream

    Ice-cream Network Guru Member

    got shot of ewrt and tried dd-wrt had a problem saving the default routes so upgraded to hyper wrt it saved the route for me..
    got udhcpd working, on the gateway..
    pain fully checked every conf file and ip address

    still not working Grrrr starting to do my nut in by now..
    last resort patch cable from the wan port to lan:1 lan:4 to nocat gateway

    bingo nocat working at last christ why had I not read anything about a xover(patch) being used b4?

    am I going to wake up in the morning to a cooked wrt?

    going to rush of and give bluefish a go on a spash site.. eheh yipppeeee



Share This Page