1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

How can I set my WRT54 to update its IP to a Dynamic DNS server in everytime PPOE up?

Discussion in 'Tomato Firmware' started by winwin, Jun 18, 2007.

  1. winwin

    winwin LI Guru Member

    I am using WRT54GL with tomato lastest version, I found a problem of my WRT54 that its IP will not be updated in everytime its PPOE came up. Any who know a way to solve it, please help me.
     
  2. digitalgeek

    digitalgeek Network Guru Member

  3. winwin

    winwin LI Guru Member

    Thank to digitalgeek for yr recommend.

    But now, I am facing problem about my WRT54 with 1.07 tomato doesn't update its IP to any of dynamic DNS servers (that I have already set them into DDNS function in my WRT54) when its IP changed after PPOE is up.

    What I have done are listed below,

    (1). Register my account in www.dyndns.com and www.no-ip.com
    (2). Tested them by using my PC to update the change IP. (It worked fine)
    (3). Put information of the two account into my WRT54

    As any of the first time of WRT54's update (I mean after press SAVE in DDNS), it worked and shown "update successfully". But when PPOE went down and came up again. My IP was changed. So, my WRT54 did not update the new IP to the dynamic DNS servers.

    I think WANUp script could help me in this problem but I have no idea about the script.

    Any one got a solution, please help.

    Thanks.
     
  4. digitalgeek

    digitalgeek Network Guru Member

    After registering a dynamic dns with DynDNS I setup DDNS in the Tomaoto web interface...

    [​IMG]
     
  5. paped

    paped LI Guru Member

    I use the same DNS service and I have the drop down menu next to Service (1st option of the setup page) set to "DynDNS - Dynamic" I think this may be your problem, as the "DynDNS - Static" option which you have set I think is for when you have a static IP address from your ISP, thus the IP would never change and never need updating as such once initially set-up. The "DynDNS - Dynamic" set-up I have seems to work flawlessly....

    Hope this helps.

    PS - I would also un-tick the "backup MX" option, as I had this set then started using some of the email services they offer and it caused havoc so if you un-tick it now it may save you any possibly problems in the future if you started using these services!!!!!
     
  6. winwin

    winwin LI Guru Member

    Thank you very much for your help.

    Acually, I set it as the DynDNS - Dynamic. and faced problem as I mentioned.

    Have you try to disconnect and connect the PPOE? (to force IP changed) and then your WRT54 would show as the same as I got.

    Please kindly help me to test it., with your excellent experiences, you should got some solution and help me find out.

    Thank you in advance
     
  7. digitalgeek

    digitalgeek Network Guru Member

    Yes, everytime my PPPoE connection cycles (re-connects) the IP is update almost immediately and I am able to reconnect.

    Paped- thanks for the quick eye on the static, I missed that... although I was always able to update the IP... so either will work with DynDNS dynamic host.
     
  8. paped

    paped LI Guru Member

    Tested and like Digitalgeek it works everytime within seconds.

    Just wondering if a full reset to remove any corruption that might be causing the issue and then a manual rebuild might fix it. As I can't see any reason why it would not work....
     
  9. winwin

    winwin LI Guru Member

    Thank you again for helping and your results. It's a good news for you. I may set some configuration wrong.

    So, I did everything again

    (1). I started by doing Erase all data in NVRAM momory (thorought).
    (2). Set up the WAN configuration as attached (1).
    (3). Set up the DDNS configuration than SAVE
    (4). The DDNS shown "update successfully"
    (5). Disconnect and connect PPOE
    (6). the result of DDNS shown as attached (2).

    I would be appreciated if you can give me your configuration. Thank you.
     

    Attached Files:

    • 1.jpg
      1.jpg
      File size:
      23.4 KB
      Views:
      20
    • 2.jpg
      2.jpg
      File size:
      22.3 KB
      Views:
      20
  10. winwin

    winwin LI Guru Member

    It's a good new for me.
     
  11. winwin

    winwin LI Guru Member

    Thank to digitalgeek, I have found a way to solve this problem.

    I removed all configurations out from in DDNS function. But I write a two row script into the WanUp script. the script is shown below.

    sleep #60
    ez-ipupdate -S dyndns -u username:password -h www.domain.xxx -i ppp0 -r 5 -w

    Just this configuration, it update the changed IP to Dyndns server.

    Any comment, please add.
    Thanks again.
     
  12. winwin

    winwin LI Guru Member

    Thank to both of you.

    Now, I found out that it is because ez-ipupdate can not mark connection when IP changed. So, I removed config out from DDNS and applied a scipt in WanUp script as the following

    sleep 60
    ez-ipupdate -S dyndns -u user:passwd -h mydomainname -i ppp0 -r 5 -w

    after applied this, everytime my PPOE disconnect and re-connect again, my WRT54 will wait for 60 second then making an update. It's work well..

    Any comment, please add Thank you.
     
  13. winwin

    winwin LI Guru Member

    Oh!! repeated post.
     

Share This Page