1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

How did I brick two WRT54Gs?

Discussion in 'Tomato Firmware' started by rhester72, Feb 29, 2012.

  1. rhester72

    rhester72 Network Guru Member

    I was looking to bridge connectivity to some media gear (smart TV, Blu-Ray, DVR, etc.) and got the bright idea to put K26 with IPv6 on a WRT54GL on the bridge router (acting essentially as a remote switch, no DHCP or WAN).

    Compiled git TomatoUSB (i.e. Tomato-RT) as K26 MIPSR1 Standard with IPv6, found it to be _just_ too large to fit (ugh). Recompiled as K26 i (the "mini" IPv6) build with no issue, flashed through the web GUI, and got an infinitely-blinking power light. Ugh. Tried to TFTP rescue it, discovered the infamous "Windows 7 detects media disconnections and reconnect happens about a second too late" problem, gave up and moved on to the backup router (standard older WRT54G model). Did a 30-second reset button boot just for grins, no change. (I don't currently have serial or JTAG.)

    What do you know? Same process, same brick on the WRT54G. Same inability to recover (I'll be trying the TFTP from Ubuntu next - any suggestions on timing the TFTP upload if the 5-second delay isn't working?).

    The burning question is...what went wrong? I'm sure the compiles are R1 (I even forced MIPS32=r1 on a later build to byte-compare it to the previous and it was indeed good), I'm sure they are K26, I'm sure they fit...and I've even loaded K26 R1 (without IPv6) Standard from the same git tree on other WRT models without issue in the past.

    Any thoughts?

  2. charos

    charos Networkin' Nut Member

    Some times a simple hard reset won't do the trick. You need to do the 30/30/30 reset. Basically you press the reset button for 30sec , then while still holding the reset button you unplug the router from the power supply and wait 30sec , then plug the power cable and wait for another 30sec.
    Wait for few minutes and if your router is still bricked , try to tftp again.Here's a video of the process

    If you have a Windows OS , I can suggest Draytek's router tools . In my case it worked when the tftp command from shell didn't manage to upload the bin file.
  3. mstombs

    mstombs Network Guru Member

    Use an old hub between PC and router, windows can then keep media detected.

    Serial console is best for debugging this, or for interrupting the boot to give plenty of time to tftp.

    BUT if its corrupt nvram - the Linksys reset_gpio pin is stored in nvram so reset doesn't work - its 2 hours to build the JTAG cable and 2 seconds to give the nvram erase command...

    I have a WRT54G-TM (with working serial console and JTAG) available if you want me to do some testing?
  4. rhester72

    rhester72 Network Guru Member

    I'm confident I'll be able to recover them with a bit of time investment, that doesn't really worry me (it's just annoying)...what concerns me more is why the build bricked in the first place, because I can't see any reason why it would have.


Share This Page