1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

How to get NI360's WPS button working

Discussion in 'Tomato Firmware' started by DeLaJSR, Feb 5, 2014.

  1. DeLaJSR

    DeLaJSR Reformed Router Member

    Netcore NI360 is a China-Only model, which has a BCM5357C0 processor, 64MB memory, 8MB flash, 2*5 dbi antennas, only for $13

    I've flashed Shibby 115/116 and Hi-Spider 3.11(a chinese localization mod base on shibby), everything worked fine except for WPS button

    button scripts not worked at all, no buttons process after startup, manually start buttons get exit code 1

    check board information
    check wps gpio
    LED worked
    run gpio poll and press/release wps button, F->E when pressed
    disable gpio 20, and gpio poll and press/release wps button, output not affect by wps button, always likes wps button pressed
    How can I get WPS button working? modify buttons.c etc?(and how), use nvram set btn_ses, btn_override?(and how) I have no clue
     
  2. DeLaJSR

    DeLaJSR Reformed Router Member

    I've modified Shibby's codes to add Netcore NI360 support,

    Now the model can be correctly recognized and wps button now works fine
     

    Attached Files:

  3. DeLaJSR

    DeLaJSR Reformed Router Member

    HW v1.0's stock firmware(I've masked MAC addresses)
     
  4. DeLaJSR

    DeLaJSR Reformed Router Member

    HW v1.1's stock firmware(I've masked MAC addresses), can't boot Tomato

    NI360 HW1.1 can use HW1.0's CFE, and boot Tomato

    The 3 antennas ver, "NI360 S3" HW1.1(which has same CFE of NI360 HW1.1) can't use NI360 HW1.0's cfe, will brick the router
     

    Attached Files:

Share This Page