1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

How to tell which RV042 is the problem?

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by ca_picker, Jul 9, 2008.

  1. ca_picker

    ca_picker LI Guru Member

    I am having real trouble with one VPN tunnel between 2 RV042s. Each RV042 has several tunnels to other locations which are generally OK. But the tunnel between the 2 (which, perhaps not coincidentally, is the busiest tunnel of them all), randomly drops the VPN connection. It seems like the problem has been getting worse recently though that may just be because I'm paying more attention to it.

    I've tried just about every permutation of encryption/authorization/life times/DPD/Keep-Alive/etc. and nothing seems to make any difference at all. Sometimes the tunnel will stay up for several hours, but sometimes only a few minutes. Reboots don't "fix" anything, they just cause a tunnel reconnect which may or may not last.

    One router is running f/w 1.3.12.6-tm and the other one is running 1.3.9. I am thinking about trying to upgrade the one running 1.3.9 but it is remote (see separate thread) and I'm not sure it will really make any difference anyway.

    The strange thing is that each of these routers has other tunnels to other RV042s running various f/w versions, and those tunnels work just fine, no drops.

    Are "busy" tunnels more likely to get dropped? If so is there anything I can do to address it?
     
  2. ifican

    ifican Network Guru Member

    Short answer, no. The only thing that comes to mind with this one is to test the order in which the tunnels are created. I would go so far as to drop the other tunnels and just bring up the one and see if it stays stable. Then start bringing up others 1 at a time and see if there is any change.
     
  3. ca_picker

    ca_picker LI Guru Member

    I decided to do some testing of my link and see if I can figure out any other possible causes.

    Here are my latest results of broadbandreports.com's "Smoke Ping":
    [​IMG]

    You can see the one little section of decent latency (and near 0% packet loss at the time) is when I unplugged my RV042 and directly connected a machine :frown:

    When the RV042 is connected, packet loss is near 85% (it *is* set to respond to WAN ping, just for this test).

    So I think maybe I've found my problem. With packet loss that high I would guess that the tunnel doesn't stand a chance of staying connected.

    Is it time to replace my RV042? I have just tried resetting to factory config, then re-enter all my info; no luck. Same deal, tunnel may stay up for a little while but eventually just dies (symptom: both RV042s show it connected, but pings through the tunnel fail).

    I am kind of tired of wasting time on this and thinking just get another router. I don't know if it'll be a linksys. Any recommendations?
     
  4. Sfor

    Sfor Network Guru Member

    The 1.3.9 firmware has a problem with IPSec VPN negotiation over a NAT. It has been solved in the 1.3.10, as far as I know.
     
  5. ca_picker

    ca_picker LI Guru Member

    Thanks...I suppose that may help with the tunnel, but the router with high packet loss is running 1.3.12 (and the packet loss occurs independently of the VPN tunnel), so maybe there are 2 separate problems.
     
  6. Sfor

    Sfor Network Guru Member

    The RV042 devices are suffering from elecrolytic capacitors malfunctions, quite often. Such a situation makes them more and more unstable with time.
     
  7. ca_picker

    ca_picker LI Guru Member

    Interesting...really?!? I'm amazed how some of these manufacturing flaws get so far along in the process of these devices.

    So...would that particular malfunction account for high packet loss (but otherwise "normal" function)? I'm getting this on both WAN ports. When I directly connect a computer instead of the router, no packet loss, so I'm pretty certain that's where the problem is. And it's not like it's 100% loss (as would happen if I was ignoring WAN pings).

    Anyway, weird. As I said I think I'm just going to replace the RV042.

    Do you know if the RV082 suffers the same capacitor problem? How about RV016? I would like to stick with Linksys since I know it but if this is a problem across the product line maybe I'll look at some other brand.
     
  8. Sfor

    Sfor Network Guru Member

    No, I do not know. But, I've heard the simple capacitor change makes the device work as it should to. Hissing noice from the coil can be a sign of the capacitor failure. Still, I had no opportunity to test it myself.

    I have just one suspicious RV042. Still, it works correctly after the last firmware upgrade, so far. Perhaps the factory defaults reset did the trick. But, it does have the second WAN disabled, now. So, I can not be sure of anything.
     

Share This Page