1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

http_id mismatch ?

Discussion in 'Tomato Firmware' started by damwill, Feb 9, 2009.

  1. damwill

    damwill Network Guru Member

    I have noticed the following in my log file and have no idea if it's a problem:
    unknown daemon.warn httpd[756]: http_id mismatch

    Any help or insight is appreciated.

    WRT54G v2.0 running Tomato Firmware v1.23.1607.
  2. fyellin

    fyellin LI Guru Member

    When you download a page from Tomato, it includes somewhere a line of the form
    http_id=TID<random 16digit hex number>
    Most of the forms that you submit to Tomato quietly return this value right back. Tomato will reject the request if the http_id doesn't match.

    This value is saved in nvram and should survive the machine being rebooted, but will be reset if the machine is completely wiped.

    Do you have any scripts that directly make requests to the router using curl or wget?
  3. damwill

    damwill Network Guru Member

    Well I moved from the ND version of the firmware to the regular version and I no longer see the error. I don't believe I have any scripts using curl or wget.
  4. fyellin

    fyellin LI Guru Member

    Any saved bookmarks, "Take me directly to page XX without going through the home page"?

    If the problem has gone away, don't worry about it.
  5. damwill

    damwill Network Guru Member

    Yes, I have a bunch like that.

Share This Page