1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Huawei EC 306 not working with tomatousb by Shibby

Discussion in 'Tomato Firmware' started by alllexx, Aug 22, 2014.

  1. alllexx

    alllexx Reformed Router Member

    I'm a fan of tomatousb Shibby mod (great work, man), and have been using it for a very long time on my Asus RT-N66U with a wired connection. Recently, I've bought a new RT-AC68U, and moved the old N66U outside of the city to a place where the only affordable option to connect to internet is via a 3g modem. The modem I have is Huawei EC 306. To avoid hassle with mode switching, I issued AT commands for the modem to function as modem-only. All three usb tty's (0,1,2) are the serial modem now, and I tried them all (as well as the others) in the respective settings tab, but to no avail. pppd just won't establish connection. I flashed dd-wrt then, and it connects just fine, and the connection is more or less stable, but I like tomatousb a lot moreā€¦
    Here are the logs:


    If there's a way I can get some additional info, please tell me, and I'll try to do that when I have the chance.

    I found this thread on configuring Huawei EC 306 modem on openWrt:
    However, I don't see how this can be applied to tomatousb.

    Can anyone please give me a hint on what I can try here?

    Thank you,
  2. shibby20

    shibby20 Network Guru Member

    modem has been detected:

    You should use ttyUSB0. Be sure you have set correct APN and you have PIN control disabled (and PIN field is empty).
    alllexx likes this.
  3. alllexx

    alllexx Reformed Router Member

    Thank you for your reply, Shibby!
    I used ttyUSB0 here. And I know modem is detected. I even can see some response from the modem from `cat /dev/ttyUSB0` while it's being dialed, but dialing still fails.
    There's no APN for evdo modems, and PIN is indeed disabled and the respective field empty. I also tried setting APN to some random value, the same as user, etc.. Still no good.

  4. remlei

    remlei Networkin' Nut Member

    maybe the RAS mode connection is not supported by your ISP, not sure if shibby supports NDIS connection though.

    ive seen some ISP that doesnt support RAS mode already (due to overhead of PPP which overloads their tower for un-necessary load)
    alllexx likes this.
  5. alllexx

    alllexx Reformed Router Member

    Well, maybe Shibby could tell us if his builds support NDIS.
    I flashed openwrt attitude adjustment 12.09 on my old pocket 3g router asus wl-330n3g, and it works fine with the modem after you configure it properly. As for RAS vs. NDIS, I don't know whether openwrt supports NDIS either.
    Thank you for your reply :)
  6. shibby20

    shibby20 Network Guru Member

    can you detect which module openwrt used to run your modem? lsmod should help or cat /proc/bus/usb/devices
    alllexx likes this.
  7. alllexx

    alllexx Reformed Router Member

    It looks like it's option module.

    T:  Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=480  MxCh= 1
    B:  Alloc=  0/800 us ( 0%), #Int=  1, #Iso=  0
    D:  Ver= 2.00 Cls=09(hub  ) Sub=00 Prot=01 MxPS=64 #Cfgs=  1
    P:  Vendor=1d6b ProdID=0002 Rev= 3.03
    S:  Manufacturer=Linux 3.3.8 dwc_otg
    S:  Product=DWC OTG Controller
    S:  SerialNumber=dwc_otg.0
    C:* #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=  0mA
    I:* If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub
    E:  Ad=81(I) Atr=03(Int.) MxPS=   4 Ivl=256ms
    T:  Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#=  3 Spd=480  MxCh= 0
    D:  Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
    P:  Vendor=12d1 ProdID=1506 Rev= 0.00
    S:  Manufacturer=Huawei Technologies
    S:  Product=HUAWEI Mobile
    C:* #Ifs= 3 Cfg#= 1 Atr=c0 MxPwr=500mA
    I:* If#= 0 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=01 Prot=01 Driver=option
    E:  Ad=81(I) Atr=03(Int.) MxPS=  64 Ivl=2ms
    E:  Ad=82(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
    E:  Ad=01(O) Atr=02(Bulk) MxPS= 512 Ivl=4ms
    I:* If#= 1 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=01 Prot=02 Driver=option
    E:  Ad=83(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
    E:  Ad=02(O) Atr=02(Bulk) MxPS= 512 Ivl=4ms
    I:* If#= 2 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=01 Prot=03 Driver=option
    E:  Ad=84(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
    E:  Ad=03(O) Atr=02(Bulk) MxPS= 512 Ivl=4ms
    Module                  Size  Used by    Tainted: G  
    option                 14992  1 
    sg                     18864  0 
    usb_wwan                6560  1 option
    usbserial              23664  4 option,usb_wwan
    cdc_acm                11424  0 
    dwc_otg                58592  0 
    ohci_hcd               12016  0 
    ledtrig_usbdev          2032  0 
    sr_mod                 10912  0 
    nf_nat_irc               816  0 
    nf_conntrack_irc        2480  1 nf_nat_irc
    nf_nat_ftp               992  0 
    nf_conntrack_ftp        4448  1 nf_nat_ftp
    ipt_MASQUERADE           976  1 
    iptable_nat             2528  1 
    nf_nat                 10368  4 nf_nat_irc,nf_nat_ftp,ipt_MASQUERADE,iptable_nat
    pppoe                   7504  0 
    xt_conntrack            2080  3 
    xt_CT                   1216  0 
    xt_NOTRACK               448  0 
    iptable_raw              560  1 
    xt_state                 608  0 
    nf_conntrack_ipv4       4368  6 iptable_nat,nf_nat
    nf_defrag_ipv4           640  1 nf_conntrack_ipv4
    nf_conntrack           38224 12 nf_nat_irc,nf_conntrack_irc,nf_nat_ftp,nf_conntrack_ftp,ipt_MASQUERADE,iptable_nat,nf_nat,xt_conntrack,xt_CT,xt_NOTRACK,xt_state,nf_conntrack_ipv4
    ehci_hcd               29296  0 
    sd_mod                 22784  0 
    pppox                   1152  1 pppoe
    ipt_REJECT              1680  2 
    xt_TCPMSS               2560  1 
    ipt_LOG                 6096  0 
    xt_comment               400  0 
    xt_multiport            1120  0 
    xt_mac                   528  0 
    xt_limit                 944  1 
    iptable_mangle           816  1 
    iptable_filter           592  1 
    ip_tables               8848  4 iptable_nat,iptable_raw,iptable_mangle,iptable_filter
    xt_tcpudp               1616  4 
    x_tables                9984 18 ipt_MASQUERADE,iptable_nat,xt_conntrack,xt_CT,xt_NOTRACK,iptable_raw,xt_state,ipt_REJECT,xt_TCPMSS,ipt_LOG,xt_comment,xt_multiport,xt_mac,xt_limit,iptable_mangle,iptable_filter,ip_tables,xt_tcpudp
    cdrom                  30400  1 sr_mod
    ppp_async               5984  1 
    ppp_generic            18880  7 pppoe,pppox,ppp_async
    slhc                    4144  1 ppp_generic
    rt2800pci               5264  0 
    rt2800lib              48112  1 rt2800pci
    rt2x00soc               1136  1 rt2800pci
    rt2x00pci               1824  1 rt2800pci
    rt2x00lib              28816  4 rt2800pci,rt2800lib,rt2x00soc,rt2x00pci
    mac80211              250128  3 rt2800lib,rt2x00soc,rt2x00lib
    usbcore                97456  9 option,usb_wwan,usbserial,cdc_acm,dwc_otg,ohci_hcd,ledtrig_usbdev,ehci_hcd
    usb_common               480  1 usbcore
    scsi_mod               69856  3 sg,sr_mod,sd_mod
    nls_base                4672  1 usbcore
    crc_itu_t                944  0 
    crc_ccitt                944  2 ppp_async,rt2800lib
    eeprom_93cx6            1632  0 
    cfg80211              153616  2 rt2x00lib,mac80211
    compat                  4576  3 rt2800pci,mac80211,cfg80211
    arc4                     768  2 
    aes_generic            29600  4 
    crypto_algapi           9216  2 arc4,aes_generic
    leds_gpio               1552  0 
    button_hotplug          2656  0 
    gpio_keys_polled        2064  0 
    input_polldev           1696  1 gpio_keys_polled
    input_core             20000  4 button_hotplug,gpio_keys_polled,input_polldev

    However, I think, it's not a driver issue, but rather a chat script thing. OpenWrt has different default user editable chat scripts fot umts and evdo modems.
    For umts it is
    TIMEOUT 10
    ""      "AT&F"
    OK      "ATE1"
    OK      'AT+CGDCONT=1,"IP","$USE_APN"'
    SAY     "Calling UMTS/GPRS"
    TIMEOUT 30
    OK      "ATD*99***1#"
    CONNECT ' '
    And for evdo:
    # This is a simple chat script based off of the one provided by Sierra Wireless
    # for CDMA connections.  It should work for both Sprint and Verizon networks.
    TIMEOUT    10
    ''         AT
    OK         ATZ
    SAY     'Calling CDMA/EVDO'
    TIMEOUT    30
    OK        ATDT#777
    CONNECT    ''
    If I'm not mistaken, tomatousb uses something similar to the first one, which is not appropriate, as it appears, for evdo modems, hence failing to connect

Share This Page