1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

HyperWRT 2.0b3: Port 21 open?

Discussion in 'HyperWRT Firmware' started by Pistolero, Dec 27, 2004.

  1. Pistolero

    Pistolero Network Guru Member

    Hi Avenger,

    I came across a very funky issue this weekend: Doing a port scan from a friend's house I could connect to port 21 on my IP, but I have no forwardings for FTP to any of my boxes, and telnetting to this port yields a blank prompt. It is likely this port 21 is open and pointing to the router itself, as I tried forwarding it to a dummy IP and I still can connect to it.

    Any ideas?

    Thanks!

    Pistolero.

    PS: Any ETA for HyperWRT 2.0b4 or 2.0 final?
     
  2. Avenger20

    Avenger20 Network Guru Member

    Strange, If you have the firewall enabled (as default) all ports should be stealth.
    Some ISP's (like mine) block ports below 1024, and filter ports like 21. Maybe this is what you're seeing.
    Would be nice if anyone without a ISP port restriction could confirm that port 21 is closed as it should be :wink:

    I'm probably going to make 2.0 final soon, not much changes from 2.0b3, only a few bugfixes.
     
  3. Pistolero

    Pistolero Network Guru Member

    Thank you for the quick reply, Avenger. Regarding the final version, are you going to implement a more permanent fix to klogd right into the firmware? Even with Dellsweig's script, I still find klogd dying and not being restarted, and it still stops logging after either very heavy load or long idle time.

    Thankee-sai.
     
  4. stephbu

    stephbu Network Guru Member

    Just tried Gibson's ShieldsUp against my setup - Port 21 appears to be stealth'd as appropriate.
     
  5. Pistolero

    Pistolero Network Guru Member

    ShieldsUp also reports my port 21 to be stealthed... but I can still telnet into it and attempt to open an FTP session with any FTP client... that's kinda scary 8O 8O 8O
     
  6. Avenger20

    Avenger20 Network Guru Member

    What happens when you use another firmware (sveasoft, wifibox, original linksys, ...)?
     

Share This Page