1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

HyperWRT v1.3 has been released.

Discussion in 'HyperWRT Firmware' started by Toxic, Aug 11, 2004.

  1. Toxic

    Toxic Administrator Staff Member

    HyperWRT v1.3 has been released.

    Changes are as follows:

    - Updated to new Linksys v2.04.4 code
    - Added Command Shell
    - Added AutoRun
    - Added Uptime & CPU Load
    - Added Reboot Button
    - Added Site Survey

    Get the new version here:

    http://www.hyperdrive.be/hyperwrt/

    if version still says 1.2 dont worry. files have already been uploaded and refer to 1.3
     
  2. Avenger20

    Avenger20 Network Guru Member

    Again a very big update, that's close to the HyperWRT I had in mind.
    Hope this version will stay for a long time

    HyperWRT v1.3 Changes:
    - Updated to new Linksys v2.04.4 code
    - Added Command Shell
    - Added AutoRun
    - Added Uptime & CPU Load
    - Added Reboot Button
    - Added Site Survey

    Download at http://www.hyperdrive.be/hyperwrt/


    Command Shell & AutoRun are in Administration -> Diagnostics.
    Command Shell : Only one command a time and full path must be given, for example "/sbin/ifconfig eth1", but after a reboot changes are lost.
    AutoRun : Autorun accepts commands and shell scripts, for example "/sbin/syslogd -R 192.168.1.100" will enable syslogging to 192.168.1.100 everytime the router reboots.

    Uptime & CPU Load is in Status -> Router
    Reboot Button is in Administration -> Management
    Site Survey is in Status -> Wireless
    Only use Site Survey on a wired connection, it will disconnect all wireless clients and force you to reboot to get them back connected.

    People that have problem with visiting certain Website's / connecting to Msn Messenger see FAQ section on my homepage that explains how to fix this Linksys bug.

    You may also submit usefull startup commands/scripts here. Will put them on my site in How-To section then.
     
  3. sblasl

    sblasl Network Guru Member

    WDS - Is this in the latest version?

    WDS - Is this in the latest version of HyperWRT v1.3?
     
  4. JetLi

    JetLi Network Guru Member

    hello
    i try this Firmware. Very good. Its faster. But can you doing in next version with Ping feature in Diagnostic? I like this Feature. This is on official Firmware and this i will on HyperWRT. Of can you doing on 1.3 Firmware? 8)
     
  5. enochcheng

    enochcheng Network Guru Member

    faster?
    unfortunately, this works seems slower than version 1.2 to me
     
  6. enochcheng

    enochcheng Network Guru Member

    another question
    can i run wake on lan via WAN using this firmware?
     
  7. Avenger20

    Avenger20 Network Guru Member

    just typing in "ping www.linksysinfo.org" in command shell for example will do the same.
     
  8. JetLi

    JetLi Network Guru Member

    ok thnx.
     
  9. Avenger20

    Avenger20 Network Guru Member

  10. kimz

    kimz Network Guru Member

    can i do something like this in the shell;

    iptables -t nat -I PREROUTING -p tcp --dport 81 -d [inetip] -j
    DNAT --to 192.168.1.2:80
     
  11. Esquire

    Esquire Mesquire Staff Member Member

  12. JetLi

    JetLi Network Guru Member

    hello
    i have found a bug. Yesterday i had power off my WRT54G rev2 (WLAN LED is off) and now Power On again, the WLAN LED is ON. :roll:
     
  13. Avenger20

    Avenger20 Network Guru Member

    No, was just about an hour.
     
  14. Avenger20

    Avenger20 Network Guru Member

    Idd, that's a small bug. But only the led goes on, not the wireless :wink:
     
  15. FunkMeista

    FunkMeista Guest

    I'm not sure of this has been posted yet but I have a weird problem with BT.

    Forwarded ports 6881-6999 for Bit torrent. Green light status comes out, downloads are fast, uploads are fast..AFTER I have set the MTU to 1492 as u suggestged in ur FAQ. However, as soon as I reopen the BT client program again (Azureus), I get slow downloads, on yellow status (so not enough seeds/leechers to get good u/l and d/l speeds). I have to reset the MTU to Auto and it works again. The next time I reboot Azureus, I have to reset the MTU once again back to 1492 or a lower value..

    Have I done something wrong?

    On a Linksys WRT54G 1.1 with Intel Pro 2200 B/G if that helps.

    Never had this problem with official 2.02.7s or the ones that came with the router originally and I did not have this problem when I used HyperWRT 1.0 and 1.1 for a short time.
     
  16. ebauche

    ebauche Network Guru Member

    VERY tiny bug...

    VERY tiny bug... when you click on "Site Survey", the window that pops up has a misspelled title bar. :eek:
     
  17. Avenger20

    Avenger20 Network Guru Member

    Re: VERY tiny bug...

    Yeah idd, all the code linksys added says "site suvery", just everywhere ;)
     
  18. ebauche

    ebauche Network Guru Member

    If you mean, will the router send "wake-on-lan" magic pings on to other hosts on the LAN side, the answer is yes - I can send a WOL ping from a wireless laptop via the WRT54GS w/ HyperWRT 1.3, and it passed it on.

    Actually, due to the router topology I'm using, it goes something like this:

    Laptop to WRT54GS to a 2nd Router (via a LAN side wired connection between the WRT and the other router) to Other Computer wired into the 2nd router's LAN side..

    Now I can wake up the other machine for printing as needed.

    ed
     

Share This Page