1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Hyperwrt_2.1b1_4.70.6-151005 release

Discussion in 'HyperWRT Firmware' started by Thibor, Oct 15, 2005.

  1. Thibor

    Thibor Super Moderator Staff Member Member

    my latest release can be found in the download section.
    i've integrated some of tofu's 54g changes into it(statics gui amongst others) and fixed some bugs(wireless tx power not changing mainly, and some cosmetic bugs)
    i also added the ability to manually select txpwr up to 251mW, but please be sensible and consider the extra heat generated at this power level.
     
  2. bdm_module

    bdm_module Network Guru Member

    I can't find your latest release in the download section ! :(
     
  3. Thibor

    Thibor Super Moderator Staff Member Member

    it may take Toxic a little time to get it posted, but i've sent it to him
     
  4. none

    none Network Guru Member

    Hi Thibor,

    The latest HyperWRT firmware in the download section is "141005", not "151005" as this announcement.

    Is this a new version that still needs to be added to the download section?
    If so, do you have a download link?

    Also, are you planning to release a "stable" version sometime in the future or just keep releasing regular and frequent updates?

    Thanks.
     
  5. Toxic

    Toxic Administrator Staff Member

  6. Thibor

    Thibor Super Moderator Staff Member Member

    thanks Simon, you may wish to change your sig though, it's Thibor...not Thobir(or are you now using Thobir's firmware????)
     
  7. Dwibbly

    Dwibbly Network Guru Member

    New Firmware Update

    Hi all.

    I often check the Linksysinfo site for updated firmware, it's great someone is keeping this baby up to date.

    I have a WRT54GS 1.1 with Linksys High Gain Antenna, runs sweet.

    Still a bit unsure about Client mode and what it does, i'll have to do a bit of ready.

    I used to have a WAG54G, what a load of rubbish.

    :thumb:
     
  8. Laurentwb

    Laurentwb Network Guru Member

    Hi everybody,

    I'm afraid something is wrong in the download section. Indeed, I downloaded and installed the 15-10-2005 firmware but I get following installed :

    "Firmware Version : v4.70.6_Hyperwrt-2.1b1-(Thibor), Oct. 8, 2005 ".

    Moreover, no way to increase the TW power higher than 84 mW.

    Could anyone with admin right for the download section check if everything is really alright ?

    Thanks.
     
  9. Toxic

    Toxic Administrator Staff Member

    let me check m8
     
  10. Toxic

    Toxic Administrator Staff Member

    sorry just downloaded 151005 build installed and it says:

    v4.70.6_Hyperwrt-2.1b1-(Thibor), Oct. 15, 2005

    so i dont know why you have a different build.

    the 151005 is here.

    please re download and make sure you upgrade using the correct firmware binary.

    filename of binary is:

    Hyperwrt_GS_4.70.6-151005.bin
     
  11. LiquidEnforcer

    LiquidEnforcer Network Guru Member

    I Have a WRT54G v4 I try and upgrade and it gives me "Upgrade are Failed" message. Ive tried using a direct ethernet connection, reset factory defaults. Used the reset button on the router. Power cycled it. Set my computer to a statc IP. Nothing seems to work. I have firmware v4.20.7 installed on the router. Ive tried Firefox and IE. Im at a loss.

    Any help would be appreciated. Thanks.
     
  12. Toxic

    Toxic Administrator Staff Member

    you have a 4.20.7 firmware which is for the WRT54G,

    Thibors Build is for the WRT54GS

    use Tofu's build please. check the WRT54G (NOT the GS version) HyperWRT downloads.
     
  13. LiquidEnforcer

    LiquidEnforcer Network Guru Member

    And im stupid! Thanks for the help man.:)
     
  14. SirDracula

    SirDracula Network Guru Member

    What's wrong with httpd in this version? On my WRT54GSv3 it crashes after a while. If I telnet in the httpd process is gone. The router seems to still be functioning OK.

    httpd tries to restart as I see it in the process table but I can't connect to it and it goes away after a while ...

    Has anyone else run into the same problem?

    Thanks.
     
  15. SirDracula

    SirDracula Network Guru Member

    I think it has something to do with the wireless being in use. httpd stays up for a long time if I don't have any wireless clients attached to the router. As soon as the 1st wireless client attaches, httpd dies. Looks kinda weird, why would httpd die? The wireless client is not even trying to access the router's web interface.
     
  16. SirDracula

    SirDracula Network Guru Member

    OK, I think I found the problem: if the option "Wireless Access Web" under the Administration tab is set to Disable, then httpd crashes when a wireless client attaches to the AP (it doesn't have to try to access the web interface).

    Any idea why this happens? Any recent changes in that area? It didn't use to happen in the previous version 081005
     
  17. sq3hta

    sq3hta Network Guru Member

    Advanced routing is not working

    On this version advanced routing is not working, after define the route and push save settings I geting clean page. Something wrong?
    Pawel :(
     
  18. Thibor

    Thibor Super Moderator Staff Member Member

    @sq3hta: I've tested advanced routing just now, no problems here.
    @SirDracula: this is the first time i've done anything regarding this function. can you describe how it usually works?
    i've just tested this and it happened this way:
    1. Disable Wireless Access Web, and Apply settings
    2. httpd is killed and 2 mins later comes back up
    3. Wireless clients can browse the internet without issue, but if one tries to access the web interface, httpd is killed again(2 min respawn time)
    I think the reason httpd was killed, is because i was trying to access http from behind a client mode router.
     
  19. SirDracula

    SirDracula Network Guru Member

    httpd should not die. In my case, the wireless clients do not even have to try to connect to the web interface, just being attached to the AP will kill httpd. And yes, I see httpd trying to come back up but it keeps getting killed, it doesn't stay up, so it's unusable.

    This did not use to happen in the previous version of your firmware, so something changed.

    What used to happen: the wireless client would get an error message (the pink error page that you see when you type the wrong password for example) when trying to access the web interface and httpd would still be fine.

    I'm using MAC address filtering for the wireless clients and also WPA2-PSK if you think that could make a difference ...

    Do you know if this is fixed in the latest 1610 (or 1710?) version? I don't want to upgrade and run into more significant issues. In fact, I think I will revert back to 0810, it did everything that I wanted it to.

    Btw, as a personal preference, I liked the interface for static DHCP in 0810 much better than in this 1510, it was easy to cut & paste the entries from a text file, now they have to be entered manually one by one, which is tedious if you have 10+ entries ...
     
  20. Thibor

    Thibor Super Moderator Staff Member Member

    you were of course correct. there WAS a problem, it's now fixed and was quite obscure too.
     
  21. SirDracula

    SirDracula Network Guru Member

    Do you have a build w/ this fix please? Thanks for looking into it.
     

Share This Page