1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Improving WNR3500Lv2 support

Discussion in 'Tomato Firmware' started by koitsu, Mar 25, 2012.

  1. koitsu

    koitsu Network Guru Member

    First and foremost, before responding: I'm talking about the Netgear WNR3500Lv2. Please note the "L" and the "v2" designators. I am not talking about the WNR3500v2. Herein I will refer to the WNR3500Lv1 as "v1" and the WNR3500Lv2 as "v2".

    Secondly: if you're trying to determine what model of unit you have, the v2 units have printed on their box that the router has 128MBytes of RAM + 128MBytes of NAND flash, and have "WNR3500L v2" printed on the back of the unit under the yellow WAN port. Here's a photo of the two versions (v2 on the top, v1 on the bottom). It's that simple.


    So far, the only Tomato or TomatoUSB-based firmware that appears to work on this revision router are Shibby's builds. I've not been able to confirm that the Toastman builds have support for v2 units (keep reading).

    Here are some reference posts confirming that end-users are having difficulty figuring out what's supported and what isn't when it comes to TomatoUSB (including some folks bricking their router because some of the firmwares claim "WNR3500L support" yet that claim is too vague given that there are two completely different versions (v1 and v2)):


    My concern lies with the fact that most vendors are no longer selling the v1; they are only selling the v2, since they sell the product as "WNR3500L" (no version specified). As such, v2 support is quite important!

    I don't know what changes Shibby made to his builds to get support for the v2 working, but I would like to request that those changes be backported or merged into other versions (such as Toastman's and Teaman's).

    Until that can be accomplished, I'd also like to request that Toastman rename his 4shared site directory titled RT (MIPSR2 - newer routers like RT-N16, E3000,3500L etc) - NORMAL BRANCH to instead say "3500Lv1" (note the v1). As it stands right now simply stating "3500L" implies both versions are supported, which does not appear to be the case. I don't know if/when this can be done since 4shared has been sucking goats lately (see page 3).

    Finally: if folks need to use me as a guinea pig for testing builds on a v2, let me know in this thread or privately, as I regretfully have one which can be used as a test unit for the time being. I have no interest in using the stock firmware on it, so as long as I can get boot_wait enabled bare minimum I have no problem testing things.
  2. Toastman

    Toastman Super Moderator Staff Member Member

    No Toastman builds currently have any support for the V2. I have held off with the V2 because I have bricked my V2 router by flashing with known good V2 builds, which should not have happened, and now the serial port doesn't seem to be working with any device I have. I am waiting for another type.

    Netgear have made a real mess of this naming biz, haven't they?

    I agree with you, the wording is easily changed to V1 to make the distinction. I'll do it.
  3. koitsu

    koitsu Network Guru Member

    Thanks much Toastman.

    Yup, in full agreement about Netgear -- they should have just called this the WNR3501L or something like that, rather than muck about with version numbers.

    Then again over on the official TomatoUSB forum I've now found Asus doing the same thing with their RT-N16 units (their new H/W Revision A1 units may be using a different Broadcom switch IC for the 5 Ethernet ports, or are using the same chip but a different silicon revision which results in auto-neg not being as compatible as the older Asus model). Grrr... EDIT: Just got a response from a forum user about that issue; it's looking more like a PHY/NIC issue on the Motorola side than the Asus side, as the other users' SB6120 (a newer H/W rev though) negotiates gigE just fine.

    If you're worried that somehow the serial lines are busted on your v2, let me know and I can ship you (my dime) my WNR3500Lv2 (I haven't even taken it out of its box) for testing/development use. Alternately I can open it up + wire up the necessary headers for serial connectivity (I'm familiar with this as long as someone has a pinout diagram somewhere and know what voltage it requires, e.g. 5V or 3.3V for a MAX232 chip or FTDI TTL-232R-5V or TTL-232R-3V3 adapter). I could probably rig up remote access for you (remote access to router, as well as remote access to the serial port via TCP). Let me know time permitting!
  4. shibby20

    shibby20 Network Guru Member

    I added NAND support and share/id detection:

    One more think. 3500L (v1) is supported by RT branch ( wireless driver). But 3500Lv2 is supported ONLY by RT-N branch ( wireless driver).

    As i know, only my tomato-RT-N mod supports new WNR3500Lv2
  5. Toastman

    Toastman Super Moderator Staff Member Member

    It has a serial header already :)

    Problem is that the serial connection on the router I have is sending garbage. Or more correctly, I can receive data from it if I boot it, quickly attach the rx line and then the ground. Otherwise it receives garbage. Strange. But since I can't get it to receive anything I can't break into cfe to enable tftp. I have 2 PC's with serial ports and used with MAX232 chip convertor and also a CA42 clone USB cable. Both adapters do the same. These cables work fine with every router and satellite TV receiver I've ever tried so this is rather strange. I'm currently waiting for one with an FTDI chip because that is what other people have used successfully. It would be rather odd if the serial port was actually busted.

    I haven't seen an RT-N16 yet that's any different from the very first one that I bought.
  6. koitsu

    koitsu Network Guru Member

    Understood -- thanks for clarifying. Since the board already has pin hookups for serial, can you tell me what voltage (3.3V or 5V?). It obviously matters since I have to decide which FTDI cable to use. :)
  7. Toastman

    Toastman Super Moderator Staff Member Member

  8. Toastman

    Toastman Super Moderator Staff Member Member


    The FTDI cable (spec above) was able to send and receive from the 3500LV2 and the router is now recovered. I have flashed the router now several times both with tftp and by normal tomato upgrade page and it worked OK each time. Why it bricked before is unexplained. So now that doubt is removed, I've added 3500L v2 support to my RT-N branch.

    EDIT - now the other serial cable based on ARK chip also works, as does the MAX232 Level Shifter used with normal serial ports. Go figure ... !
  9. koitsu

    koitsu Network Guru Member

    Awesome, thanks much! My 3V3 cable is in the mail (I already had a 5V cable for a different project). I see that you uploaded 1.28.0497.1 STD type RT-N-VPN (.chk file) to 4shared; any chance of getting the same but for RT-N-Ext? (That's what I tend to run) No rush on this though. :)

    EDIT: Actually, now that I see the VPN build is the same as Ext except it includes VPN support (which I don't use), I'll go ahead and give that a shot when I get home tonight. With 128MBytes flash, I have no reason to be crying/whining over 400KBytes of extra used space.
  10. Toastman

    Toastman Super Moderator Staff Member Member

    This router has a different behaviour to what we are used to. Instead of being able to tftp to it during a small "window" on bootup, but it has two different mechanisms for flashing apart from the GUI.

    1) On bootup the router will look for a tftp server on and if there is a file on it called "vmlinuz" it will download and flash it. So you could rename your file to vmlinuz and upload it that way. When my router was bricked, this didn't work :(

    2) To manually tftp to this router you have to attach a serial cable, break into cfe with CTRL-C, and then enable tftp on the router by typing "tftpd" at the prompt. Now the router will just wait for an upload.

    BTW - the wireless seems to have similar signal strength to my RT-N16 sitting next to it, a little weaker perhaps, 2dB or so.
  11. koitsu

    koitsu Network Guru Member

    Wow, that is indeed quite a difference in behaviour. It sounds like the WNR3500Lv2 on boot-up actually does a PXE boot! It's disappointing that it always looks for a TFTP server on a hard-coded IP ( rather than relying on what the DHCP server can return to it (this would be the "next-server" parameter in ISC DHCP syntax and is supposed to be supported per some RFC which I can't be bothered to look up right now).

    I'll explain my situation in another thread, and I imagine (Toastman) given your great expertise with wifi, you can probably clue me in to what my best choice would be. I'm both a senior UNIX SA and a mid-level NA, but wifi is something I have very little experience with. I'll start another thread for help rather than take over this one. :)

    Good info in general here though, thank you so much.
  12. lollekatt

    lollekatt Reformed Router Member

    I'll just necrobump this one ,p

    I have a wnr3500Lv2 I had with shibby for ages, love it. However, I saw an openwrt recently bet build for the v2, got the test to try, and it got bricked. Unlike the usual brick, I couldn't keep a tftp window long enough to upload a fw.

    So I got a usb serial ttl thingy.. it was a cheap ebay one, but said 5V but 3.3 V further down. Unfortunately, I did a mmistake... and didn't just do gnd, tx, rx, but I slapped on the VCC :/

    DOn't ask me why, anyway this multimueter told me it's 5v indeed, and I prolly fired the fecker.

    The poiwer light now blinks continously and I can't do anythign else. In the serial console I only get 0x00s for each led blink (1-2 Hz). It is properly fried/bricked ruined I guess.

    Has anyone got some more tips for this.. as in , coudl some shorting some bootsel pins or some shite work?

    I really _love_ the router and don't wanna discard it but guess it's a paperweight.

    I was given yrs ago a zyxel p2812, and I have in fact recovered that in the meantime with openwrt, so I have another backup router (along with an earlier wnr3500L I picked up for 10 quid used and is ok).

    Is there any hope short of desoldering (I don't think I cba :p)?

Share This Page