Incoming log & syslog

Discussion in 'Tarifa Firmware' started by nozmoking, Aug 31, 2008.

  1. nozmoking

    nozmoking LI Guru Member

    Just upgraded to b033 RC 1 and noticed that although I have syslogd and packet logs enabled, the messages log file and incoming log are empty. I also noticed that the ping function under diagnostics does not work either - tracerte does however work fine.

    Can anyone advise?

    Thanks...
     
  2. Outer Marker

    Outer Marker Guest

    I believe jchuit is working on Tarifa 034 that should address these issues. I am not sure when 034 will be released, but I don't think it will be long now.

    At one time there was a Tarifa 033RC2, but I don't know if this will resolve your issue.
     
  3. jchuit

    jchuit Network Guru Member

    The wrt54gl v1.1 can have a new type of flash memory, this could be the source of your problem.

    At the moment I am building a new firmware based on the 4.30.12 source, this solves this mysterious bug.

    The user interface is still the original, but the rest is updated.

    ftp://krumdeel.dyndns.org/Public/wrt54gl/Tarifa034beta3/

    Remark: Telnet is started at default after a factory reset, the administration webpage does sometimes gives a faulty message, but it does work.

    Greetings,
    jchuit

    Added:
    (b000) rc_startup en rc_shutdown
    (b001) passwd security for logon to Linux
    (b002) telnetd
    (b002) Tx-power setting upto 251 mw
    (b010) Tx-antenna and Rx antenna diversity setting
    (b004) static dhcp
    (b030) syslog and klog

    updated:
    (b022) busybox 0.6 to 1.1.2
    (b013) squashfs 2.0 to 2.2-r2
    (b014) mksquashfs 2.0 to 2.1 (indexed, 64 kbyte block size)
    (b028) Netfilter / iptables 1.2.7a to 1.3.5
    (b034) MiniUPnPd , see: http://miniupnp.free.fr/
    (b034) dnsmasq 1.10 to 2.45, cachesize increased from 150 to 2048

    solved:
    (b028) incoming log, this doesn't work in the original firmware
    (b013) webpage loading problem due java-script error for Ubuntu/Firefox/konqueror/etc
    (b023) Bridge Restict mode change after boot

    changed:
    (b034) Netfilter / increased size of hash-table to 2048, in case of a wrt54gs (32MByte RAM) to 8192
    (b034) Netfilter / improved NAT hash-table population, Bob Jenkins Jhash Algoritm
    (b034) Netfilter / CONNTRACK set to maximum of 2048 connections, in case of a wrt54gs (32MByte RAM) to 8192 connections

    date 1 Sept 2008
     
  4. bake73

    bake73 Network Guru Member

    I'm using the latest build and the ping function still doesn't work, also on the admin page i get an error message when i change any settings. btw i'm using a wrt54gl v1.1
    Any idea when a new build will be out?

    Keep up the good work :)
     
  5. jchuit

    jchuit Network Guru Member

    Two weeks ago I started working on 34RC2, this should also solve the error message in the admin page.

    I searched for two days to solve this nasty bug, but still no sollution. It looks like a variable that indicates an error has a wrong initial value set.

    Luckely it is only a message, if the error status variable is set a message is generated.
     
  6. bake73

    bake73 Network Guru Member


    Ok cheers mate and thanks for the speedy reply :cool:

    I look forward to your next build.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice