1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Initial flash of RT-N16 won't take

Discussion in 'Tomato Firmware' started by krasnal, May 12, 2012.

  1. krasnal

    krasnal Serious Server Member

    This is my first post on this forum but I've been a Tomato firmware user since v1.22. I progressed through the vanilla Tomato and am currently running version 088V of the Shibby build, complete with a working VPN, so am no greenhorn.

    A couple of weeks ago a port failed on my WRT54GL, so I decided to upgrade to an Asus RT-N16. I ran it with its native firmware for a week or so to see if it had any hardware issues but all worked well. So, time to upgrade to Tomato...

    I followed the instructions at the TomatoUSB site to the letter but it just will not take the new firmware. First I tried Shibby 088V (for K26) and then, when that didn't work, Victek 9006 (tomato-K26USB-1.28.9006MIPSR2_RAF-VPN-NOCAT.trx).

    For the record, the PC is an XP/SP3 laptop and the Asus recovery tool is version that was provided on the CD with the router.

    Here's what I see:

    1. The router goes into recovery mode ok and the power light flashes. At this point, the router is still pingable.
    2. I select the firmware (either Shibby or Victek: the result is the same) and choose to upload.
    3. There is some activity on the port LED for about 10 seconds and then the power light stops blinking and either goes off or stays on permanently (it seems to be random whether the light ends up on or off). After 31-32 seconds, I get an error message telling me that the router is not in recovery mode. At this point, the router is no longer pingable.
    4. I've waited patiently for something to happen but the router is completely unresponsive to pings or http.
    5. Power off/on and I'm back to the stock Asus firmware.

    I've tried as many permutations as I can think of but it always ends up the same.

    Anyone have any ideas?
  2. BikeHelmet

    BikeHelmet Networkin' Nut Member

    I flashed to DD-WRT first through the web interface. After that I flashed to TomatoUSB, then eventually to Toastman's firmware. No issues so far.


    You're likely on a different stock firmware than I was. I flashed several years ago... still, I'd hope the "Firmware for Initial Flashing" would work just the same?

    You'll have to search the DD-WRT forums if you want to confirm it works fine. They have threads there for every model of router, and people are constantly posting their successes and problems.
  3. krasnal

    krasnal Serious Server Member

    Thanks BikeHelmet. Much appreciated. I'll try the DD-WRT route and report back.

    For the record, the Asus firmware restoration utility gives the same problem on a second (XP/SP3) machine. I even tried to upgrade the Asus firmware (from the original to through the firmware recovery utility and got the same problem. However, I did manage to upgrade via the browser interface without any problems, so the router is still working. Perhaps Asus have tweaked their recovery firmware.
  4. Manna420

    Manna420 Networkin' Nut Member

    Once you have succesfully installed the tomato firmware, ill suggest you upgrade to the following build:
    Tomato Firmware 1.28.0000 MIPSR2-092 K26 USB AIO

    I just did that for 3-4 days ago, and im not regreting at all. Its just amazing how many features it provides.
  5. krasnal

    krasnal Serious Server Member

    Looks like the recommended route for upgrading from stock is indeed via DD-WRT, rather than the firmware recovery utility. It certainly worked for me. Perhaps the TomatoUSB instructions need to be revised - or at least a caveat added to indicate that there are alternative

    For the record, I downloaded file dd-wrt.v24-14896_NEWD-2_K2.6_mini_RT-N16.trx from DD-WRT and upgraded without issue via the Asus GUI. Cleared the NVRAM, rebooted and then loaded Victek's Tomato RAF: tomato-K26USB-1.28.9006MIPSR2_RAF-VPN-NOCAT.trx.

    The machine rebooted but still showed DD-WRT on the logon screen. Strange... Then I couldn't logon using admin/admin. No joy via telnet, either. Yikes. I'd read conflicting advice about doing a 30/30/30 reboot but, after some more head scratching, gave it a go. Success! (NB Use the RED WPS button.)

    @Manna420: Is that a Shibby build?
  6. jed_99

    jed_99 Addicted to LI Member

    I received 2 -RT-N16's last week, so just did my updates. I had the same thing as you happen when flashing via the Asus utility. But what worked for me was, disabling the firewall. I must have tried half a dozen times before disabling the firewall, did that, and it immediately took. Did the 2nd router on the first try. To clarify, this was straight to Tomato from stock.
  7. krasnal

    krasnal Serious Server Member

    @jed_99. Interesting. You need to be a bit clearer. Firewall on the PC or router? FYI, I recall that disabled the "firewall" on the stock Asus firware and it didn't do the trick. But, of course, each time I tried to upload the firmware, I went into recovery mode, so perhaps it reverted back to the enabled state. I also set the PC filewall (Comodo) to allow all traffic from the firmware recovery utility, so it wasn't strictly disabled but that should have been sufficient, IMO.
  8. Toastman

    Toastman Super Moderator Staff Member Member

  9. krasnal

    krasnal Serious Server Member

    @Toastman: Mine was from the supplied CD. I also read your comment that "Some people report that they have trouble with the downloaded version and that the one supplied on the included CD (available from this link) works OK." so thought it best to stick with the one from the CD.

    Maybe the problem all along has been with a router setting, eg firewall, and reports of dodgy versions are spurious.

    However, just to keep the record straight, the firmware recovery utility on my CD is version Perhaps you can tell me what version is at 4shared. (I'd check myself but it looks like I need to register to get the file.)
  10. Toastman

    Toastman Super Moderator Staff Member Member

    I don't know what version it is right now, I just know that it worked for many people who had trouble with the one they had. It was supplied with the very first RT-N16 I bought when it came out. I personally have never needed to use DD-WRT or jump through hoops, the recovery tool has always worked, in fact usually flashing from the supplied firmware works fine.

    You need to register with 4shared nowadays, but give any email address will work, just keep a note of it!
  11. kthaddock

    kthaddock Network Guru Member

    Toastmans version is:
  12. xtacydima

    xtacydima LI Guru Member

    I found that pressing the reset button whilst powering on the RT-N16 for 20sec (actual seconds use a timer) will always work, I seen many cases where the router becomes pingable and seems like you can upload to it at shorter time frames but it will fail.

    Did you make sure you set a static IP on your PC, I didn't see you list this as your step?
    I used the ASUS recovery tool, my version happens to be and it seems to be the safest most reliable way I think.
    Also, what happens exactky is once the flash starts you see a progress indicator start, I still keep the reset button depressed until a few of the blue progress percentage starts to go, and then I let it go, sometimes if you let go immediately upon seeing the indicator go off, it will also not work.
    This has always worked for me, I hope it helps.
  13. krasnal

    krasnal Serious Server Member

    @xtacydima: Yes, static IP address used. Like I said originally, I followed the instructions to the letter.

    The router seemed to go into recovery mode very quickly (after just a few seconds pressing the recovery button), so I never thought it necessary to hold the button anywhere near as long as 20 seconds - and the TomatoUSB instructions don't even hint that it might be beneficial to keep the button depressed for so long.

    No %age progress indicator was ever shown. Once the Upload button was pressed, it would briefly flash a message to the effect that it was looking for a suitable IP address and then show a message saying that it was uploading, with an elapsed time counter, not a %age progress indicator. When the counter hit 31-32 seconds, it would report that the router was not in recovery mode.
  14. xtacydima

    xtacydima LI Guru Member

    well, try 20sec like I mentioned, see what results you get, and remember, depress the reset and hold it in just before plugging router power in
  15. WRD - EasyTomato

    WRD - EasyTomato Networkin' Nut Member

    Hey guys. For all of you with the Asus RT-N16 we've written some very detailed install instructions. They are overly detailed for most folks on this forum (they hese are written for another version of Tomato and a less technical user base), but they give you an idea of how the process works. We should have a nice install video going up soon too.

    Our thoughts on Recovery Mode (TFTP) installs vs DD-WRT (both of which we've done FAR too many times by now) are as follows:

    DD-WRT-mini Install: works first time, every time regardless of the computer OS, firewall status, or recovery software version. It takes at most 5 min longer (including 3 min of waiting for the second flash). If you're new to flashing Tomato on the router, I would go this route. Unless of course you really just don't have that extra 5 min to spare, but do have hours of free time to troubleshoot should things go wrong :)

    Recovery Mode Install: It's faster if you get it right, but it can be finicky as is seen from the post above.

    Hope this helps!

Share This Page