1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Installing Config from one 54GL to another?

Discussion in 'Tomato Firmware' started by D2149, Mar 4, 2010.

  1. D2149

    D2149 Addicted to LI Member


    I have recently started to have problems with our oldest WRT54GL router. (We have three of them) As luck would have it, this is the one we are using as our MAIN router. The other two are used as bridges. The problem with 54GL #1 is that it keeps having intermittent issues with the WIFI portion going dead and not being able to connect to the internet even though all of our laptops and wireless devices are able to connect to the router just fine, and all devices connected to the ports on the back can get out just fine at this same time. For some reason, devices trying to get out via WIFI are not getting out to the WAN even though they can connect to the router with no problem.

    Anyway, after reflashing Tomato 1.27 onto the unit, and restoring a saved config, even hard resetting it in between, the router continues to suffer from this odd problem, so out of desperation, I grabbed one of our other 54GLs that are being used as ethernet bridges and planned to install this one as our MAIN router until a new 54GL we ordered today arrived.

    Here is the problem... When I attempted to upload the saved config file from 54GL #1 to 54GL #2 I got a message on the browser screen from Tomato saying that I could not restore this config file to a different router. :frown:

    All this time I have assumed that in the event of something like this happening, I could just swap out one of the other 54GLs and upload the config file used for our main router to the backup router, thus being able to use it as our main router until a permanent replacement was installed.

    So... Why can't I restore a config from one 54GL to another identical unit? The configuration of our main router is very involved and has over a dozen devices specified with MAC addresses and such for static IPs, a bunch of port forwarding settings etc. etc. etc. Basically LOTS of stuff to configure by hand!

    I shudder at the thought of having to MANUALLY configure the new 54GL when it arrives tomorrow.

    Does anyone have any idea why I can't do what I am attempting to do here? It seems like a no brainer kind of feature to be able to move a config from a dying router to an indentical replacement, since we all know, as much as we all love our 54Gs, they don't last forever.

    Any advice or suggestions would be GREATLY appreciated! The new 54GL arrives tomorrow (03/04/10) and I really don't want to have to configure the new one manually. It could take me literally HOURS to get everything entered into the new unit if I can't simply restore to it using my saved config from 54GL #1.

    Thanks in advance!

    P.S. I emailed Jon earlier today with an urgent plea for help, but he has not responded and I am running out of time.


  2. Toastman

    Toastman Super Moderator Staff Member Member

    There is a scheme Jon implemented deliberately for preventing you from restoring configuration data from one router to another. Many of us have been trying to find reliable and simple way around this, but I don't think there's any good solution as yet. I am one of those who bricked a WRT54GL while trying (restored with JTAG). I am afraid you may have to enter your configuration from scratch after a complete NVRAM reset.

    It would be very useful to be able to do this!

    Your configuration does not sound so complex. I have between 80 and 130 users in various buildings, and it takes me about 2 hours to re-enter everything, I cut and paste between old and new router.

    BTW - it sounds to me more like it may have been corrupt NVRAM and not a hardware fault. Restoring from a recent saved config will not help if that is so, you would need to start again. Did you try install from a very old config backup file from a date when it was known to work correctly?
  3. D2149

    D2149 Addicted to LI Member

    Hi Toastman!

    Thanks for the info! I was afraid that this inability to restore a config from one router to another identical model was deliberate. I can somewhat understand his reasoning, but in any situation like this it makes far more sense to give the user the OPTION to turn the failsafe OFF in case the user WANTS to restore the identical config on a second unit due to a failure of the first.

    To answer your question... Yes... I restored a config from several months back when the router was working normally. However, this particular router has had episodes like this in the past where the entire WIFI section just goes south for no apparent reason while the ports continue to work normally.

    In the past, restoring from this same config file would fix the problem, but not this time.

    I have to agree that my config is not as involved as yours is, but I would still much prefer to save myself all that tedium and just upload the config file this unit will need to use when it replaces the defective main router.

    Still no word from Jon on my email. I was hoping that he could send me a script or something that would override the stuff blocking the ability to copy over the config from the defective 54GL.

    Thanks for your help!

    Much appreciated!
  4. Toastman

    Toastman Super Moderator Staff Member Member

    I guess it's really busted then. Pity. I believe there is absolutely zero chance that Jon will have created any way to disable this, though, so you may as well start typing now :biggrin:
  5. D2149

    D2149 Addicted to LI Member

    Thanks...Yeah... I bit the bullet earlier today and configured the new router by hand. I printed out all the pages of settings from the one this is replacing and just went through page by page setting everything up.

    It is working great, so hopefully my WIFI issues are now a thing of the past.

    I also discovered that the problem with flashing Tomato onto the new GL was the fault of Safari and not the hardware! This unit had the same problem, so I called Linksys and they informed me that the latest version of Safari is not playing nice with their routers for some reason.

    This explains why I had no problem 3 months ago when I upgraded the last 54GL. That version of Safari obviously didn't have this problem that must have been introduced in the most recent update of the browser.

    One good thing to come out of all that was during my searches for a reason for the problem, I came across a website that detailed how to replace the vworks OS on a 54G v8 with Linux and then flashing DD-WRT v24 micro on it! :D

    I had a 54G v8 in the closet gathering dust, so I hooked it up and ran the conversion. Worked like a charm! Now I am using that as a repeater bridge for my weather radio streaming server to Weather Underground. The signal strength via WIFI was always a bit low, so now I have it hooked to that v8 with ethernet and boosted the transmit on the v8 to 80 which gives it a great signal to the main router.

    Glad someone found way to get Linux onto those newer versions of the "G" that previously could only be used with the stock firmware!

Share This Page