1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Internet connection extremely slow.

Discussion in 'Tomato Firmware' started by riveral, Aug 20, 2008.

  1. riveral

    riveral Addicted to LI Member

    I am currently running a Linksys WRT54GL with the latest tomato firmware.

    I just installed a this brand new router with tomato, restored the device to tomato's defaults, and entered in all of the information needed to get my static IP internet connection. (I copied all of the information from my previous linksys router (ww-drt) that I just retired).

    The problem is that after setting everything up the internet was extremely slow and would time out when trying to retrieve email via POP3. The whole network was bottlenecked and only received 10mb in the 3 hours that I let it run in order to see if it would work itself out. I tried rebooting machines and renewing connections.

    Frustrated, I set up a OEM linksys router the settings and replaced my new tomato router. Almost immediately, the internet connection was back in complete working order.

    What happened?
    Other info: I'm pretty sure the ISP is comcast.
  2. pharma

    pharma Network Guru Member

    After you loaded the firmware, did you do reset the router? If you had DD-WRT running on it before you'll probably want to make sure nothing is left. I believe there is a FAQ on Jon's Tomato website with regard to the procedure on flashing Tomato when the previous firmware was DD-WRT.

    You might also try loading the firmware again and trying the default settings. It's possible something you included in setting up Tomato is causing the issue.


Share This Page