1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Internet connection problem with LINKSYS WRT54G v.2 Router

Discussion in 'Cisco/Linksys Wireless Routers' started by satmaster, Apr 23, 2005.

  1. satmaster

    satmaster Network Guru Member

    Hi all,

    My uncle has Neighbourhood cable, and has just purchased a new pc, so he now has 3 PC's. He wants them all to be networked together and have access to the internet. Now I just purchased a new LINKSYS WRT54G v.2 router.
    I have connected the cable modem to the router, and the internet is not working.
    He has a Static IP, In connection type in te router's control panel, I chose Automatic - DHCP, and my internet doesn't work, I tried setting it to Static IP, and put in my IP, Gateway, and everthing else needed, apart from the Host Name and Domain name.
    Still wouldn't work, would this be because I dont have the Host name and Domain Name?

    Also I used a normal cat5 patch cable to connect from the modem to the router, am I supposed to use a Cross over cable?
    I thought maybe I had to use a cross over cable, so I connected the modem >>> 8 port switch >>> Router >>> PC and still cant get internet access.

    Maybe Im not selecting the connection type properly, Ive tried Static IP and Auto- DHCP.

    The internet works perfect, when connected directly from the modem >> PC.

    The router looks like this.

    Modem Port


    I plugged the modem into the modem port, and the pc into one of the ports.

    I did power cycle with DHCP mode.
    And each pc had its IP address:

    But, no internet connection.

    Any help, greatly appreciated.
  2. howardp6

    howardp6 Network Guru Member

    Please indicate the cable provider. Some cable providers require you to clone the MAC address of the PC. You should power everything down for at least thirty seconds after cloning the MAC address of the PC that was able to connect to the cable modem. Turn on the modem, the router and then the PC.
  3. satmaster

    satmaster Network Guru Member

    Thanks, I will try cloning the MAC address into the router.

    The cable provider is, Neighbourhood Cable (AUSTRALIA).

  4. satmaster

    satmaster Network Guru Member

    Thankyou very much.
    It was the MAC address, I had to clone it into the router.
    Now everything works 100%.


Share This Page