1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Internet Connectivity Help

Discussion in 'Tomato Firmware' started by Affinity, Jul 22, 2013.

  1. Affinity

    Affinity Reformed Router Member

    Intro:
    I hope everyone's day is going well. Anyways, I ran into a problem while setting up a router which I thought was interesting and wondered if anyone might be able to point me in the right direction so that I might solve it.

    Info:
    Router - RT-N16
    Build - 1.28.0502 MIPSR2Toastman-RT-N K26 USB Std
    Setup - [ISP --> SB Modem --> Router --> Devices]

    Problem:
    I noticed that on a reboot of the router, my internet connectivity on all devices connected to the router vanishes. However, I check my router status and see that the router does indeed have a lease with the modem, which is strange. So then I try all the trivial things like restarting my modem, restoring to default settings my modem, restarting my router, checking if my laptop can connect to the internet through the modem (it can), and changing my router's WAN MAC address. No luck. At that point I get desperate and just thoroughly wipe the NVRAM through the GUI. Presto! Problem has been alleviated. Except, then the next time my router is rebooted, I have to do the exact same thing and re-enter all my config once again...

    Outlook:
    So, does anyone have any idea what might be promoting such a problem? I'm kind of out of ideas and my googling hasn't been very successful. Also, let me know if there is other information that you'd like to be shared.

    Any and all help is appreciated. Thanks :)
     
  2. dc361

    dc361 LI Guru Member

    What sorts of things are you putting into your config? Do you have a device on the network where you could get to a shell (or dos/command window)?

    The first thing that I'd try is to try rebooting the router after you wipe the config and verify that you can get to the internet... on toastman's builds the only thing you should have to enable is the DHCP server (or you could go with statics to test). Once you verify internet connectivity, then restart the router and make sure it is still ok.

    If it is .. add your configuration one 'setting' or group of settings at a time and re-test until it fails.
     
  3. Malitiacurt

    Malitiacurt Networkin' Nut Member


    Probably to best way to solve this issue yourself. Without knowing your settings, it's impossible to guess what's causing the issue. And even if you posted the settings, it's not guaranteed someone will know what's wrong.
     
  4. koitsu

    koitsu Network Guru Member

    When I read this problem report, my first thought was "this sounds related to someone screwing around with MAC addresses, particularly on the WAN interface". Then I read this line:

    Stop changing the router's WAN MAC.

    This is what's causing your problem. Use the stock default WAN MAC; do not use "Clone MAC" or any other feature, use whatever the stock/default is.

    If you say "my ISP only allows one MAC to be registered with them, so I have to clone the MAC or use the MAC address of the system I was connected to the cable modem with when I signed up with my ISP", then I will tell you to contact your ISP and have them remove the old MAC (permanently) and reprovision with your existing one (on the router).

    What's happening is that you're confusing the hell out of your cable modem, because there is a short period of time when rebooting a router where the WAN interface will answer with the stock default MAC address -- you have to understand that ARP is going on constantly -- and only after a little while (when the router firmware and settings are fully loaded, GUI available, etc.) will the "new" or "different" MAC address be applied to the WAN interface. However, most cable modems and ISPs (there is a symbiotic relationship here) will not pick up the MAC address change until ARP timeout is reached, during which time no packets will flow past the cable modem. And with some ISPs, they'll just blacklist/blackhole your packets (at the CMTS level, i.e. past your cable modem) until they see the "correct" MAC.

    So do the right thing: stop playing with the MAC address of the WAN interface on the router. Erase NVRAM (thorough), and do not touch that setting. If things don't work after the first time, you need to power-cycle your cable modem (really -- DO NOT soft reboot it, unplug it for a full 15-20 seconds (yes wait that long, you need to wait for capacitors to lose charge!), then plug it back in) and go from there. If after a power-cycle it STILL doesn't work, then call your ISP and bitch that their provisioning database is "locking" you to an old MAC that no longer applies to you. Tell them you bought a router and need to be reprovisioned.

    I hope this answers your question/dilemma.

    P.S. -- It really would have been nice if you'd have disclosed who the ISP is and what country you're in, because the behaviour varies per ISP and CMTS config.
     
  5. Monk E. Boy

    Monk E. Boy Network Guru Member

    Sometimes Tomato will actually default to the wrong MAC address though, which is why I always hit the default button to see if the MAC changes. Default, in all the cases I've witnessed, changes them to match the MAC addresses stickered to the router.

    Cable ISPs in particular are getting substantially more annoying about DHCP leases. To change MAC addresses with one of these ISPs the procedure is rather involved:
    1) Perform DHCP release on router for WAN port
    2) Disconnect router from modem (remove cat5 cable)
    3) Power off modem
    4) Adjust WAN MAC address on router
    5) Power on modem
    6) Wait for modem to boot
    7) Connect router to modem

    Ideally the MAC address shouldn't be a cloned or nonstandard value for reasons koitsu outlined.
     

Share This Page