1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Internet under Linux very slow, under WindowsXP fast

Discussion in 'HyperWRT Firmware' started by knight14th, Jun 11, 2005.

  1. knight14th

    knight14th Network Guru Member

    Hi,

    i have a stupid problem using my WRT54G as internet-gateway: under windows as client internet connection is as fast as it should be. But using Linux as client, internet is very slow. I've tested three different Linux clients - same behavior.
    Even a simple "ping" needs about 10s 'til the first package is send out. After this packages return with about 20ms.
    All clients are configured using wrt's buildin dhcpd. There is no difference between WLAN and LAN.

    Any hints?

    Thanks
     
  2. Mathias

    Mathias Network Guru Member

    Disable IPv6. Recent Linux distributions are configured for IPv6 by default these days. Most people don't have IPv6-aware routers yet, so the IPv6 address resolution has to timeout first before falling back to plain old IPv4. How you can disable IPv6, depends on your distribution. Normally, adding "alias net-pf-10 off" and "alias ipv6 off" to /etc/modules.conf fixes the problem.

    Of course, this problem could be something else entirely, so good luck hunting it down.
     
  3. knight14th

    knight14th Network Guru Member

    Thanks for that!

    I've never thougt, this could be a problem. Now after migrating to alchemy 1.0 (i was tired of changing configuration on all of the linux clients) everything is ok.

    Maybe HyperWRT will support IPv6 in the feature cause Alchemy seems to be a little bit buggy using wlan + wpa (it dropps connections from time to time)
     

Share This Page