1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

INTERNET WAN PORT -- DHCP -- external gateway problem

Discussion in 'Cisco/Linksys Wireless Routers' started by ketron82, Feb 19, 2007.

  1. ketron82

    ketron82 Network Guru Member

    I have simple problem with an external internet gateway.

    My configuration is:

    NETGEAR DG632 in Half-Bridge Mode ----> Wan Internet port of WRT54GS ----> PC Wired / Wireless in a large WiFi Network between mountain of central Italy

    The problem is simple but very difficult to resolve:

    1) if I connect directly the DG632 (half-bridge mode) to lan port of a Pc with windows xp......windows Xp in dhcp take the public xp with a external gateway and all work well:

    ip: 87.238.x.x
    gw: look that gateway that is external

    2) if I connect the DG632 (half bridge mode) to WAN port of WRT54GS (internet automatic configuration DHCP) I saw that the WRT take all the correct ip:
    ip: 87.238.x.x
    gw: look that gateway that is external
    but the problem is that internet not working. The Wrt make correctly the nat because it is on gateway mode. But if I go on telnet and type route I can saw that the gw is suppressed.

    So....I add manually a route and gw:
    route add default vlan1
    route add default gw
    in this way I can ping internet also for 5-6 seconds afther that the routes will suppressed.
    I do linux "ps" command and kill dhcpc application that could renew the route but the problem persist and route will be reset again.

    So....I set INTERNET STATIC IP but also the gw will be suppressed.

    I think that is a linux problem because googling I have saw that someone have had some problem with linux and half-bridge and bridge mode.

    Can someone help me???
    Many thanks By

    Patriarca Fabio
    Arce (FROSINONE)

Share This Page